LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-15-2003, 12:51 PM   #1
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Rep: Reputation: 30
Question samba


hey guys i just installed samba on my rh 7.2 server...i got both the deamons up and running...but i cant get to SWAT over the network with 192.168.1.100:901 (thats the correct ip)...smbd and nmbd are up...what did i do wrong...also i cant find my smb.conf ANYWHERE...its not in /etc/samba (i dont even have a samba in etc) or in /usr/local/samba/lib/....help...thanks
 
Old 05-15-2003, 12:57 PM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
If you don't have /etc/samba, I would reinstall samba. that is where your config file needs to be. RH default it there. I am not sure why it is not there.
 
Old 05-15-2003, 01:05 PM   #3
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Original Poster
Rep: Reputation: 30
hmm ok lemme try taht
 
Old 05-15-2003, 01:11 PM   #4
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Original Poster
Rep: Reputation: 30
ok i recompiled it and reinstalled this time i use make install > install.log.....so i searched thru the log and i found that it installed testparm...which lets me see where samba is looking for its .conf file...and it still couldnt find smb.conf
 
Old 05-15-2003, 01:15 PM   #5
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
Do you have /etc/samba?
 
Old 05-15-2003, 01:17 PM   #6
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Original Poster
Rep: Reputation: 30
nope
 
Old 05-15-2003, 01:23 PM   #7
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
Is there anything in /usr/local/samba/lib? In FreeBSD 4.2 you had to make a smb.conf file. I have a little how-to at http://www.valkyrie.net/~tangle/comp.../smb_conf.htm. You can just cut and past this and change the values to what you need. I would do this and see if it works.
 
Old 05-15-2003, 01:28 PM   #8
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Original Poster
Rep: Reputation: 30
hmm thanks
 
Old 05-15-2003, 01:33 PM   #9
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Original Poster
Rep: Reputation: 30
ok testparm OK'ed the file...going to reboot now..THANKS
 
Old 05-15-2003, 01:36 PM   #10
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
You don't have to reboot. Just type smbd restart and nmbd restart at the command line.
 
Old 05-15-2003, 01:38 PM   #11
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Original Poster
Rep: Reputation: 30
well i already rebooted....now how do i get swat working...i also changed the password dir to /etc/passwd
 
Old 05-15-2003, 01:42 PM   #12
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
Check out http://de.samba.org/samba/ftp/docs/h...s/swat.8.html.
 
Old 05-15-2003, 01:53 PM   #13
roofy
Member
 
Registered: Apr 2003
Location: Florida
Distribution: Redhat 7.2
Posts: 222

Original Poster
Rep: Reputation: 30
ok well i read the link and i did all that...created the file in xinetd.d and mapped the service in /etc/services....now how do i make xinetd call the swat file?
 
Old 05-15-2003, 02:23 PM   #14
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
If your /etc/xinet.d/swat (Ithink that is the location) then it should work. Make sure that server = is the path to the swat binary.

# description: SWAT is the Samba Web Admin Tool. Use swat \
# to configure your Samba server. To use SWAT, \
# connect to port 901 with your favorite web browser.
service swat
{
port = 901
socket_type = stream
wait = no
only_from = localhost
user = root
server = /usr/local/samba/swat
log_on_failure += USERID
disable = no
}
 
Old 05-15-2003, 05:14 PM   #15
KennyK
Member
 
Registered: Apr 2003
Location: California, USA
Distribution: Redhat 8.0, 9.0 Suse 9.0 Pro
Posts: 129

Rep: Reputation: 15
only_from = localhost

I think that this in your swat file will prevent you from accessing swat across the network.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba/Cups print sharing problems (/var/spool/samba files) Gates1026 Linux - General 9 06-23-2013 01:33 AM
Samba - Connecting from WinXP Pro to Samba running on Debian critical Linux - Networking 1 02-03-2005 09:36 AM
I need the content from thegoldenear.org/toolbox/unices/samba/samba-setup.html rtg2001 Linux - Networking 1 08-05-2004 05:54 PM
Samba: Authenticate Linux-Clients in Samba Domain & Mount mule Linux - Software 0 12-10-2003 01:21 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 05:54 AM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration