LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-16-2009, 10:10 PM   #1
brianpbarnes
Member
 
Registered: Dec 2005
Posts: 143

Rep: Reputation: 15
s2ram fails on suse 11.1, runlevel services powerd start returned 7


Hi,
I am trying to get s2ram working on Suse 11.1/64bit on an Asus P5Q3, P45 chipset, DDR3 motheboard. /usr/sbin/s2ram -f -a 3 crashes immediately requiring a power off to reboot. I waited thinking that it might be writing a hybernation file to disk, but after 2 minutes with zero disk activity, I turned the power off.

When I looked at the powerd in yast -> system services (runlevel), it shows that powerd is not running. When I try to start it, I get:
/etc/init.d/powerd start returned 7 (program is not running):

This is a brand new Suse install and it used to work on a previous install (before a software upgrade mangled X and a mondorestore cratered on restore). I reinstalled the kpowersave package with yast with no difference

root@godzilla2:/home/brianp# s2ram --test
Machine unknown
This machine can be identified by:
sys_vendor = "System manufacturer"
sys_product = "P5Q3 DELUXE"
sys_version = "System Version"
bios_version = "1306 "
See http://en.opensuse.org/S2ram for details. ...

The http://en.opensuse.org/S2ram page has been no help. The only file I have in /etc/pm/config.d is rtcwake.config.

The pm-suspend (which "is only useful for debugging and it would be good if you knew what you are doing when using this") appears to work, but only once. After that, it just shuts down the X server for 10 seconds, comes right back and takes my 3 TB, /r5 RAID array offline with I/O errors and so is not useful. I compiled and installed the patched driver from 3Ware for the RAID controller. See the first /var/log/pm-suspend.log file below.

How does one debug this? I will update the page with this solution when I finally get it figured out.

Thank you,
BrianP

================================================================
PM-SUSPEND.log:

brianp@godzilla2:~$ cat /var/log/pm-suspend.log
2009-04-16 21:24:12.780376723 -0500: running 'suspend'/'suspend'/'' hooks.
===== 2009-04-16 21:24:12.812286989 running hook: /usr/lib/pm-utils/sleep.d/00clear =====
===== 2009-04-16 21:24:12.825261466 running hook: /usr/lib/pm-utils/sleep.d/01logging =====
suspend initiated: Thu Apr 16 21:24:12 CDT 2009

Linux godzilla2 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
kernel command line: 'root=/dev/disk/by-id/ata-Hitachi_HUA721010KLA330_GTE005PBG81J2L-part1 resume=/dev/disk/by-id/ata-Hitachi_HUA721010KLA330_GTE005PBG81J2L-part3 splash=silent vga=0x375'
Module Size Used by
usb_storage 101072 0
st 38892 0
ide_disk 14872 0
ide_cd_mod 33984 0
nls_utf8 2160 1
ip6t_LOG 7180 7
xt_tcpudp 3608 2
xt_pkttype 2152 3
ipt_LOG 6812 8
xt_limit 3180 15
snd_pcm_oss 48896 0
snd_mixer_oss 16808 1 snd_pcm_oss
binfmt_misc 10260 1
snd_seq 61968 0
ip6t_REJECT 6024 3
nf_conntrack_ipv6 24840 4
ip6table_raw 2456 1
xt_NOTRACK 2152 4
ipt_REJECT 3480 3
xt_state 2568 8
iptable_raw 2760 1
iptable_filter 3400 1
ip6table_mangle 3128 0
nf_conntrack_netbios_ns 2840 0
nf_conntrack_ipv4 12792 4
nf_conntrack 80480 5 nf_conntrack_ipv6,xt_NOTRACK,xt_state,nf_conntrack_netbios_ns,nf_conntrack_ipv4
ip_tables 19464 2 iptable_raw,iptable_filter
ip6table_filter 3240 1
ip6_tables 21048 4 ip6t_LOG,ip6table_raw,ip6table_mangle,ip6table_filter
x_tables 23376 11 ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_NOTRACK,ipt_REJECT,xt_state,ip_tables, ip6_tables
ipv6 293608 27 ip6t_REJECT,nf_conntrack_ipv6,ip6table_mangle
fuse 61088 7
ext2 69688 1
loop 17924 0
dm_mod 73952 0
snd_hda_intel 545508 4
snd_usb_audio 97936 3
snd_usb_lib 18856 1 snd_usb_audio
snd_pcm 95440 3 snd_pcm_oss,snd_hda_intel,snd_usb_audio
snd_timer 26664 2 snd_seq,snd_pcm
snd_rawmidi 26768 1 snd_usb_lib
snd_seq_device 8604 2 snd_seq,snd_rawmidi
snd_page_alloc 9816 2 snd_hda_intel,snd_pcm
rtc_cmos 13960 0
snd_hwdep 9072 2 snd_hda_intel,snd_usb_audio
i2c_i801 12836 0
rtc_core 22420 1 rtc_cmos
ohci1394 31380 0
ieee1394 98880 1 ohci1394
sr_mod 16196 1
fglrx 2361576 30
snd 74632 25 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_hda_intel,snd_usb_audio,snd_usb_lib,snd_pcm,snd_timer,snd_rawm idi,snd_seq_device,snd_hwdep
serio_raw 6412 0
pcspkr 3064 0
rtc_lib 3560 1 rtc_core
i2c_core 35280 1 i2c_i801
joydev 12112 0
sky2 51116 0
button 8328 0
intel_agp 29936 0
skge 44016 0
soundcore 8816 1 snd
cdrom 36200 2 ide_cd_mod,sr_mod
floppy 63240 0
sg 35344 0
usbhid 52896 0
hid 41568 1 usbhid
ff_memless 8912 1 usbhid
ehci_hcd 55348 0
uhci_hcd 27928 0
sd_mod 35064 13
crc_t10dif 2152 1 sd_mod
usbcore 198656 7 usb_storage,snd_usb_audio,snd_usb_lib,usbhid,ehci_hcd,uhci_hcd
edd 10272 0
ext3 141912 4
mbcache 10412 2 ext2,ext3
jbd 68824 1 ext3
fan 6016 0
ide_pci_generic 4652 0
3w_9xxx 32516 1
ata_generic 6044 0
siimage 9304 0
ide_core 118012 4 ide_disk,ide_cd_mod,ide_pci_generic,siimage
pata_marvell 4824 0
pata_sil680 8140 1
ahci 34628 8
libata 183376 4 ata_generic,pata_marvell,pata_sil680,ahci
scsi_mod 179144 7 usb_storage,st,sr_mod,sg,sd_mod,3w_9xxx,libata
dock 14564 1 libata
thermal 24232 0
processor 49904 1 thermal
thermal_sys 14336 3 fan,thermal,processor
hwmon 4040 1 thermal_sys

total used free shared buffers cached
Mem: 4052484 1773776 2278708 0 114836 752064
-/+ buffers/cache: 906876 3145608
Swap: 17479896 12 17479884

===== 2009-04-16 21:24:12.842062309 running hook: /usr/lib/pm-utils/sleep.d/02rtcwake =====
rtcwake alarm not enabled in /etc/pm/config.d/rtcwake.config, doing nothing...
===== 2009-04-16 21:24:12.853760494 running hook: /usr/lib/pm-utils/sleep.d/05led =====
===== 2009-04-16 21:24:12.856954848 running hook: /usr/lib/pm-utils/sleep.d/06autofs =====
===== 2009-04-16 21:24:12.880048771 running hook: /usr/lib/pm-utils/sleep.d/10NetworkManager =====
Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
===== 2009-04-16 21:24:12.893197426 running hook: /usr/lib/pm-utils/sleep.d/30s2disk-check =====
===== 2009-04-16 21:24:12.896873726 running hook: /usr/lib/pm-utils/sleep.d/45pcmcia =====
===== 2009-04-16 21:24:12.900161915 running hook: /usr/lib/pm-utils/sleep.d/50modules =====
===== 2009-04-16 21:24:12.906038623 running hook: /usr/lib/pm-utils/sleep.d/80acpi-fan =====
===== 2009-04-16 21:24:12.909228989 running hook: /usr/lib/pm-utils/sleep.d/80videobios =====
===== 2009-04-16 21:24:12.912475836 running hook: /usr/lib/pm-utils/sleep.d/94cpufreq =====
===== 2009-04-16 21:24:12.921562884 running hook: /usr/lib/pm-utils/sleep.d/95led =====
===== 2009-04-16 21:24:12.924798834 running hook: /usr/lib/pm-utils/sleep.d/99Zgrub =====
===== 2009-04-16 21:24:12.928843584 running hook: /usr/lib/pm-utils/sleep.d/99info =====
2009-04-16 21:24:12.932043874: done running suspend/suspend hooks.
INFO: going to suspend. In case of problems with the selected suspend options,
INFO: please read /usr/share/doc/packages/pm-utils/README.smart-suspend-to-RAM
INFO: module fglrx is loaded, trusting it to restore video after resume.
+ /usr/sbin/s2ram --force
Switching from vt7 to vt1
fbcon fb0 state 1
fbcon fb0 state 0
switching back to vt7
+ RET=0
+ set +x
2009-04-16 21:25:01.985008390 -0500: running 'suspend'/'resume'/'reverse' hooks.
===== 2009-04-16 21:25:02.010853661 running hook: /usr/lib/pm-utils/sleep.d/99info =====
===== 2009-04-16 21:25:02.014142095 running hook: /usr/lib/pm-utils/sleep.d/99Zgrub =====
===== 2009-04-16 21:25:02.019972219 running hook: /usr/lib/pm-utils/sleep.d/95led =====
===== 2009-04-16 21:25:02.025326870 running hook: /usr/lib/pm-utils/sleep.d/94cpufreq =====
===== 2009-04-16 21:25:02.032360852 running hook: /usr/lib/pm-utils/sleep.d/80videobios =====
===== 2009-04-16 21:25:02.035534654 running hook: /usr/lib/pm-utils/sleep.d/80acpi-fan =====
===== 2009-04-16 21:25:02.038723249 running hook: /usr/lib/pm-utils/sleep.d/50modules =====
===== 2009-04-16 21:25:02.044291538 running hook: /usr/lib/pm-utils/sleep.d/45pcmcia =====
===== 2009-04-16 21:25:02.047314710 running hook: /usr/lib/pm-utils/sleep.d/30s2disk-check =====
===== 2009-04-16 21:25:02.050743288 running hook: /usr/lib/pm-utils/sleep.d/10NetworkManager =====
Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
===== 2009-04-16 21:25:02.059850743 running hook: /usr/lib/pm-utils/sleep.d/06autofs =====
===== 2009-04-16 21:25:02.065856309 running hook: /usr/lib/pm-utils/sleep.d/05led =====
===== 2009-04-16 21:25:02.068814016 running hook: /usr/lib/pm-utils/sleep.d/02rtcwake =====
===== 2009-04-16 21:25:02.072196670 running hook: /usr/lib/pm-utils/sleep.d/01logging =====
===== 2009-04-16 21:25:02.075232435 running hook: /usr/lib/pm-utils/sleep.d/00clear =====
2009-04-16 21:25:02.080715721: done running suspend/resume hooks.


brianp@godzilla2:~$ cat /etc/mtab
/dev/sdc1 / ext3 rw,acl,user_xattr 0 0
/proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sda4 /home ext3 rw 0 0
/dev/sdd1 /r5 ext3 rw 0 0
/dev/sdc2 /tera ext2 rw 0 0
/dev/sda2 /usys ext3 rw 0 0
/dev/sdb1 /windows/C fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/sdb5 /windows/D fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
securityfs /sys/kernel/security securityfs rw 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
gvfs-fuse-daemon /home/brianp/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=brianp 0 0
/dev/sr2 /var/adm/mount/AP_0x00000001 iso9660 ro 0 0


brianp@godzilla2:~$ sudo umount /dev/sdd1
root's password:
umount: /r5: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Services in runlevel don't start automatically tklima Linux - Server 5 12-12-2007 05:41 AM
Services not starting in runlevel 3 JesusAddict3791 Linux - Newbie 4 04-26-2005 12:49 AM
Start and stop services in SUSE - using shell UltimaGuy Linux - Newbie 3 02-16-2004 10:13 PM
Runlevel 5 default services pete_bogg Red Hat 7 10-31-2003 06:55 PM
some services down after a change of runlevel zovres Linux - Newbie 5 10-15-2003 07:48 PM


All times are GMT -5. The time now is 08:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration