LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-21-2013, 02:36 PM   #1
iLinux85
LQ Newbie
 
Registered: Mar 2010
Posts: 3

Rep: Reputation: 0
Running Mono on Centos 5 CLI


I have vps server (virtual private server) running on linux centos 5 32 bit , i installed vncserver x windows , gnome and kde environment and i connect to the vnc server from vncviewer in my windows 7 desktop

now i execute the command

Code:
mono Radegast.exe
in terminal and i got

Code:
[ERROR]: - Unhandled System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.XplatUI ---> System.ArgumentNullException: Could not open display (X-Server required. Check you DISPLAY environment variable)
    Parameter name: Display
      at System.Windows.Forms.XplatUIX11.SetDisplay (IntPtr display_handle) [0x00000]
      at System.Windows.Forms.XplatUIX11..ctor () [0x00000]
      at System.Windows.Forms.XplatUIX11.GetInstance () [0x00000]
      at System.Windows.Forms.XplatUI..cctor () [0x00000]
      --- End of inner exception stack trace ---
      at System.Windows.Forms.Application.EnableVisualStyles () [0x00000]
      at Radegast.MainProgram.RunRadegast (System.String[] args) [0x00000]
      at Radegast.MainProgram.Main (System.String[] args) [0x00000] : An exception was thrown by the type initializer for System.Windows.Forms.XplatUI
      at System.Windows.Forms.Application.EnableVisualStyles () [0x00000]
      at Radegast.MainProgram.RunRadegast (System.String[] args) [0x00000]
      at Radegast.MainProgram.Main (System.String[] args) [0x00000]
mono version is

# mono -V
Code:
Mono JIT compiler version 2.4.2.3 (tarball Sat Apr 20 19:49:33 MSD 2013)
Copyright (C) 2002-2008 Novell, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        GC:            Included Boehm (with typed GC)
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  x86
        Disabled:      none
Attached Images
File Type: png error.png (106.9 KB, 15 views)

Last edited by iLinux85; 04-21-2013 at 02:47 PM.
 
  


Reply

Tags
centos, mono, vnc, x11, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mono: error running custom app via mono on linux RH kirk5000 Linux - Software 4 06-15-2012 04:22 AM
[SOLVED] missing the mono.pc file CentOS Mortadelo bernardomh Linux - Newbie 7 01-11-2011 11:57 AM
Install Mono on CentOS 5.4 without blowing ISPConfig 3 gr33d Linux - Software 3 11-17-2009 09:17 PM
LXer: Running Mono - an Overview LXer Syndicated Linux News 0 10-29-2009 11:20 PM
Problems running Mono 1.0 in Mandrake 9.1 ernesto_cgf Programming 5 08-14-2004 07:36 AM


All times are GMT -5. The time now is 06:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration