LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-06-2003, 06:41 PM   #1
e0n
LQ Newbie
 
Registered: Mar 2003
Location: Canada
Distribution: gentoo
Posts: 21

Rep: Reputation: 15
Problems with running a deamon at boot time


For the past few hours i've been fooling around with Undernet's ircd. I can get everything to work fine, but the problem is i cant start the deamon as a superuser. At first it didnt bother me, but now i want to start the ircd at boot and it just doesnt want to start. What i want to know is 1- why cant the ircd be started with root, 2- is there a way to change this and if there isnt, how can i make the deamon start with a different user?

Thx in advance,

-Mat

Last edited by e0n; 05-06-2003 at 06:43 PM.
 
Old 05-06-2003, 07:00 PM   #2
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
are you starting it up in your startup scripts? Startup scripts are usually ran as root.

Secondly, where is it installed and who is the owner of the daemon (use the 'ls -l' command to check on that)

Alex
 
Old 05-06-2003, 07:07 PM   #3
e0n
LQ Newbie
 
Registered: Mar 2003
Location: Canada
Distribution: gentoo
Posts: 21

Original Poster
Rep: Reputation: 15
i start the ircd by placing a script in /etc/rc.d/init.d then creating a link to it in /etc/rc.d/rc5.d. i dont know if that's the proper way to do it, but it works for other services.

to awnser your 2nd question, i installed ircu in /usr/local/ircd and root is the owner but i used chmod o+x

i started another thread similar to this one because i couldnt edit this thread's subject. please respond in the other thread
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running setup.exe, but another already running? erisco Linux - Software 2 08-08-2005 06:45 PM
Any one running etheral? If so what OS are you running it with? abefroman Linux - Security 2 05-09-2005 02:22 PM
Process running but not running LinuxRam Linux - Newbie 13 12-29-2004 11:45 AM
any linux distro can running in RAM , not need CD_ROM reading when running. wangcity Linux - General 3 09-18-2003 06:45 AM
running samba worked, running it out of xinetd doesn't? system Linux - Networking 1 12-24-2001 04:15 AM


All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration