LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-16-2006, 07:01 PM   #1
cyb0rg777
Member
 
Registered: Dec 2004
Location: ~
Distribution: Debian
Posts: 143
Blog Entries: 8

Rep: Reputation: 15
RTAI on kernel 2.6.15


I'm trying to install RTAI 3.3 on a vector linux 4.3 system.
I am using kernel 2.6.15.1.
I have also tried kernel 2.6.15.2 and 2.6.15.4.
the kernel source is a fresh install.
I applied the patch hal-linux-2.6.15-i386-1.1-03.
I have also tried hal-linux-2.6.15-i386-1.2-00.
I'm really not sure which patch goes with which kernel so I tried them all
The problem is this.
After I apply the patch I go to menuconfig but The hal or adeos option is not there.
I think I have the hang of compiling the kernel .
I just reinstalled the source because I was having this problem.
 
Old 02-18-2006, 06:23 PM   #2
cyb0rg777
Member
 
Registered: Dec 2004
Location: ~
Distribution: Debian
Posts: 143
Blog Entries: 8

Original Poster
Rep: Reputation: 15
OK ,I found out from the mailing list that the rtai-3.3 uses the -ipipe option under general in the kernel setup.
I have my kernel and rtai compiled and installed but my modules are not loaded .
They are not in the directory with the rest of the modules.
Why did I need rtai again?
Oh yeah ,nanosecond timing.
Does anyone know why my modules are not loading?
Help on the subject seems to be scarce .
I really appreciate it.Thanks.
 
Old 02-19-2006, 02:35 AM   #3
cyb0rg777
Member
 
Registered: Dec 2004
Location: ~
Distribution: Debian
Posts: 143
Blog Entries: 8

Original Poster
Rep: Reputation: 15
OK ,I put my modules in /lib/modules/2.6.15.4 and restarted and it found them.
Now I'm having trouble running run and calibrate .
It says error loading module and junk like that.
Anybody?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RTAI kernel problem pgpython Linux From Scratch 11 08-02-2007 02:09 PM
Slack 10.2 Ker 2.6.8.1 RTAI 3.1 Blank screen Pier Slackware 4 11-06-2005 02:29 PM
RTAI Proramming mrgoodtrips Programming 0 04-14-2005 01:59 PM
How to uninstall a RTAI patch satish427 Linux - Newbie 1 09-28-2004 11:01 PM
RTAI Installation problems saintt Linux - Software 0 10-31-2001 05:19 AM


All times are GMT -5. The time now is 03:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration