LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-07-2012, 08:58 PM   #1
luthfi.imanal
LQ Newbie
 
Registered: Oct 2012
Posts: 3

Rep: Reputation: Disabled
rsh (rexec) failed


Hi.

I have new cluster machine. Running OpenSuSE 11.2 with rsh and rsh-server version 0.17-708.2.

I have no problem on running rlogin. the nodes can rlogin to each other without prompting passwords.

But rexec giving me this error.
Code:
poll: protocol failure in circuit setup
this is the /var/log/messages on the receiving node.
Code:
Oct  8 08:53:04 lapanhpc1 in.rshd[8235]: connect from 192.168.200.2 (192.168.200.2)
Oct  8 08:53:04 lapanhpc1 kernel: [ 4076.025328] in.rshd[8235] trap stack segment ip:2b1fe8916860 sp:c0007fff5d7e5320 error:0
Thanks.
 
Old 10-08-2012, 03:44 PM   #2
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
It sounds like you have a firewall issue or something in /etc/hosts.deny that is blocking the communication.

--C
 
Old 10-08-2012, 07:50 PM   #3
luthfi.imanal
LQ Newbie
 
Registered: Oct 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
i haven't touch the /etc/hosts.deny

here is my /etc/hosts.deny

Code:
admin@lapaninf1:~> cat /etc/hosts.deny
# /etc/hosts.deny
# See 'man tcpd' and 'man 5 hosts_access' as well as /etc/hosts.allow
# for a detailed description.

http-rman : ALL EXCEPT LOCAL
thx for fast response

Last edited by luthfi.imanal; 10-08-2012 at 07:51 PM.
 
Old 10-09-2012, 11:49 AM   #4
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
Quote:
Originally Posted by luthfi.imanal View Post
i haven't touch the /etc/hosts.deny

here is my /etc/hosts.deny

Code:
admin@lapaninf1:~> cat /etc/hosts.deny
# /etc/hosts.deny
# See 'man tcpd' and 'man 5 hosts_access' as well as /etc/hosts.allow
# for a detailed description.

http-rman : ALL EXCEPT LOCAL
thx for fast response
Is your firewall on? Check to see if you're allowing the proper ports

--C
 
Old 10-09-2012, 10:06 PM   #5
luthfi.imanal
LQ Newbie
 
Registered: Oct 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
No. My firewall is off. I don't know the problem until now. Reinstall the OS with SLES 11 SP2 and all system works now.

Thanks for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disabling rexec, rsh, rlogin, and rcp on Debian moerobins Linux - Server 3 09-04-2012 12:33 PM
rsh failed : poll: protocol failure in circuit setup fender_gr Red Hat 1 04-02-2008 05:16 AM
rsh problem - PAM authentication failed for in.rlogind davey123 Linux - Security 0 12-05-2005 11:24 AM
RSH: remuser too long error when rsh is executed from IIS dev33445 Programming 0 08-29-2005 09:34 AM
Trying to get rexec to work. When incoming rexec, linux host responds 'Where are you krulr Red Hat 1 09-12-2003 10:20 AM


All times are GMT -5. The time now is 05:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration