LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-24-2010, 07:04 PM   #1
Darrell22
Member
 
Registered: Nov 2003
Posts: 62

Rep: Reputation: 15
Question rpmbuild: ./libtool: line 1015: -e: command not found


rpmbuild: ./libtool: line 1015: -e: command not found


Dear Experts,

As part of a solution here:
http://oracle-magician.blogspot.com/...nd-tricks.html

I'm trying to create a binary RPM from a SRC.RPM file.

I'm running Redhat 5.

cat /etc/redhat-release
Enterprise Linux Enterprise Linux Server release 5.2 (Carthage)

uname -a
Linux blue.gateway.2wire.net 2.6.18-92.el5PAE #1 SMP Fri May 23 22:26:05 EDT 2008 i686 i686 i386 GNU/Linux

I managed to find the source package I need:
compat-db-4.1.25-9.src.rpm

But I'm getting this error as part of
the build process:

./libtool: line 1015: -e: command not found

Does anyone know the secret to get
it to work?

Please see more detail in the following notes.

Thanks a lot!


pwd
/tmp/compat-db-4.1.25-9.i386

ls -l
total 5928
-rwxr-xr-x 1 root root 6057917 Jan 24 15:54 compat-db-4.1.25-9.src.rpm


rpm -ivh compat-db-4.1.25-9.src.rpm

warning: compat-db-4.1.25-9.src.rpm: Header V3 DSA signature: NOKEY, key ID db42a60e
1:compat-db ########################################### [100%]



cd /usr/src/redhat/SPECS
ls -lrt
total 16
-rw-rw-r-- 1 root root 13052 Nov 30 2004 compat-db.spec



rpmbuild -bb compat-db.spec

.....

+ soversion=3.3
+ make libdb=libdb-3.3.a libcxx=libdb_cxx-3.3.a
/bin/sh ./libtool --mode=compile cc -c -I. -I./../include -I./../include_auto -D_GNU_SOURCE -D_REENTRANT -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables ../mutex/mut_pthread.c
./libtool: line 320: s,^.*/,,g: No such file or directory
./libtool: line 705: -e: command not found
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require --mode=MODE be specified.
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1015: -e: command not found
./libtool: line 1043: -e: command not found
./libtool: line 1067: -e: command not found
: compile: cannot determine name of library object from `'
make: *** [mut_pthread.lo] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.52354 (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.52354 (%build)


which libtool
/usr/bin/libtool

rpm -qa | grep -i "libtool"
libtool-ltdl-1.5.22-6.1
libtool-1.5.22-6.1
 
Old 01-25-2010, 01:15 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,536

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
/home/<user>/rpms/BUILD/compat-db-4.1.25/ :

A file 'libtool', not usable ? in EL5 only ?
is created from
compat-db-4.1.25/db-3.3.11/dist/aclocal/libtool.ac
→ → →
compat-db-4.1.25/db-3.3.11/dist/libtool
Anyway, it fails.
( And by the way, /usr/bin/libtool cannot replace it.)


But why in the fist place try to build a package,
you don't want to install ?
You can just plug out the files you need from the rpm :
compat-db-4.1.25-9.i386.rpm
http://ftp.scientificlinux.org/linux....25-9.i386.rpm
( http://ftp.scientificlinux.org/linux.../i386/SL/RPMS/ )

Unpack with :
rpm2cpio compat-db-4.1.25-9.i386.rpm | cpio-idmv
.....
 
  


Reply

Tags
libtool, rpmbuild


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't rebuild RPM - rpmbuild command not found defa0009 Linux - Newbie 11 12-10-2007 06:35 AM
sh: line 1: gs: command not found notooth Linux - Software 16 04-29-2005 08:34 PM
rpmbuild: command not found ltt19 Linux - Software 7 11-28-2004 12:34 PM
rpmbuild: command not found zebra5 Linux - Software 3 10-08-2003 02:31 PM
rpmbuild-command not found arnold_it Linux - Software 4 08-11-2003 08:54 AM


All times are GMT -5. The time now is 11:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration