LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-15-2003, 10:31 PM   #1
init-5
Member
 
Registered: Sep 2003
Location: SJ
Distribution: RHL 9, Solaris 9
Posts: 41

Rep: Reputation: 15
rpm --rebuilddb error


when i try to do a -

rpm --rebuilddb

i get this error -

error: db4 error(16) from dbenv->remove: Device or resource busy

does anybody know the reason? and the solution?

thanks
 
Old 09-15-2003, 10:34 PM   #2
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
sounds like you've got something running in there
what distribution do you have?

ehd

 
Old 09-15-2003, 10:35 PM   #3
init-5
Member
 
Registered: Sep 2003
Location: SJ
Distribution: RHL 9, Solaris 9
Posts: 41

Original Poster
Rep: Reputation: 15
RHL 9
 
Old 09-15-2003, 10:48 PM   #4
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
Quote:
--querybynumber HDRNUM
Query the HDRNUMth database entry directly; this is useful only
for debugging.
[QUOTE]REBUILD DATABASE OPTIONS
The general form of an rpm rebuild database command is

rpm {--initdb|--rebuilddb} [-v] [--dbpath DIRECTORY] [--root DIRECTORY]




from the man rpm file

check it out may help

ehd



Last edited by ehdwuld; 09-15-2003 at 10:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Segment violation in "rpm --rebuilddb" jromero_arg Linux - Enterprise 1 06-30-2004 09:10 AM
Corrupted rpmdb - --rebuilddb not working ugge Linux - Software 5 12-28-2003 06:12 PM
rpm error only says"rpm: relocation error: rpm: undefined symbol: poptAliasOptions" dlrsims Linux - Newbie 2 11-14-2003 09:22 PM
"rpm --rebuilddb" fails to error. Tommi Linux - General 3 05-04-2003 12:40 AM
# rpm --rebuilddb -- Segmentation fault russell Linux - Software 4 08-14-2001 02:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration