LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-23-2003, 02:15 AM   #1
kelper
Member
 
Registered: Jan 2003
Posts: 77

Rep: Reputation: 15
Question RPM of php installation


Server: redhat 7.3
I have installed apache_1.3.27.i386.rpm and then i
install php4.2.3-8.i386.rpm.
The error message is below:

[root@localhost home]# rpm -ivh php-common-4.2.3-8.i386.rpm php-4.2.3-8.i386.rpm
error: failed dependencies:
apache(EAPI) < 2.0.0 is needed by php-4.2.3-8
apache(EAPI) >= 1.3.9 is needed by php-4.2.3-8

How to solve it
THX
 
Old 01-23-2003, 06:29 AM   #2
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
You have apache_1.3.27
The php rpm needs >= 1.3.9
Solution:
Upgrade apache to a version >= 1.3.9 but < 2.0.0
 
Old 01-23-2003, 08:22 AM   #3
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Quote:
Originally posted by iceman47
You have apache_1.3.27
The php rpm needs >= 1.3.9
Solution:
Upgrade apache to a version >= 1.3.9 but < 2.0.0
Is not 1.3.27 greater than 1.3.9????

The problem is elsewhere. Try and find a newer version of php, the current version is 4.3.0, and a newer version may cooperate with apache better. Give www.rpmfind.net a search.
 
Old 01-23-2003, 11:03 AM   #4
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
Quote:
Originally posted by bulliver
Is not 1.3.27 greater than 1.3.9????
What was I thinking
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i make my own php rpm? Ratclaws Linux - Newbie 1 12-02-2005 09:07 PM
How to add options in php.in after installation of PHP? touqeeransar Linux - Software 1 11-30-2005 05:52 AM
Searching PHP RPM?!?!!?!! djkoe Linux - Newbie 1 12-29-2003 11:03 AM
php-4.2.4 RPM RH 9.0 Blackrose_1100 Red Hat 0 11-18-2003 04:54 PM
RPM of php problem kelper Linux - General 4 02-26-2003 05:47 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration