LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-21-2006, 06:59 AM   #1
TrupsT
LQ Newbie
 
Registered: Aug 2006
Posts: 5

Rep: Reputation: 0
Rpm installation gives segmentation fault


I have installed gvidcap on Fedora using
rpm -ivh gvidcap-1.1.3-fc1.i386.rpm

This had resulted into some dependencies so I got them installed before installing this package.

After doing this gvidcap got smoothely installed.
But now when I try to run the application, it is crashing with a segmentation fault.

Plz help.
 
Old 08-21-2006, 08:20 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,718
Blog Entries: 54

Rep: Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967
But now when I try to run the application, it is crashing with a segmentation fault.
If the package and all the dependencies installed without errors then open up a terminal window and type the command to start the application. If it doesn't start but shows you errors then you have something to search LQ, the Gvidcap FAQ (http://www.jarre-de-the.net/faq/inde...on=show&cat=4), mailinglist and bugtracker for. If it doesn't start but also doesn't show you errors then you need to run it like "strace -v -o/tmp/gvidcap.strace command". Now you have the file /tmp/gvidcap.strace to read (last few lines) and check LQ, the Gvidcap FAQ (http://www.jarre-de-the.net/faq/inde...on=show&cat=4), mailinglist and bugtracker for. If that doesn't yield any results you could post your question to the development list or maintainer or post the first three and last ten lines here.
 
Old 08-22-2006, 09:55 AM   #3
TrupsT
LQ Newbie
 
Registered: Aug 2006
Posts: 5

Original Poster
Rep: Reputation: 0
When I type the command xvidcap on the prompt, it starts well.

When I give verbose option it prints the following data.
But when I click on the capture video button, it crashes with segmentation fault.(This is also visible down.) A file of 0 bytes also gets created on the root called testmovie-0.mpeg

[root@cdeep-6 ~]# xvidcap -v
job.job_set_file(): Original dimensions: 192 * 144
job.job_set_file(): Original dimensions: 192 * 144
control.InitControl(): Original dimensions: 192 * 144
Current settings:
frames per second = 25.000000
video encoding = MPEG4
file pattern = testmovie-%0d.mpeg
verbose level = 1
frames to store = 0
time to capture = 20.000000 sec
autocontinue = yes
compression level = 0
quality (jpeg) = 75
input source = shm (16)
capture pointer = none
capture audio = no
- input = /dev/audio
- sample rate = 8000
- bit rate = 8
- channels = 1
animate command = animate "%s" -delay %d &
make video command= ppm2mpeg "%s" %d %d %d %d %f %d &
edit frame command= display "%s" &
help command = MANPATH=/usr/local/X11/man rxvt -e man xvidcap &
Segmentation fault
[root@cdeep-6 ~]#
 
Old 08-22-2006, 11:21 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,718
Blog Entries: 54

Rep: Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967
But when I click on the capture video button, it crashes with segmentation fault.
Looks like that is in the FAQ I pointed you to. See if this (After installation from RPM gvidcap crashes on recording) helps solve your problem: http://www.jarre-de-the.net/faq/inde...=18&artlang=en
 
  


Reply

Tags
fault, installation, rpm, segmentation fault


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation fault while running RPM KaruppuSwamy.T Linux - General 5 12-03-2004 06:56 AM
rpm -anything gives Segmentation Fault dtashima Red Hat 8 12-02-2004 11:21 AM
RPM segmentation fault gaurava99 Linux - Software 1 07-16-2004 09:34 AM
Segmentation fault using RPM janisj Linux - General 3 05-11-2004 08:35 AM
# rpm --rebuilddb -- Segmentation fault russell Linux - Software 4 08-14-2001 03:39 AM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration