LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-03-2003, 12:05 AM   #1
Cher
LQ Newbie
 
Registered: Feb 2003
Location: Northern Canada
Distribution: Mandrake 9.2/Fedora10
Posts: 8

Rep: Reputation: 0
RPM Install has quit working on RH8


I just tried to install something on RH8, and the installer for RPM's isn't working, any ideas?


Any help will be so appreciated *S*

Cher
 
Old 03-03-2003, 05:20 AM   #2
hpk_hpk2
LQ Newbie
 
Registered: Feb 2003
Location: india
Posts: 6

Rep: Reputation: 0
i think it is so simple just use following command

rpm -ihv <file name>
 
Old 03-03-2003, 08:46 AM   #3
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Did you try to use the GUI installer or did you try to install from a command prompt? Sometimes if an rpm install gets killed before completing you can get whats known as lock files in your rpm database. This will cause rpm to not work correctly. To solve the problem you can delete the existing rpm database and then rebuild it. To do that you would do:

rpm -v /var/lib/rpm/__db*
rpm --rebuilddb
 
Old 03-03-2003, 09:52 AM   #4
bandit12
LQ Newbie
 
Registered: Feb 2003
Location: Bristol UK (53rd State of America)
Distribution: RH 8 Gnome / KDE
Posts: 22

Rep: Reputation: 15
if you need a list of RPM commands try here

http://www.rpm.org/max-rpm/
 
Old 03-03-2003, 09:21 PM   #5
gamera2_00
LQ Newbie
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 7

Rep: Reputation: 0
It sounds like what you're experencing is an RPM bug that has been around for a while. If it locks up, and won't continue, start a new instance, or quit, then you're seeing this bug.

The first instance of this bug:
http://bugzilla.redhat.com/bugzilla/...g.cgi?id=63342

To fix this problem, read through this page, and try the unoffical version.

http://www.rpm.org/hintskinks/repairdb/

Hope that helps!

-Gamera2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
my printer quit working? shanenin Linux - Hardware 3 12-21-2003 02:23 PM
Sound mysteriously quit (RH8) MagicTom Linux - General 25 06-17-2003 09:16 AM
in what package can i install the stock IDENTD rpm in RH8? kublador Linux - Software 1 06-11-2003 05:53 AM
Newbie on Apache and PHP rpm install on RH8 1beagle Linux - General 5 03-11-2003 06:54 PM
New install RH8 - 3Com Card not working. prix92 Linux - Networking 3 01-14-2003 04:21 PM


All times are GMT -5. The time now is 11:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration