LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-03-2005, 01:55 AM   #1
mrtumnus
LQ Newbie
 
Registered: Mar 2005
Location: The Fens, UK
Distribution: Fedora Core 1
Posts: 4

Rep: Reputation: 0
rpm failed dependancy for a file that exists


I'm trying to install mplayer-gui-1.0pre6-1.i386.rpm, and I keep getting the error message:

error: Failed dependencies:
libmp3lame.so.0 is needed for mplayer-gui-1.0pre6-1

The odd thing is I've already installed libmp3lame.so.0. The system knows it is there in /usr/local/lib. Am I missing something, or does this rpm only look for this file in a mystery, unknown location? Is there a way I can find out where it is looking and put a link file in there?

Ta.
 
Old 03-03-2005, 02:31 AM   #2
saneax
Member
 
Registered: Aug 2004
Distribution: Gentoo, Suse, Fedora, Debian
Posts: 86

Rep: Reputation: 15
HI,
most probably the libmp3lame.so.0 that you have is in /usr/local/lib, however its searching for the same under /usr/lib... try to make a link under /usr/lib...
and it seems you have installed lame from source... install it from RPM and then try
 
Old 03-03-2005, 02:39 AM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
If you install packages from source, rpm does not know that they are installed. You can force the installatin if you know you have the right dependencies installed, but you are better off installing dependencies in rpm format.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed dependancy even though its there steveman2000 Linux - Newbie 2 10-23-2005 12:19 PM
rpm dependancy problems chow-stl Mandriva 5 01-16-2005 08:21 PM
SIOCADDRT: File exists SIOCCADDRT: File Exists Failed to bring up eth0. opsraja Linux - Networking 0 01-10-2005 08:29 AM
rpm dependancy nearfar Programming 1 01-27-2004 06:53 PM
apt - failed dependancy: linux-kernel-headers shack Linux - Software 0 12-19-2003 08:09 AM


All times are GMT -5. The time now is 12:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration