LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-10-2003, 11:45 AM   #1
cmpaul
LQ Newbie
 
Registered: Aug 2003
Location: Castle Rock, CO
Distribution: RedHat 9
Posts: 4

Rep: Reputation: 0
RPM Dependency Question


I'm attempting to install a few random packages and have run into a dependency problem that's confusing me.

First, I attempt to install this guy:
# rpm -Uvh libltdl-1.4.2-12.i686.rpm
warning: libltdl-1.4.2-12.i686.rpm: V3 DSA signature: NOKEY, key ID f9651d5a
error: Failed dependencies:
libtool-libs = 1.4.3-5 is needed by (installed) libtool-1.4.3-5

So, I try to install what it says it needs:
# rpm -Uvh libtool-libs-1.4.3-5.i386.rpm
Preparing... ########################################### [100%]
package libtool-libs-1.4.3-5 is already installed

Any ideas?
 
Old 08-10-2003, 12:57 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,575

Rep: Reputation: 184Reputation: 184
It sounds like your rpm database is messed up a little. I would try:
rpm --rebuilddb
and see if that cleans up the problem.

Another possible solution is to try to only clean up libtool-libs:
# rpm -Uvh libtool-libs-1.4.3-5.i386.rpm --force
 
Old 08-10-2003, 01:40 PM   #3
cmpaul
LQ Newbie
 
Registered: Aug 2003
Location: Castle Rock, CO
Distribution: RedHat 9
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the quick reply.

Neither of those suggestions worked. When I attempt to rebuild the database, I receive this message:

# rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy

(Before this, I also removed the __db* files from /var/lib/rpm.)

When I attempt cleaning up libtool-libs, it installs fine, but I still receive the original dependency error for libltdl:

# rpm -Uvh libltdl-1.4.2-12.i686.rpm
warning: libltdl-1.4.2-12.i686.rpm: V3 DSA signature: NOKEY, key ID f9651d5a
error: Failed dependencies:
libtool-libs = 1.4.3-5 is needed by (installed) libtool-1.4.3-5

Thanks again for any help you can provide.
 
Old 08-10-2003, 01:54 PM   #4
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,575

Rep: Reputation: 184Reputation: 184
-------------------------------------------------------------------------
# rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy
-------------------------------------------------------------------------

Maybe you have a lock file that was not deleted when it should have been.
 
Old 08-13-2003, 07:16 PM   #5
chrismiceli
Member
 
Registered: Aug 2002
Posts: 349

Rep: Reputation: 31
won't you just have to install that devel package?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
building rpm dependency question Neruocomp Red Hat 2 09-14-2005 10:50 PM
RPM dependency UltraSoul Linux - Software 9 07-09-2005 02:14 PM
RPM dependency help (apt 4 rpm) Cubsy Linux - Software 4 10-08-2004 05:15 PM
RPM dependency question tarballed Linux - Software 5 05-13-2003 12:11 PM
Help : rpm dependency error when install video driver rpm ymdwxm Linux - Software 1 04-04-2003 05:55 PM


All times are GMT -5. The time now is 07:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration