LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-01-2006, 02:37 AM   #1
Musikolo
Member
 
Registered: Jul 2003
Distribution: Yoper 2.91 beta (kernel 2.6.15)
Posts: 114

Rep: Reputation: 15
RPM build fails


Hi folks, I'm trying to buld a RPM package for HPLIP, but I have an issue when the system is looking for the Requires dependencies. I've looked into it but I haven't found any help at all. Thus, I hope you can give a hand to fix this error:

Code:
...etc.

+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-static-archive
+ /usr/lib/rpm/brp-strip-comment-note
+ /usr/lib/rpm/yoperfixes.sh
Using external helpers to list the dependencies ...
Stripping files ...
Removing Libtool Archives
warning: File listed twice: hplip-1.6.10.tar.gz
Processing files: hplip-1.6.10-1
Finding  Provides: /usr/lib/rpm/find-provides
Finding  Requires: /usr/lib/rpm/find-requires
error: line 76: Dependency "" must begin with alpha-numeric, '_' or '/': """
/bin/bash
/usr/bin/env
/usr/bin/perl
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libcups.so.2
libdl.so.2
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libgcc_s.so.1
libgcc_s.so.1(GCC_3.0)
libhpip.so.0
libjpeg.so.62
libm.so.6
libm.so.6(GLIBC_2.0)
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libstdc++.so.6
libstdc++.so.6(GLIBCXX_3.4)
libusb-0.1.so.4
perl(Cwd)
perl(Data::Dumper)
perl(IO::Handle)
perl(POSIX)
perl(sigtrap)
perl(strict)

error: Failed to find Requires:
Provides: cupsext.so libhpip.so.0 libsane-hpaio.so.1 pcardext.so
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(post): /bin/sh
Requires(postun): /bin/sh
Requires: /bin/sh /bin/sh rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/hplip-buildroot
Wrote: /usr/src/yoper/SRPMS/hplip-1.6.10-1.src.rpm
Wrote: /usr/src/yoper/RPMS/hplip-1.6.10-1.i686.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.53291
+ umask 022
+ cd /usr/src/yoper/BUILD
+ cd hplip-1.6.10
+ rm -rf /usr/src/yoper/BUILD/hplip-1.6.10
+ rm -rf /var/tmp/hplip-buildroot
+ exit 0
The configure, make and make install do their work fine, but it's at the end when I get the above error. Although the exit code is 0, you can see some lines above that a couple of errors are thrown.

I hope you can shed some light on this issue, because I really need after many days trying to sort it out on my own. Any help will be really appreciated!

Thanks in advance.
 
Old 11-01-2006, 06:18 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,305
Blog Entries: 54

Rep: Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857
error: line 76: Dependency "" must begin with alpha-numeric, '_' or '/': """
What does "grep ^[B,R].*equires: /your/specfile.spec" return?
 
Old 11-01-2006, 06:25 AM   #3
Musikolo
Member
 
Registered: Jul 2003
Distribution: Yoper 2.91 beta (kernel 2.6.15)
Posts: 114

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by unSpawn
error: line 76: Dependency "" must begin with alpha-numeric, '_' or '/': """
What does "grep ^[B,R].*equires: /your/specfile.spec" return?
Code:
mach@Yoper ~/SPECS $ grep ^[B,R].*equires: hplip.spec
BuildRequires:  gcc libusb-devel cups-devel python-devel libjpeg-devel chkconfig ghostscript-cups qt-devel pyqt
I hope this helps to find out what's going on...
 
Old 11-01-2006, 06:56 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,305
Blog Entries: 54

Rep: Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857
No, it doesn't. The BuildRequires line looks sane to me. Could be an error in one of the rpm scripts because it tells you about a dependency called "" (empty). Since you do have the RPM's you should decide if you want to pursue this or if you (if you didn't edit the spec file or .src.rpm or tarball) just want to add a bugtrack item for the packages maintainer. If you want to pursue this then I'd like a download location URI for the .src.rpm or tarball (and the specfile: if you edited it).
 
Old 11-01-2006, 10:04 AM   #5
Musikolo
Member
 
Registered: Jul 2003
Distribution: Yoper 2.91 beta (kernel 2.6.15)
Posts: 114

Original Poster
Rep: Reputation: 15
Well, here you have all you need, I hope: http://88.198.41.209/build/yoper-3.0...er_3.0_alpha_/

I don't think it's a bug in the source, although I don't discard it fully. I'll try to build an older version, just for the sake of trying something different.

Thanks again for you help!
 
Old 11-01-2006, 11:46 AM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,305
Blog Entries: 54

Rep: Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857
Hmm. I've looked around a bit and most of the error messages are about not filling variables of the "%{?term:} type" which you should handle doing "rpmbuild --define term x y". Now the .spec file you posted has several lines commented out so I'm wondering if it is exactly the one from the RPM or your own local modified copy. If it is you best post a diff between them.
 
Old 11-27-2006, 08:43 AM   #7
lordtweety
Member
 
Registered: Mar 2004
Location: Sydney
Distribution: Yoper 3.0
Posts: 87

Rep: Reputation: 15
Hi Musikolo,

I will try and build it using your spec file and see if I get the same problem.
 
Old 11-27-2006, 05:37 PM   #8
lordtweety
Member
 
Registered: Mar 2004
Location: Sydney
Distribution: Yoper 3.0
Posts: 87

Rep: Reputation: 15
Well, I definitely found the same issue

I've had a look over the rpmbuild scripts we use and can't see anything that could be causing it other than an issue with hplip itself.

I'll confirm that as I work it out more.

Last edited by lordtweety; 11-27-2006 at 05:38 PM.
 
Old 06-13-2007, 11:55 AM   #9
drkchaudhry
LQ Newbie
 
Registered: Jun 2007
Posts: 1

Rep: Reputation: 0
hplip dependencies

Going through the forums, I feel linux users should not use hp products or hp users should not use linux. Running linux puppy I have been denied printing for a week.
1. sh python
displays
Python 2.4(#1, Jun 13, 2007....)
hplip says DEPENDENCY PYTHON DEVEL MISSING
2. lsb-sdk 3.1.1-5 installed with rpm
hplip says DEPENDENCY LSB MISSING
Why do HP people not specify version and provide link to a source?
Dr K Chaudhry
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
klibido fails to build hedpe Linux - Software 0 06-14-2006 10:27 AM
pymedia fails to build shanenin Programming 0 07-29-2005 03:26 PM
cannot build source rpm/ rpm questions kpachopoulos Fedora 3 07-24-2005 09:15 AM
anaconda build from src rpm fails LampMan Fedora 3 03-28-2005 02:55 AM
'make' fails while trying to build jonnycarlos Linux - Software 0 04-29-2004 09:14 PM


All times are GMT -5. The time now is 01:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration