LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   ros installation error (http://www.linuxquestions.org/questions/linux-software-2/ros-installation-error-928025/)

vpriya 02-07-2012 12:45 AM

ros installation error
 
i tried to install ros in ubuntu 10.04 lucid but when i gave command i got following error:

sudo apt-get install ros-electric-desktop-full

Reading package lists... Done
Building dependency tree * * *
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ros-electric-desktop-full: Depends: ros-electric-slam-gmapping (= 1.2.5-s1326424166~lucid) but it is not going to be installed
Depends: ros-electric-perception-pcl (= 1.0.2-s1323553637~lucid) but it is not going to be installed
Depends: ros-electric-simulator-gazebo (= 1.4.10-s1326937730~lucid) but it is not going to be installed
Depends: ros-electric-navigation (= 1.6.5-s1323562415~lucid) but it is not going to be installed
E: Broken packages

----

again when I tried to install from the source for the setup command :

“sudo apt-get install build-essential python-yaml cmake subversion wget python-setuptools mercurial git-core”

I got the following error:

Errors were encountered while processing:
/var/cache/apt/archives/xz-utils_4.999.9beta+20091116-1_i386.deb
/var/cache/apt/archives/patch_2.6-2ubuntu1_i386.deb
/var/cache/apt/archives/dpkg-dev_1.15.5.6ubuntu4.5_all.deb
/var/cache/apt/archives/build-essential_11.4build1_i386.deb
/var/cache/apt/archives/dkms_2.1.1.2-2ubuntu1_all.deb
/var/cache/apt/archives/fakeroot_1.14.4-1ubuntu1_i386.deb
/var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu5_i386.deb
/var/cache/apt/archives/fglrx-amdcccle_2%3a8.723.1-0ubuntu5_i386.deb
/var/cache/apt/archives/liberror-perl_0.17-1_all.deb
/var/cache/apt/archives/libdigest-sha1-perl_2.12-1build1_i386.deb
/var/cache/apt/archives/git-core_1%3a1.7.0.4-1ubuntu0.2_i386.deb
/var/cache/apt/archives/libboost1.42-dev_1.42.0-3~lucid1_i386.deb
/var/cache/apt/archives/libboost-dev_1.42.0.1~lucid1_i386.deb
/var/cache/apt/archives/libboost-serialization1.42-dev_1.42.0-3~lucid1_i386.deb
/var/cache/apt/archives/libboost-date-time1.42-dev_1.42.0-3~lucid1_i386.deb
/var/E: Sub-process /usr/bin/dpkg returned an error code (1)

what should I do?

barunparichha 02-07-2012 12:53 AM

Looks like:
you are not able to connect to your repository.
Are you able to access system->administration->synoptic package manager to install package ?

or
check if apt-get install <package> is working for other packages. If not you need to configure for apt-get.

vpriya 02-10-2012 12:38 AM

yes i'm not able to install any package how should i configure


All times are GMT -5. The time now is 01:18 PM.