LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2003, 11:16 AM   #1
phatcher
LQ Newbie
 
Registered: Aug 2003
Posts: 9

Rep: Reputation: 0
RH8 apt-get KDE 3.1.2 install error


Using apt-get to install the newest version of KDE on RH8. When it tries to install, I get the following error:
####START######
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
alsa-lib arts kdebase kdelibs libmad qt redhat-artwork redhat-logos
redhat-menus themer
The following packages will be upgraded
arts kdebase kdelibs qt redhat-artwork redhat-logos redhat-menus
The following NEW packages will be installed:
alsa-lib kde libmad themer
7 packages upgraded, 4 newly installed, 0 removed and 139 not upgraded.
Need to get 0B/48.1MB of archives.
After unpacking 16.2MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Executing RPM (-Uvh)...
warning: /var/cache/apt/archives/alsa-lib_0.9.6-1.fr_i386.rpm: V3 DSA signature:
NOKEY, key ID e42d547b
warning: /var/cache/apt/archives/themer_0%3a1.06-0.fdr.0_noarch.rpm: V3 DSA sign
ature: NOKEY, key ID ff6382fa
Preparing... ########################################### [100%]
file /usr/share/themes/Default from install of redhat-artwork-0.81-0.fdr
.0.rh80 conflicts with file from package gtk+-1.2.10-22
file /usr/share/themes/Default from install of redhat-artwork-0.81-0.fdr
.0.rh80 conflicts with file from package gtk2-2.0.6-8
E: Sub-process /bin/rpm returned an error code (18)
######END######

So I thought maybe the gtk+ package was out of date. So I tried to apt-get gtk+ and received the following error:

####START######
warning: /var/cache/apt/archives/gtk+_1%3a1.2.10-25.fdr.4.rh80_i386.rpm: V3 DSA signature: NOKEY, key ID ff6382fa
error: Failed dependencies:
gtk+ = 1.2.10 is needed by (installed) gtk+-devel-1.2.10-22
E: Sub-process /bin/rpm returned an error code (1)
####END#####

Any clues?
TIA
Patrick
 
Old 09-28-2003, 12:24 PM   #2
danny_kurniawan
Member
 
Registered: Jul 2003
Location: Surabaya - East Java, Indonesia
Distribution: Red Hat, Mandrake, Debian, Knoppix
Posts: 57

Rep: Reputation: 15
you should uninstall gtk+devel first, then do upgrade new gtk+, after it, you can install new gtk+devel
 
Old 09-28-2003, 01:16 PM   #3
phatcher
LQ Newbie
 
Registered: Aug 2003
Posts: 9

Original Poster
Rep: Reputation: 0
thanks! THis was a great learning experience. I had to remove a few of the RPMS (redhat-artwork,gtk2, and gtk+) but I finally got it installed.
Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Install problems with Synaptic/Apt-Get hauger Debian 4 08-05-2005 11:18 AM
need help again (kde broken after apt-get install) rafc Debian 5 06-09-2004 02:06 PM
apt-get ERROR during install gnome 2.4 ..:eMa:.. Debian 1 05-06-2004 06:00 PM
Is a KDE Install Possible Using apt-get in sarge? anlace Debian 2 12-28-2003 12:55 AM
Can I install KDE 3.1 on RH8? phatcher Linux - Software 2 09-28-2003 10:10 AM


All times are GMT -5. The time now is 04:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration