LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-10-2003, 05:21 PM   #1
fcuku
LQ Newbie
 
Registered: Feb 2003
Location: Reading, England
Posts: 7

Rep: Reputation: 0
Unhappy RH8.0 and GeForce 4 4200


Hi,

I am having problems installing the NVIDIA drivers I have followed the advice given in a previous posting but get the following error when I "make install"

Get the tar's from www.nvidia.com:
http://download.nvidia.com/XFree86_...1.0-4191.tar.gz
http://download.nvidia.com/XFree86_...1.0-4191.tar.gz
untar both
-tar -zxvf NVIDIA_kernel-1.0-4191.tar.gz
-tar -zxvf NVIDIA_GLX-1.0-4191.tar.gz
cd into NVIDIA_kernel-1.0-4191
su and make install
cd into NVIDIA_GLX-1.0-4191
make install
add nvidia to /etc/modules
echo nvidia >> /etc/modules
Edit your XF86Config (/etc/X11/XF86Config) file and change:
- Driver "nv" or Driver "vesa" into Driver "nvidia"
Add in the 'Module' section:
-Load "glx"
and remove (if those exist):
Load "dri"
Load "GLcore"

The error I get is

[root@fcuku NVIDIA_kernel-1.0-4191]# make install

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1


I have the latest kernel patch from RH and gcc is 3.2

Any help is appreciated,

Thanks.
 
Old 03-10-2003, 05:37 PM   #2
Palin
Member
 
Registered: Feb 2003
Location: A Meatlocker, well feels like one
Distribution: Gentoo
Posts: 292

Rep: Reputation: 30
Is there a reason you aren't using the RH 8 packages to install the drivers?
 
Old 03-10-2003, 09:21 PM   #3
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Do "export IGNORE_CC_MISMATCH" then "make install".
 
Old 03-11-2003, 05:54 PM   #4
fcuku
LQ Newbie
 
Registered: Feb 2003
Location: Reading, England
Posts: 7

Original Poster
Rep: Reputation: 0
Hi,

I downloaded the RPMs and followed the instructions but have now come unstuck when I reboot the machine and run startx. It bombs out and there are two errors in the logfile, I put the XF86Config file back to what it was and rebooted and then started x-server but that now bombs out as well, something about glx_extensions.

Any ideas?

Thanks.
 
Old 03-11-2003, 06:03 PM   #5
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
What changes did you make to your XF86Config?
 
Old 03-12-2003, 06:30 AM   #6
nivek
LQ Newbie
 
Registered: Mar 2003
Posts: 9

Rep: Reputation: 0
DL this ftp://download1.nvidia.com/XFree86_4...1/NVchooser.sh
cd to the dir u put NVchooser
then sh NVchooser.sh

For me
$ sh NVchooser.sh

Please download and install the following files:
NVIDIA_kernel-1.0-4191.rh80up.athlon.rpm
NVIDIA_GLX-1.0-4191.i386.rpm

so i dl this 2 rpm, but the version should be different from u.


make sure u have the right driver for u gf card
after u got the right drivers then read this

http://download.nvidia.com/XFree86_40/1.0-4191/README

make sure u read it carfully cos there is some important detils about the XF86Config

Pace
nivek

Last edited by nivek; 03-12-2003 at 06:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia GeForce 4200 Go Problem Please Help! surfdog88 Fedora 2 02-22-2005 05:21 AM
MSI GeForce 4 Ti 4200 Not being seen with SuSE 9.1 Sandfury Linux - Hardware 0 05-08-2004 07:59 AM
GeForce 4 Ti 4200 and Mandrake 9.1 vitalis70 Linux - Newbie 14 11-11-2003 03:49 AM
GeForce 4 Ti 4200 and Mandrake 9.1 vitalis70 Linux - Software 3 11-04-2003 05:56 AM
Geforce Ti 4200 sutho1 Linux - Hardware 3 10-01-2003 09:15 PM


All times are GMT -5. The time now is 03:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration