LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-11-2003, 12:24 AM   #1
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
RH 9 Hangs When Starting X


Both upgrade from 8.0 and clean install of RH 9.0 in a Compaq laptop give me the following symptom:
When starting X and before the login prompts appears, the system seems to hang with the Alpha, Num & Scoll Lock LEDs flashing. The login is delayed for anywhere from 10 to 60 seconds. Many times, the cursor will not respond to the steering stick and I have to CTRL-ALT-ESC to restart the process of delay & flashing LEDs.

I can find nothing in the logs. I tried several different monitor types, including a generic 1024x768 laptop screen with no change. As you can imagine, this is very frustrating. Any suggestions for tracking down the problem?

TIA.
 
Old 05-11-2003, 01:24 AM   #2
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
Re: RH 9 Hangs When Starting X

Quote:
Originally posted by 2Gnu
Both upgrade from 8.0 and clean install of RH 9.0 in a Compaq laptop give me the following symptom:
When starting X and before the login prompts appears, the system seems to hang with the Alpha, Num & Scoll Lock LEDs flashing. The login is delayed for anywhere from 10 to 60 seconds. Many times, the cursor will not respond to the steering stick and I have to CTRL-ALT-ESC to restart the process of delay & flashing LEDs.

I can find nothing in the logs. I tried several different monitor types, including a generic 1024x768 laptop screen with no change. As you can imagine, this is very frustrating. Any suggestions for tracking down the problem?

TIA.
give your computer's specification
 
Old 05-11-2003, 05:44 PM   #3
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Original Poster
Rep: Reputation: 49
Compaq Armada M700, PIII - 850, 256M, 20GB dual boot w/W2K.
This is the best link I could find for the specs.
http://www.digit-life.com/articles/compaqarmadam700/
 
Old 05-13-2003, 02:09 AM   #4
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
Quote:
Originally posted by 2Gnu
Compaq Armada M700, PIII - 850, 256M, 20GB dual boot w/W2K.
This is the best link I could find for the specs.
http://www.digit-life.com/articles/compaqarmadam700/
First ,your specs and the specs from the link is different.
Does your Video: ATI Rage Mobility P AGP has conflicts/sharing of IRQ.In win2k :Start->Programs->Accessories->System Tools->System Information.Click on Hardware and on conflicts/sharing.You may have to change the settings from the bios too.
 
Old 05-13-2003, 01:16 PM   #5
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Original Poster
Rep: Reputation: 49
Thank you for the reply, but I'm confused by it.
Specs: There are several different variations of the M700, particularly the CPU clock speed. The ATI graphics chipset is, I think, the same for all.
Conflicts: There are a number of devices showing as 11 in the conflict/sharing list, but the have different assignments in the IRQ list.
BIOS: It's a Compaq. The only BIOS options are boot slowly or really slowly. OK, exaggeration, but there's not much granularity there.
If all is well under W2K and was OK under RH 8, what the heck could be hanging it up at the start of X with 9?
 
Old 05-15-2003, 04:25 AM   #6
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
Quote:
Originally posted by 2Gnu
Thank you for the reply, but I'm confused by it.
Specs: There are several different variations of the M700, particularly the CPU clock speed. The ATI graphics chipset is, I think, the same for all.
Conflicts: There are a number of devices showing as 11 in the conflict/sharing list, but the have different assignments in the IRQ list.
BIOS: It's a Compaq. The only BIOS options are boot slowly or really slowly. OK, exaggeration, but there's not much granularity there.
If all is well under W2K and was OK under RH 8, what the heck could be hanging it up at the start of X with 9?
My initial assumption was that: due to IRQ sharing a component is not working.It is a common problem and many systems I have seen
has a mutually exclusive working of modems and sound cards.The iomem part of the driver is usually responsible for this.
This means that at one time you may have to use either the modem or the soundcard(in your case X or maybe sound).
If your BIOS does not control IRQ management usually the error gets solved by the OS.
Or as if in my computers' case when logging out of X don't use sound(or whatever).This prevents the computer from crashing.
check
/proc/iomem
and
/proc/ioports

Last edited by rch; 05-15-2003 at 04:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HP ze4300 hangs starting pcmcia csalisbury Linux - Laptop and Netbook 7 10-26-2005 10:48 AM
install hangs without even starting Alan_MacDougall Mandriva 2 10-14-2004 07:41 PM
Bootup hangs during 'Starting sshd:' Arodef Fedora 3 09-24-2004 11:48 PM
Can't log into X-Windows - It just hangs after starting TCv1 Linux - General 5 05-15-2004 11:10 PM
'Starting sendmail' hangs liguorir Linux - Software 10 07-22-2003 05:39 PM


All times are GMT -5. The time now is 03:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration