LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   RH 9 Hangs When Starting X (http://www.linuxquestions.org/questions/linux-software-2/rh-9-hangs-when-starting-x-59158/)

2Gnu 05-11-2003 01:24 AM

RH 9 Hangs When Starting X
 
Both upgrade from 8.0 and clean install of RH 9.0 in a Compaq laptop give me the following symptom:
When starting X and before the login prompts appears, the system seems to hang with the Alpha, Num & Scoll Lock LEDs flashing. The login is delayed for anywhere from 10 to 60 seconds. Many times, the cursor will not respond to the steering stick and I have to CTRL-ALT-ESC to restart the process of delay & flashing LEDs.

I can find nothing in the logs. I tried several different monitor types, including a generic 1024x768 laptop screen with no change. As you can imagine, this is very frustrating. Any suggestions for tracking down the problem?

TIA.

rch 05-11-2003 02:24 AM

Re: RH 9 Hangs When Starting X
 
Quote:

Originally posted by 2Gnu
Both upgrade from 8.0 and clean install of RH 9.0 in a Compaq laptop give me the following symptom:
When starting X and before the login prompts appears, the system seems to hang with the Alpha, Num & Scoll Lock LEDs flashing. The login is delayed for anywhere from 10 to 60 seconds. Many times, the cursor will not respond to the steering stick and I have to CTRL-ALT-ESC to restart the process of delay & flashing LEDs.

I can find nothing in the logs. I tried several different monitor types, including a generic 1024x768 laptop screen with no change. As you can imagine, this is very frustrating. Any suggestions for tracking down the problem?

TIA.

give your computer's specification

2Gnu 05-11-2003 06:44 PM

Compaq Armada M700, PIII - 850, 256M, 20GB dual boot w/W2K.
This is the best link I could find for the specs.
http://www.digit-life.com/articles/compaqarmadam700/

rch 05-13-2003 03:09 AM

Quote:

Originally posted by 2Gnu
Compaq Armada M700, PIII - 850, 256M, 20GB dual boot w/W2K.
This is the best link I could find for the specs.
http://www.digit-life.com/articles/compaqarmadam700/

First ,your specs and the specs from the link is different.
Does your Video: ATI Rage Mobility P AGP has conflicts/sharing of IRQ.In win2k :Start->Programs->Accessories->System Tools->System Information.Click on Hardware and on conflicts/sharing.You may have to change the settings from the bios too.

2Gnu 05-13-2003 02:16 PM

Thank you for the reply, but I'm confused by it.
Specs: There are several different variations of the M700, particularly the CPU clock speed. The ATI graphics chipset is, I think, the same for all.
Conflicts: There are a number of devices showing as 11 in the conflict/sharing list, but the have different assignments in the IRQ list.
BIOS: It's a Compaq. The only BIOS options are boot slowly or really slowly. OK, exaggeration, but there's not much granularity there.
If all is well under W2K and was OK under RH 8, what the heck could be hanging it up at the start of X with 9?

rch 05-15-2003 05:25 AM

Quote:

Originally posted by 2Gnu
Thank you for the reply, but I'm confused by it.
Specs: There are several different variations of the M700, particularly the CPU clock speed. The ATI graphics chipset is, I think, the same for all.
Conflicts: There are a number of devices showing as 11 in the conflict/sharing list, but the have different assignments in the IRQ list.
BIOS: It's a Compaq. The only BIOS options are boot slowly or really slowly. OK, exaggeration, but there's not much granularity there.
If all is well under W2K and was OK under RH 8, what the heck could be hanging it up at the start of X with 9?

My initial assumption was that: due to IRQ sharing a component is not working.It is a common problem and many systems I have seen
has a mutually exclusive working of modems and sound cards.The iomem part of the driver is usually responsible for this.
This means that at one time you may have to use either the modem or the soundcard(in your case X or maybe sound).
If your BIOS does not control IRQ management usually the error gets solved by the OS.
Or as if in my computers' case when logging out of X don't use sound(or whatever).This prevents the computer from crashing.
check
/proc/iomem
and
/proc/ioports


All times are GMT -5. The time now is 07:06 PM.