LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-28-2009, 09:47 AM   #1
balu.phanee
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
review board with svn integration not working on centos 5.3


hi ,
i have problem with review board on centos 5.3 with svn.
procedure i followd

$rb-site install /svn/review/review.ocv.com

Domain Name: review.ocv.com
Root Path [/]: /svn/review-board/
Media URL [media/]:
(1) mysql
Database Type: 1
Database Name [reviewboard]: reviewboard
Database Server [localhost]: localhost
Database Username: bugs
Database Password: bugs

(1) memcached
(2) file
Cache Type: 1
Memcache Server [memcached://localhost:11211/]: memcached://192.168.2.61:63000/
(1) apache
(2) lighttpd
Web Server: 1
(1) modpython
(2) fastcgi
Python Loader: 1
Username [admin]:root
Password: linux123
E-Mail Address: abc@def.com

cp /svn/review-board/review.ocv.com/conf/apache-modpython.conf /etc/httpd/conf.d/.

vi /svn/review-board/review.ocv.com/conf/settings_local.py
add
----------------
#Disable user registration. Only admin can register new users.
BUILTIN_AUTH = False
#Require log-in to view any part of ReviewBoard
REQUIRE_SITEWIDE_LOGIN = True
------------------------------

/etc/init.d/memcached restart

/svn/review-board/review.ocv.com/conf/settings_local.py
/usr/lib/python2.4/site-packages/Django-1.0.2_final-py2.4.egg/django/conf/project_template/manage.py help

Django
http://www.djangoproject.com

We are using svn version of Django framework:

$ svn co http://code.djangoproject.com/svn/django/trunk django_src
$ cd django_src
# python setup.py install


#python
>>> import MySQLdb
>>>MySQLdb.connect(db='reviewboard', user='bugs', passwd='bu')

---------------------
installed pysvn-1.7.0.tar.gz

and reviews.ocv.com.conf in /etc/httpd/conf.d
------------------------
<VirtualHost *>
ServerName review.ocv.com
DocumentRoot "/svn/review-board/review.ocv.com/htdocs"

# Error handlers
ErrorDocument 500 /errordocs/500.html

# Serve django pages
<Location "/">
PythonPath "['/svn/review-board/review.ocv.com/conf'] + sys.path"
SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
SetEnv PYTHON_EGG_CACHE "/svn/review-board/review.ocv.com/tmp/egg_cache"
SetHandler mod_python
PythonHandler django.core.handlers.modpython
PythonAutoReload Off
PythonDebug Off
# Used to run multiple mod_python sites in the same apache
PythonInterpreter reviewboard_review_ocv_com
</Location>

# Serve static media without running it through mod_python
# (overrides the above)
<Location "/media">
SetHandler None
</Location>
<Location "/errordocs">
SetHandler None
</Location>

<Directory "/svn/review-board/review.ocv.com/htdocs">
AllowOverride All
</Directory>

# Alias static media requests to filesystem
Alias /media "/svn/review-board/review.ocv.com/htdocs/media"
Alias /errordocs "/svn/review-board/review.ocv.com/htdocs/errordocs"
</VirtualHost>
--------------------------------------------

now in url i enterd http://192.168.2.21/svn/review-board/review.ocv.com/


page is getting all options are there and iam able to login but it it is giving "the page your looking for doesn't exit".

and i am not able to add svn.

i followed admin and repository add and asking bellow information
Name: first_pro ---->it is in /svn/svn_repos/first_pro
Path:/svn/svn_repos/first_pro
Mirror path:
Repository Type: selected subversion in drop down list
Bug tracker URL:http://192.168.2.21/bugzilla
This should be the path to the bug tracker for this repository. You must include '%s' in place of the bug number.

it is saying added but iam not able to see code.
and page also total test iam getting not as shown in screenshots
and bottom it is giving loading... after waiting some time also nothing is coming.
i added one test user as entered as a admin. but test user not able to login it is saying username or password is wrong

help me iam very new to this last 2 day i sit on this and ??? nothing went out
help me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
copy svn working dir without svn hidden dirs and files? erinspice Linux - Software 4 03-29-2011 05:58 PM
LXer: DistroWatch Weekly: Fedora 8 review, openSUSE Board, paldo GNU/Linux LXer Syndicated Linux News 0 11-12-2007 05:00 AM
SVN compile issues - centos 5 64bit neocontrol Linux - Server 1 11-06-2007 11:07 AM
LXer: Book review: SpamAssassin - A Practical Guide to Integration and Configuration LXer Syndicated Linux News 0 08-31-2006 02:03 AM


All times are GMT -5. The time now is 03:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration