LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-16-2004, 04:07 AM   #1
xslider
LQ Newbie
 
Registered: Dec 2004
Posts: 4

Rep: Reputation: 0
Reverting to (slow) indirect rendering IGP 340M


Hello all,

First off, this is a great place for a newbie to learn things. Although there are some rude comments now and then made by some users, but it's scorned by many, and that's why I think this is such a great place.

My problem is that everytime I restart the computer, the permission of /dev/dri/card0 is reset, and only root can use direct rendering. To be able to use direct rendering, I would have to su and chmod 0666 to card0, so that the normal user gets access to it. I do have the line "Mode 0666" in my xorg.conf (shown below).

glxgears output:
----------------------------
Without direct rendering: 220 FPS
With direct rendering: 480 FPS (Is this still slow for direct rendering?)
----------------------------

Besides that, here are my computer specs:
Laptop Compaq Presario 2596US
Video card: Radeon IGP 340M
Slackware 10.0
Xorg version 6.8.1
Kernel build 2.6.9
Fluxbox 0.9.11

glxinfo output:
------------------
libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
display: :0 screen: 0
direct rendering: No
-------------------


/var/log/Xorg.0.log
------------------
(II) RADEON(0): [drm] installed DRM signal handler
(II) RADEON(0): [DRI] installation complete
(II) RADEON(0): [drm] Added 32 65536 byte vertex/indirect buffers
(II) RADEON(0): [drm] Mapped 32 vertex/indirect buffers
(II) RADEON(0): [drm] dma control initialized, using IRQ 10
(II) RADEON(0): [drm] Initialized kernel GART heap manager, 5111808
(II) RADEON(0): Direct rendering enabled
--------------------


/etc/X11/xorg.conf
---------------------
Load "glx"
Load "GLcore"
Load "dri"

Section "DRI"
Mode 0666
EndSection
---------------------

I have read a lot about this problem, but everyone was able to fix it by adding that last few lines into their xorg.conf file, but even after adding them, I am still not able to set the appropriate permission to /dev/dri/card0. Is anyone familiar with this problem? This is the first time posting ever, so, I may have missed some crucial information.

I would like to be able to have the permissions set straight from the start, it gets quite annoying to su and change the permission on it every single time I start the computer.

By the way, those with the IGP 340M, is ~480 FPS good or bad?


Thank you,
A.K.
 
Old 12-17-2004, 08:28 PM   #2
bm17
Member
 
Registered: Sep 2004
Location: Santa Cruz, CA, USA
Distribution: Redhat 9.0
Posts: 104

Rep: Reputation: 15
Three things that may or may not help:
1) Just before "Mode 0666" I have the line "Group 0".
2) My /dev/dri/card0 always comes up as "crw-rw-rw-" (which is 0666).
3) 480 FPS is a bit lame for a modern card, but I am not familiar with the IGP 340M. Bear in mind that the X.org-supplied 3D dri driver is not the greatest and it renders in software mode more than it needs to. I get 880fps with a Radeon Mobility FireGL 7800. You might want to consider using the proprietary drivers available for linux from the ATI site.
 
Old 12-18-2004, 04:21 PM   #3
xslider
LQ Newbie
 
Registered: Dec 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by bm17
Three things that may or may not help:
1) Just before "Mode 0666" I have the line "Group 0".
2) My /dev/dri/card0 always comes up as "crw-rw-rw-" (which is 0666).
3) 480 FPS is a bit lame for a modern card, but I am not familiar with the IGP 340M. Bear in mind that the X.org-supplied 3D dri driver is not the greatest and it renders in software mode more than it needs to. I get 880fps with a Radeon Mobility FireGL 7800. You might want to consider using the proprietary drivers available for linux from the ATI site.
bm17, thank you for your reply, but still no luck! My xorg.conf looks like this at the end now:

Section "DRI"
Group 0
Mode 0666
EndSection

and still
$ls -al /dev/dri/card0
crw-rw---- 1 root video 226, 0 2004-12-18 14:11 /dev/dri/card0

I tried to download the radeo driver from http://dri.freedesktop.org/snapshots/ and still no luck. It is still around ~480 FPS. Does anyone else have a clue as to why the permission isn't set correctly?

Thank you,
xslider

[edit]
I figured that I have the IGP 345M card instead of the 340M, the 345M doesn't have any open source drivers, maybe I'm wrong? Hence, I'm only getting ~480 FPS
[/edit]

Last edited by xslider; 12-18-2004 at 04:33 PM.
 
Old 12-19-2004, 09:08 AM   #4
tripmix
Member
 
Registered: Nov 2004
Location: Norway
Distribution: Debian mostly
Posts: 106

Rep: Reputation: 16
ATI has no drivers for your card, but Xorg do. I'm getting 3000 +\- a few hundred whit the same card.

This is an outtake of my xorg.conf (should be what you need)

Section "Module"
Load "synaptics"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "pex5"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xie"
Load "extmod"
Load "fbdevhw"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Device"
Option "backingstore" "true"
#Option "sw_cursor"
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
Option "ShadowFB"
Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
Driver "ati"
# Driver "radeon"
VendorName "ATI"
BoardName "Radeon Mobility U2"
VideoRam 65536
BusID "PCI:01:05:0"
Option "AGPMode" "4"
Option "DPMS"
Option "AGPFastWrite" "on"
Option "EnablePageFlip" "on"
EndSection

Hope this helps.
 
Old 12-20-2004, 12:18 AM   #5
xslider
LQ Newbie
 
Registered: Dec 2004
Posts: 4

Original Poster
Rep: Reputation: 0
tripmix, thank you for the reply. Before going on any further, I would like to mention that you have duplicate Load extmod in your xorg.conf file.

Well, I figured out why the permission's reset everytime, and that's because I didn't have DRI built into my kernel. So, I just enabled DRI into my kernel, recompiled and the permission is fine and dandy. On the other hand, I am rather surprised at the fact that you are getting around 3000 +/- FPS with the IGP 345M. I tried changing my Driver line from Driver "radeon" to Driver "ATI" like you have it, but it doesn't work for me, it gives me an error something to the effect of "No Module found".

tripmix, what is the video depth that you are running to get ~3000 FPS? What's your computer specs, if that makes any differences.

I just changed my Video Depth (Default Depth) to 24, and now I am getting even worse FPS, it's only around 400. Although, in my /var/log/Xorg.0.log, I have this error, does anyone know how to fix this?

(EE) RADEON(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons

I recompiled my kernel with:

Device Drivers --> Graphics Support:[*] Support for framebuffer devices[*] ATI Radeon display support

Restarted the computer, and it gave me really whacky screen. The words were blurry, looks like the pixels were jumbled up, and nothing is readable.

Thanks everyone for helping,
xslider
 
Old 12-20-2004, 02:19 AM   #6
tripmix
Member
 
Registered: Nov 2004
Location: Norway
Distribution: Debian mostly
Posts: 106

Rep: Reputation: 16
Thanks for the headsup on the extmod.
My video settings are depth 24 res 1024x768
Specs: cpu 2.5ghz whit 500mb ram. Running Debian Sarge on 2.6.9 kernel.
I compiled the kernel whit framebuffer to and never got that error.
Did you compile whit I2O device support and VGA 16-color graphics suport, I was told you needed that for the framebuffer.
You need the ATI drivers in the kernel for the Xorg ATI drivers to work.
I am having some problems whit 3D to. I only get 3000 when my cpu is free, and if I start moving the mouse around it goes down to like 1000 fast. And anything that uses 3d has a nanosecond skip about once a second.
I tried running glxgears now whit alot of other stuff running and I only get 350. Have no idea how to fix this, but I will keep searching.
 
Old 12-20-2004, 06:01 AM   #7
tripmix
Member
 
Registered: Nov 2004
Location: Norway
Distribution: Debian mostly
Posts: 106

Rep: Reputation: 16
Hi, is me again. Tought I would clear out the cpu some more so I booted to blackbox (I usaly use kde 3.2), now all my glx stuff runs fine whitout any skipping. I don't have anything that is very intensive, biggest thing I have run is NeverWinterNights. I have to tone down some of the effects there and it still has a sligth mouse deleay.
In blackbox I get the same output from glxgears as you, I'm even more cunfused now....
 
Old 12-21-2004, 07:08 AM   #8
xslider
LQ Newbie
 
Registered: Dec 2004
Posts: 4

Original Poster
Rep: Reputation: 0
tripmix,

Sorry for the late replies, I have a ton of other things to tend to, and I just haven't gotten the time to do them all. Well, that is really odd to have the numbers change like that. Are you sure you are reading the right output?

In glxgears, the first number is the number of frames shown in 5.0 seconds, the second number is the number of frames per second. My first numbers are ranging roughly around 2000 frames. I tried switching back to KDE, and I am getting roughly the same numbers, if not a little bit less.

And when you said I2O, did you mean I2C? I did both, but none seem to work, but the framebuffer choice in the kernel said to use I2C.

Hope I am making sense,
xslider
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No 3D accel ATI RADEON IGP 340M SUSe 9.3 mconroy Linux - Laptop and Netbook 1 09-18-2005 12:27 PM
ATI Radeon IGP 340M 3d acceleration cedar Libranet 27 05-29-2005 06:23 PM
DISCUSSION: 3D acceleration on an ATI IGP 340M scoob_e LinuxAnswers Discussion 13 05-26-2005 03:41 PM
problem with MPlayer using ATI IGP 340m peevee Linux - Laptop and Netbook 1 12-07-2004 06:41 PM
3D support on an ATI IGP 340m!!! scoob_e LinuxQuestions.org Member Success Stories 5 06-22-2004 01:05 AM


All times are GMT -5. The time now is 10:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration