LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-12-2005, 01:32 AM   #1
gauntalus
Member
 
Registered: May 2004
Location: Hillsdale, MI
Distribution: gentoo 2004.3
Posts: 135

Rep: Reputation: 15
Question [RESOLVED] Resolution Problems


I've been trying to bump my resolution up to 1600x1200, but anytime I raise it above 1280x1024 I start getting artifacts... I've attachted a picture to illustrate my dilemma, but does anyone have any idea why I'm having these problems?

**edit** removed link to protect some aol screennames :-D

As you can see the screen try's to keep rolling over, the screenshot doesn't look exactly as it looks on my screen however... On my screen there is some light blue static lookin' stuff on the right side of the screen, and many things don't appear as they should.

Last edited by gauntalus; 01-12-2005 at 05:34 PM.
 
Old 01-12-2005, 10:17 AM   #2
gauntalus
Member
 
Registered: May 2004
Location: Hillsdale, MI
Distribution: gentoo 2004.3
Posts: 135

Original Poster
Rep: Reputation: 15
**bump** could this have something to do with the drivers that I'm using? I don't even know where to find this info. sorry, im a
 
Old 01-12-2005, 11:31 AM   #3
sludink
Member
 
Registered: Jan 2005
Location: Brabant, the Netherlands
Distribution: Gentoo 2004.x (2.6.10 hardened)
Posts: 91

Rep: Reputation: 15
Now, this could be many things...

First, try the following keypresses:

Ctrl+Alt+Num -
(whith num - I mean the minus sign at the numeric keypad)
or Ctrl+Alt+Num +
This changes the resolution. + changes it forth, - changes it back, like the back and forward buttons in your browser. See if you find a nice one.

If you didn't:

I don't know very well, but I'll give some suggestions:

Get a term, or a prompt. xterm is fine, but at least bash or sh or csh. Doesn't botter much which.
Then at the prompt, type:
$ cd /etc
$ ls -F X*
Pay attention to the capitals! They're very important!
Now, you should see one of the following:

(Edited later: I noticed you use gentoo 2004.3. So do I. The file I mention below should be located in gentoo in the directory /etc/X11, and then XFree86.conf or xorg.conf. XFree86 isn't supported by gentoo anymore, so I don't think you use this one)

- A file called xorg.conf or XFree86.conf
If it's xorg.conf, you're using xorg, if its XFree86, you're using XFree86. This is the 'graphical part' of your linux installation.
It could also be you don't see this files, but see a dir called someting like X11 or X11R6. Then a / is displayed after the name, which means it's a directory.
Then you should type
$ cd X11
or
$ cd X11R6
and again
$ ls
and now you should see the .conf files

another,maybe simpler way is:
$ find /etc -iname "x*.conf"

Now, I hope you found the file called XFree86.conf or xorg.conf.
This is the graphical configuration file X (graphical part of linux distro) used for display settings.

Open it with a text editor. If you don't know how exactly, try:

$ nano xorg.conf

Now we're getting somewhere.

In nano, you can search using control-w

Common problems are:

- xorg problems, xorg is the new successor of X, and sometimes gives problems. Many people complain. If this is the problem, you could try to install the old XFree86 (downgrade). Much work most of the times.

- font-server problems. Don't know much about this. But my fonts still look a bit ugly. Don't think this is the problem. Do:
$ cd /usr/share/fonts/; ls
and you get some fonts listed. Mine are:


100dpi (TTF) (cyrillic) (freefont) local (sgi-fonts) (util)
75dpi Type1 (dustismo) (jmk) misc sharefonts (vc)
(CID) (alee-fonts) encodings (lfpfonts-fix) (ms) (ukr)
Speedo (artwiz) fonts.cache-1 (lfpfonts-var) (ormaxx) (urw-fonts)
(Intsalled some myself, especially the ones between the () signs)
In xorg.conf / XFree86.conf, the 100dpi entry should be listed BEFORE 75dpi, this two are important fonts.
In my conf file:
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"

- the dpi-setting. At the prompt, type:
$ xdpyinfo | grep resolution.
For me, it says something like 84x84 dots per inch.
This is my dpi resolution. If it's very low, say below 60x60, that could be the issue.
- Default bit-depth setting. I once had it at 8 bit, which is to low and things look screwed up. You should at least have 16 bit, but 24 should be better. Try searching for default depth in the file. It's somewhere at the end, at the section "Screen". If default-bit depth isn't mentioned, this could be the problem.
- driver problems. Search for Driver (note the capital!). In nano type Ctrl+w, and insert Driver, and look for it. For me it shows
Driver "nv",
which is the free version of the nvidia driver. The nv driver is used standard for nvidia cards in much distro's i think, while the (not so free) nvidia driver is more extended, and is better in most cases. If it's nv, you could try the nvidia driver, or best, download the one at the nvidia site (somewhere at nvidia.com, but prepare for a long search).
- Look at the "boardname" entry. Does it show the video card you installed, and not another one?
- Your monitor? Are there large magnets in the area? Don't think this is the problem though. Just to be certain.

Well, try some things, if you don't succeed, feel free to mail me. Good luck!

Last edited by sludink; 01-12-2005 at 11:34 AM.
 
Old 01-12-2005, 01:42 PM   #4
gauntalus
Member
 
Registered: May 2004
Location: Hillsdale, MI
Distribution: gentoo 2004.3
Posts: 135

Original Poster
Rep: Reputation: 15
First off, I can't do the "Ctrl + Alt + Num+/-" thing, since I'm using dell laptop, and I don't know how to configure the function keys under linux so that I can access my numpad.

Well anyways, i went into my xorg.conf file, and I found the part that says "Driver" but there were two separate entries for it. Also, the value of Boardname was "Unknown", however, if you scroll down theres information on my card from when I ran xorgconfig. I've included the seemingly relavent seconds of my xorg.conf below:

Code:
# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"
    Identifier  "Standard VGA"
    VendorName  "Unknown"
    BoardName   "Unknown"

# The chipset line is optional in most cases.  It can be used to override
# the driver's chipset detection, and should not normally be specified.

#    Chipset    "generic"

# The Driver line must be present.  When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module.  Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.

    Driver     "vga"
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for.  When this line isn't present, a device
# section can only match up with the primary video device.  For PCI
# devices a line like the following could be used.  This line should not
# normally be included unless there is more than one video device
# intalled.

#    BusID      "PCI:0:10:0"

#    VideoRam   256

#    Clocks     25.2 28.3

EndSection

# Device configured by xorgconfig:

Section "Device"
    Identifier  "** ATI Radeon (generic)               [radeon]"
    Driver      "radeon"
    #VideoRam    65536
    # Insert Clocks lines here if appropriate
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "** ATI Radeon (generic)               [radeon]"
    Monitor     "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection
Can you see anything wrong here?
 
Old 01-12-2005, 01:50 PM   #5
barryman_5000
Member
 
Registered: Jan 2005
Distribution: Gentoo/Vector/Debian
Posts: 95

Rep: Reputation: 15
I am using a dell laptop as well. If you have a fn key then you can do it.

Just set this option if you have an inspiron:

Option "XkbModel" "inspiron"

Last edited by barryman_5000; 01-12-2005 at 01:52 PM.
 
Old 01-12-2005, 01:53 PM   #6
gauntalus
Member
 
Registered: May 2004
Location: Hillsdale, MI
Distribution: gentoo 2004.3
Posts: 135

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by barryman_5000
I am using a dell laptop as well. If you have a fn key then you can do it.
Well, its like this. The little light lights up on my keyboard indicating that NUMLOCK should be activated, however, it isn't :-) I just typed this message with NUMLOCK "activated", as you can see.. no numbers :-/

**edit** ok, figured it out... num lock doesn't work, but if i hold down "Ctrl+Fn+Alt+Num-/+" it works. but it just zooms in and out... doesn't really change my res.

Last edited by gauntalus; 01-12-2005 at 01:57 PM.
 
Old 01-12-2005, 02:04 PM   #7
barryman_5000
Member
 
Registered: Jan 2005
Distribution: Gentoo/Vector/Debian
Posts: 95

Rep: Reputation: 15
2 things.

1. remove the driver "vga" section from the monitor section.
2. Try adding HorizSync 31.5-48.5 and VertRefresh 50-70 in your monitor lines.

You have an lcd so I assume it runs around 60hz.
 
Old 01-12-2005, 04:14 PM   #8
sludink
Member
 
Registered: Jan 2005
Location: Brabant, the Netherlands
Distribution: Gentoo 2004.x (2.6.10 hardened)
Posts: 91

Rep: Reputation: 15
Probably the "radeon" in your conf file means you're using a free variant of the graphics driver, which are often a bit worse than propriarity ones. But many distro's use the free one's since this is more like the linux-spirit, and it avoids some potentially copyright issues.

You could try to get a newer propriarity driver.

At
http://www.ati.com/support/driver.html
you can opt for a new driver.
Choose linux, than graphics driver, then your graphics card, and click the "Go" button.
Now there's a download, and some FAQ's and HOWTO's explaining how to install the new driver.

Good luck again!
 
Old 01-12-2005, 05:03 PM   #9
gauntalus
Member
 
Registered: May 2004
Location: Hillsdale, MI
Distribution: gentoo 2004.3
Posts: 135

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by barryman_5000
2 things.

1. remove the driver "vga" section from the monitor section.
2. Try adding HorizSync 31.5-48.5 and VertRefresh 50-70 in your monitor lines.

You have an lcd so I assume it runs around 60hz.
Hey, I removed the Driver "vga" part from monitor, but I already had lines saying HorizSync 31.5-48.5, and VertRefresh 50-70 in my monitor section.
 
Old 01-12-2005, 05:34 PM   #10
gauntalus
Member
 
Registered: May 2004
Location: Hillsdale, MI
Distribution: gentoo 2004.3
Posts: 135

Original Poster
Rep: Reputation: 15
Yay! I re-ran xorgconfig, and when it asked to input video modes, I just had to add 1600x1200 to the available modes. Everything's working fine now. Thanks for your help guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution Problems Rick069 Ubuntu 1 06-16-2005 10:53 PM
Resolution Problems ajunt_ornj Mandriva 1 02-26-2005 01:26 PM
Resolution Problems kamransoomro84 Slackware 5 05-20-2004 06:47 PM
Resolution Problems garamatt Linux - General 2 10-15-2003 12:24 AM
resolution problems saturn_vk Slackware 4 03-01-2003 02:29 PM


All times are GMT -5. The time now is 02:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration