LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Removing "@printserver" from lpstat -t on other servers (http://www.linuxquestions.org/questions/linux-software-2/removing-%40printserver-from-lpstat-t-on-other-servers-905265/)

MensaWater 09-27-2011 01:06 PM

Removing "@printserver" from lpstat -t on other servers
 
We recently moved from one CUPS print server on RHEL5 to a new one on RHEL6. We brought the printer configs from the former to the latter.

On occasion were seeing an issue wherein one of the other servers that we submit print jobs to the print server shows the printer @printsvr2 instead of just showing the printer as if it were local:

lpstat -t | grep lck

device for lck_sls_2@printsvr2: ipp://printsvr2:631/printers/lck_sls_2

lck_sls_2@printsvr2 accepting requests since Tue 13 Sep 2011 01:15:01 PM EDT

printer lck_sls_2@printsvr2 is idle. enabled since Tue 13 Sep 2011 01:15:01 PM EDT

After we remove and readd the printer on the print server this same command shows the printer without the @printsvr2

lpstat -t |grep lck

device for lck_sls_2: ipp://printsvr2:631/printers/lck_sls_2

lck_sls_2 accepting requests since Tue 27 Sep 2011 09:53:19 AM EDT

printer lck_sls_2 is idle. enabled since Tue 27 Sep 2011 09:53:19 AM EDT

We need the printer to show up this way as it is accessed from multiple servers that use the same print server. The underlying application requires the printer name and we dont really want to have to modify it in the application on multiple hosts. Also it appears we cant force the name to show the @printsvr2 so even if we did change the application there is a danger wed end up having the opposite problem.

Anyone have any ideas why it sometimes shows this way and what we can do to prevent it or make it revert without having to remove and add the printer again?


All times are GMT -5. The time now is 11:11 PM.