LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-29-2006, 01:47 AM   #1
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Rep: Reputation: 30
Removed KDM, now kde's fonts are horrible


Hi,

I'm changing my Debian in order to get the best performance of it. So i removed kdm, since i will use autologin on console. The problem is that kde or anyother window managet (icewm, fluxbox) got and big, horrible font. Can i get the older font without running kdm?
 
Old 05-30-2006, 09:54 AM   #2
jeelliso
Member
 
Registered: Oct 2005
Location: Knoxville, Tn (USA)
Distribution: OpenSUSE, Ubuntu
Posts: 250

Rep: Reputation: 30
I'm not sure why removing KDM would have also removed font packages since other packages depended on it. If you can figure out what fonts you are talking about, then you can add that package back. Otherwise, you should probably add KDM back, but just disable it from running when you start your computer (which I think is what you are trying to do). The easiest way to keep the X server from starting is to modify your /etc/inittab file. Here is the first part of mine looks like.
Code:
#
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#               Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
# 
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit
The line that says id:5:initdefault should probably be changed to id:3:initdefault (or whatever run level starts full multiuser mode without X11).
 
Old 05-30-2006, 10:39 AM   #3
michapma
Member
 
Registered: Oct 2003
Location: Zürich
Distribution: Debian
Posts: 537

Rep: Reputation: 39
It is quite possible that, when you removed KDM, APT found a dependency and removed other packages as well. What version of Debian are you using? Unfortunately, I'm not aware of a log file for APT, if there is though you could use it to find the output of APT when you removed the kdm package.

What kind of fonts are you expecting to see, that is, what were you seeing previously?

Note that this is probably a Debian-specific issue, and would get best attention in the Debian forum.
 
Old 05-30-2006, 01:35 PM   #4
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by jeelliso
I'm not sure why removing KDM would have also removed font packages since other packages depended on it. If you can figure out what fonts you are talking about, then you can add that package back. Otherwise, you should probably add KDM back, but just disable it from running when you start your computer (which I think is what you are trying to do). The easiest way to keep the X server from starting is to modify your /etc/inittab file. Here is the first part of mine looks like.
Code:
#
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#               Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
# 
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit
The line that says id:5:initdefault should probably be changed to id:3:initdefault (or whatever run level starts full multiuser mode without X11).
Well, i wasn't cleary enough when i wrote this topic. What i was trying to report is that when i start X server with kdm or gdm, kde fonts look great, but when i start using xdm or startx on console, kde (when i say kde, i mean kde, not gtk) fonts looks horrible, they get bigger (without changing any conf).

michapma

I'm using Debian Sarge, but my kde is 3.5 (backport). I was seeing some good-looking small fonts, and now i see some big and ugly fonts. Like my K menu on a 1024x768 resolution wasn't getting more than 60% of the screen, now it get 100%.

I installed gdm, just to test it, and then the fonts got fixed, then i removed gdm and installed xdm, so the fonts got ugly again.
 
Old 06-01-2006, 02:51 AM   #5
michapma
Member
 
Registered: Oct 2003
Location: Zürich
Distribution: Debian
Posts: 537

Rep: Reputation: 39
After a quick Google search, I doubt that removing KDM removed any font packages. The search results seem to be telling me that it is related to the DPI setting, which apparently the display manager is controlling. Both KDM and GDM must be setting it, whereas XDM is not (by default) set up to configure it.

Check it out:
My Google search
http://lists.debian.org/debian-deskt.../msg00040.html
http://www.promptweb.co.uk/fonts/

The last link even provides screenshots to illustrate. The whole article is probably useful for you, but look especially about 2/3 of the way down under "How many DPI?" I am guessing that KDM and GDM were set up to use 75 dpi for nonscalable fonts first, and XDM looks for 100dpi first. Apparently, "You can configure the Xserver dpi from startx, kdm, xdm, gdm or whatever login manager you use."

This is good, it may help me to better control the font setup for IceWM.

Have fun experimenting, and tell us if it helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
using KDM spoils all fonts alaxulas Debian 5 04-10-2005 03:08 AM
KDM fonts so completely tiny CrazyHorse Debian 2 02-01-2005 01:49 PM
Konqueror fonts suddenly horrible irfanhab Slackware 2 09-02-2004 03:48 AM
Wrong fonts in KDM! hellblade Linux - Software 0 01-27-2004 08:45 AM
Fonts in OpenOffice 1.0.3 are horrible woranl Linux - Software 8 06-24-2003 09:19 PM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration