LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Remote X Session Help (http://www.linuxquestions.org/questions/linux-software-2/remote-x-session-help-360341/)

implant25 09-05-2005 05:25 AM

Remote X Session Help
 
Hi all,

I am having problems trying to access a remote x session at work. I have had this setup in the past but since a reinstall of Suse 9.3 it stops working and h'm at a loss on to how i get it working again.

basically,

i try the following "X -query hostname :1" which starts a new session but i just get a gray screen with an X cursor. i then get the following message displayed in the console;

"XDMCP Fatal error: Session failed for display: cannot open display"

I've tried connecting to several of our Linux boxes and i get the same problem.

Any thoughts?

Andy

LinuxVB 09-05-2005 08:39 AM

Remote X capability is switched off by default in SUSE.
If you need xhost +hostname capability, you must edit your display manager configuration in /etc/sysconfig/displaymanger with a text editor or in YaST's /etc/sysconfig editor.
change
Code:

# Allow remote access to your display manager (xdm/kdm). Please note
# that a modified kdm or xdm configuration, e.g. by KDE control center
# will not be changed.
#
DISPLAYMANAGER_REMOTE_ACCESS="no"
# Tcp port 6000 of Xserver. When set to "no" (default) Xserver is
# started with "-nolisten tcp". Only set this to "yes" if you really
# need to. Use ssh X11 port forwarding whenever possible.
#
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"

both to "yes"

Also in /etc/opt/kde3/share/config/kdm/kdmrc
Code:

[Xdmcp]
# Whether KDM should listen to incoming XDMCP requests.
# Default is true
Enable=false

change Enable to true.

ssh -X is the preferred way of forwarding an X session.
VNC is another possibility.


All times are GMT -5. The time now is 11:48 AM.