LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-26-2004, 08:00 PM   #1
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 46
remote application X11 forewording not working


I have done this a lot, but on other systems, I configured the 2 I am currently using from the ground up in gentoo from a stage 1 install.

on the computer I wish the application to be displayed on I type:
xhost +
it says:
access control disabled, clients can connect from any host
I then type:
ssh 192.168.3.1 (IP address of the host that will run the application)
I type:
export DISPLAY="192.168.3.2:0.0"
I then try to run the application:
xmms

I get this error:
_X11TransSocketOpen: socket() failed for tcp
_X11TransSocketOpenCOTSClient: Unable to open socket for tcp
_X11TransOpen: transport open failed for tcp/192.168.3.2:0

** CRITICAL **: Unable to open display

I have done this successfuly several times and am not sure why it is not working on my current configuration.

any ideas?
 
Old 07-26-2004, 08:20 PM   #2
TBC Cosmo
Member
 
Registered: Feb 2004
Location: NY
Distribution: Fedora 10, CentOS 5.4, Debian 5 Sparc64
Posts: 355

Rep: Reputation: 43
Should it not be: ssh -X 192.168.3.1 ?

Code:
-X      Enables X11 forwarding.  This can also be specified on a per-host
             basis in a configuration file.
Also, maybe -X is not necessary if enable x forward option in /etc/ssh/sshd_config is set to yes. Have not tried myself, but in my setup, the -X is not necessary.

Last edited by TBC Cosmo; 07-26-2004 at 08:23 PM.
 
Old 07-26-2004, 08:29 PM   #3
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Original Poster
Rep: Reputation: 46
same error (and I still had to use export command) like I said I have done it this way many many times, but it was on slackware.
 
Old 07-26-2004, 10:32 PM   #4
kgodbey
LQ Newbie
 
Registered: Jul 2004
Distribution: RedHat 8, Suse 9
Posts: 11

Rep: Reputation: 0
Shouldn't you do the "xhost +" on the host running the application (192.168.3.1)? Since the app is running there, it would be using the X services on that machine, and the remote computer (192.168.3.2) would be the one opening a client into the host's X server.

Probably wrong, probably stupid, but easy to try if you've got nothing else!
 
Old 07-26-2004, 10:42 PM   #5
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Original Poster
Rep: Reputation: 46
lol, I thaught it was clean, I used xhost + on the machine that was going to disoplay the program, and export on the machine that was runnign the program, that is also the correct way to do it, let me state once again, I manually typesd these commands to load xmms on these 2 machines for 3 months before changing them to gentoo, at which point the exact same commands in exact same sequence no longer worked, I am not lookinmg for command correction, I am looking for the problem, the syntax is correct and tested.
 
Old 07-26-2004, 11:33 PM   #6
kgodbey
LQ Newbie
 
Registered: Jul 2004
Distribution: RedHat 8, Suse 9
Posts: 11

Rep: Reputation: 0
Sorry, didn't read carefully enough. Is there a default firewall setup? If one X has IPv6, do both have it (sounds like you configured both the same, though)? Does "strace xterm" give any more info?
 
Old 07-27-2004, 12:00 AM   #7
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Original Poster
Rep: Reputation: 46
strace isn't found, also I use eterm not xterm.
 
Old 07-28-2004, 10:08 AM   #8
TBC Cosmo
Member
 
Registered: Feb 2004
Location: NY
Distribution: Fedora 10, CentOS 5.4, Debian 5 Sparc64
Posts: 355

Rep: Reputation: 43
Finally not too busy at work, so ....

On remote host:
+++++++++++
sshd_config has X11Forwarding yes

on the local host:
++++++++++++
ssh -X remotehost
xclock

And that worked fine

I did not do an "xhost +" on remote host
Both are Redhat AS2.1, remotehost is in runlevel 3 and only serving vnc displays. On those displays, "xhost" reports "access control enabled - only authorized hosts can connect"

Hope this gets you closer to a solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote X11 session from Windows i_joh Linux - Software 4 09-24-2005 10:19 PM
Remote X11 apps crashing as root Maqo Mandriva 0 01-02-2005 02:24 PM
Remote X11 (XDMCP) Ph0enix2003 Mandriva 1 06-12-2004 11:54 AM
X11 remote access cae Linux - General 2 01-30-2004 11:44 AM
Remote X11 Session cli_man Linux - Software 10 04-16-2003 07:15 PM


All times are GMT -5. The time now is 06:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration