LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Reltek HD Audio Drivers (make provides errors) (http://www.linuxquestions.org/questions/linux-software-2/reltek-hd-audio-drivers-make-provides-errors-813642/)

Newb4Life 06-11-2010 07:18 PM

Reltek HD Audio Drivers (make provides errors)
 
Hi.

I downloaded realtek's HD Audio codec, extracted it, and ran ./configure with no problems.

When I use the 'make' command I get this:

Code:

newb4life@newb4life-linux:~/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23$ sudo make
make dep
make[1]: Entering directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23'
make[2]: Entering directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23/include'
make -C sound prepare
make[3]: Entering directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23/include/sound'
make prepare2
make[4]: Entering directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23/include/sound'
ln -s ../../alsa-kernel/include/cs4231-regs.h
ln -s ../../alsa-kernel/include/cs46xx.h
ln -s ../../alsa-kernel/include/cs46xx_dsp_scb_types.h
ln -s ../../alsa-kernel/include/cs46xx_dsp_spos.h
ln -s ../../alsa-kernel/include/cs46xx_dsp_task_types.h
ln -s ../../alsa-kernel/include/cs8403.h
ln -s ../../alsa-kernel/include/cs8427.h
ln -s ../../alsa-kernel/include/emu10k1.h
ln -s ../../alsa-kernel/include/emu10k1_synth.h
ln -s ../../alsa-kernel/include/emu8000.h
ln -s ../../alsa-kernel/include/emu8000_reg.h
ln -s ../../alsa-kernel/include/emux_legacy.h
ln -s ../../alsa-kernel/include/emux_synth.h
ln -s ../../alsa-kernel/include/es1688.h
ln -s ../../alsa-kernel/include/gus.h
ln -s ../../alsa-kernel/include/hda_hwdep.h
ln -s ../../alsa-kernel/include/hdsp.h
ln -s ../../alsa-kernel/include/hdspm.h
ln -s ../../alsa-kernel/include/hwdep.h
ln -s ../../alsa-kernel/include/i2c.h
ln -s ../../alsa-kernel/include/info.h
ln -s ../../alsa-kernel/include/initval.h
ln -s ../../alsa-kernel/include/jack.h
ln -s ../../alsa-kernel/include/l3.h
ln -s ../../alsa-kernel/include/memalloc.h
ln -s ../../alsa-kernel/include/minors.h
ln -s ../../alsa-kernel/include/mixer_oss.h
ln -s ../../alsa-kernel/include/mpu401.h
ln -s ../../alsa-kernel/include/opl3.h
ln -s ../../alsa-kernel/include/opl4.h
ln -s ../../alsa-kernel/include/pcm-indirect.h
cp ../../alsa-kernel/include/pcm.h .
patch -p0 -i pcm.patch pcm.h
make[4]: patch: Command not found
make[4]: *** [pcm.h] Error 127
make[4]: Leaving directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23/include/sound'
make[3]: *** [prepare] Error 2
make[3]: Leaving directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23/include/sound'
make[2]: *** [prepare] Error 2
make[2]: Leaving directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23/include'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/home/newb4life/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23'
make: *** [include/sndversions.h] Error 2
newb4life@newb4life-linux:~/Downloads/realtek-linux-audiopack-5.15/alsa-driver-1.0.23$


Elv13 06-11-2010 07:24 PM

Are you sure you need this driver? Many cards work with intel-hda driver too, even if they are not intel.

Simon Bridge 06-11-2010 07:44 PM

Code:

patch -p0 -i pcm.patch pcm.h
make[4]: patch: Command not found

for k/ubuntu it should be /usr/bin/patch

In general:
Code:

$ sudo make
... should you be running make as root here? Usually you are only expected to be root for the install step.

Make sure that the functionality you seek is not already available by another means before compiling your own packages. Realtech HD audio is usually the same as intel HD audio - the drivers come with the kernel. Very new chipsets may need the latest drivers and some implimentations need vendor-specific settings.

Where did you get the source from? here?

Newb4Life 06-11-2010 07:51 PM

Yes I am sure it is the right Driver/Codec

and yes that is where I got it from.


ah, ok. I used sudo there to see if that was what the error was about.


EDIT:

"for k/ubuntu it should be /usr/bin/patch"

so how do I change it?

Simon Bridge 06-12-2010 02:54 AM

Quote:

Originally Posted by Newb4Life (Post 4000762)
Yes I am sure it is the right Driver/Codec

You are supposed to tell me how you know :)
Quote:

and yes that is where I got it from.
What about your mobo site like they say?
Quote:

ah, ok. I used sudo there to see if that was what the error was about.
Nah - you'd have got "permission denied" instead. Instead you are told it isn't there.
Quote:

"for k/ubuntu it should be /usr/bin/patch"

so how do I change it?
... first check that "patch" is where it is supposed to be. You may have missed a package.

sudo apt-get install patch

Then check that /usr/bin is in your path

echo $PATH

Then check the tarball for documentation - there is often something to edit in the toplevel makefile though the configure script is supposed to do that.

Newb4Life 06-12-2010 08:37 AM

Quote:

Originally Posted by Simon Bridge (Post 4000925)
You are supposed to tell me how you know

Because when I was on my M$ system I everest told me all I needed to know.
Quote:

Originally Posted by Simon Bridge (Post 4000925)
:)What about your mobo site like they say?

They don't have instructions

Quote:

Originally Posted by Simon Bridge (Post 4000925)
Nah - you'd have got "permission denied" instead. Instead you are told it isn't there.

Yeah, I do remember getting that error


Quote:

Originally Posted by Simon Bridge (Post 4000925)
... first check that "patch" is where it is supposed to be. You may have missed a package.

sudo apt-get install patch

Done


Quote:

Originally Posted by Simon Bridge (Post 4000925)
Then check that /usr/bin is in your path

echo $PATH

Then check the tarball for documentation - there is often something to edit in the toplevel makefile though the configure script is supposed to do that.

I skipped all of that after make and make install ran correctly.




Lib was success as well, but Utils gave me this error when I ran ./configure:

"configure: error: required curses helper header not found"

Simon Bridge 06-12-2010 10:19 AM

Quote:

Because when I was on my M$ system I everest told me all I needed to know.
Didn't tell you about creating the right build environment - what else got left out?

GNU/Linux is different. You almost never need to compile a sound driver for this manufacturers cards unless you have an old or minimal distro. Realtech HD audio cards very often work with the supplied intel HD driver. Have you tried configuring it? What does lspci tell you about your soundcard? What about lsmod | grep snd ?

Quote:

configure: error: required curses helper header not found
sudo apt-get install ncurses-dev

whenever you get an error about something "not found" it means you have to install it, or add it to your path. Pasting the error message into a search engine will usually tell you what to do.

Newb4Life 06-12-2010 10:31 AM

Thanks. Ill need to start doing that.


Yeah, Sound was working. I wanted to try upgrading the driver for the possibility of better sound quality.

I skipped a few of the errors by googleing this time.

Simon Bridge 06-12-2010 11:51 PM

Quote:

Yeah, Sound was working. I wanted to try upgrading the driver for the possibility of better sound quality.
I take it then that you have tried the audio under another OS and enjoyed the quality more? Can you describe what is wrong with the quality under the linux driver?

Have you tried upgrading the installed driver? - with the *buntus this is very easy.

I decided to go look - according to the readme that comes in the tarball, the source code is already in the kernel - it comes from the alsa project. In fact, your configure line is:

./configure --with-cards=hda-intel

We used to see sound quality issues with these chipsets, but they have pretty much cleared up in recent kernels.

So - it looks like you are doing far more work than you need to.

The main difference from the readme is that ubuntu relies more heavily on pulseaudio ... so alsamixer works but alsaconf does not. From all this, I feel I must strongly urge you to install the latest mainline kernel and see if there is any improvement that way.


All times are GMT -5. The time now is 07:51 AM.