Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


Closed Thread
  Search this Thread
Old 10-14-2003, 08:56 AM   #1
Registered: Sep 2003
Location: Boston
Distribution: Gentoo, Slack, SuSE, Ubuntu... Flavor of the week
Posts: 134

Rep: Reputation: 15
reinstalled apache, php, still no php support SuSE 8.2

I read the instructions till I'm blue in the face (I must just be dumb), alas... It seems as though apache is not recognizing that I have php installed. Here's what I did: I installed apache2.0.47 on my SuSE Linux with PHP 4.3.3 and mySQL. mySQL runs, apache runs, but I can't get phpMyAdmin to run or my browsers to recognize php other than stuff that's served to me from other web servers.

So I reinstalled Apache, this time (d'oh) with the ./configure -so command. It looks like it installed more modules and libraries than it did last time, but alas, still no php support. I think I am missing a php module... I configured httpd.conf to say AddType application/x-httpd-php4 but it doesn't seem to help. Any clues as to what I'm doing wrong?

Also, when I installed php, I did a very general, straight, install. ./configure, make, make install. Was there something else I should have done? Is there a way to fix it if there was? I was going on the instructions I had, which I'm beginning to fear weren't very good.

I tried to download the php module from SuSE, but it's for the wrong version of Apache, so it doesn't even recognize apache. Any help would be greatly appreciated.

Old 10-14-2003, 01:42 PM   #2
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

I replied to your original thread yesterday. Do you have the LoadModule line?

The thread will continue here:

Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache 2, PHP 5, SuSE 9.2 - cannot run php files dickohead Linux - Networking 6 06-28-2006 10:25 AM
Apache + PHP (with GD+MySQL support)... non-compiled? matrixcubed Linux - Software 2 11-09-2005 01:19 PM
Php support with apache c00l Linux - Software 4 03-02-2005 04:30 PM
Apache 2 Configuration in Webmin -- and PHP support vharishankar Linux - General 4 02-10-2005 04:06 AM
php apache or php cgi - php learner rblampain Linux - Security 3 12-17-2004 11:10 PM

All times are GMT -5. The time now is 11:15 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration