LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   refresh rate too high on debian lenny w/ kde 3.5 on ati radeon hd 4850 (http://www.linuxquestions.org/questions/linux-software-2/refresh-rate-too-high-on-debian-lenny-w-kde-3-5-on-ati-radeon-hd-4850-a-745099/)

mf93 08-04-2009 02:32 PM

refresh rate too high on debian lenny w/ kde 3.5 on ati radeon hd 4850
 
i recently built a new desktop. The specs are
gigabyte ultra durable motherboard
ati radeon HD 4850 video card
4gb 1066mHz ddr2 ram
amd Phenom 64 2.3ghz quad core processor

I installed the OS(debian lenny kernel 2.6.26 64bit with kde3.5) without an issue and it boots without a problem. However, once kdm starts, the monitor displays a "frequency too high" box that floats around the screen.
I ctrl+alt+f1 and the terminal works fine. I was wondering how to change the refresh rate from the terminal so that I could run kde.

also btw I checked my /etc/X11/xorg.conf file and ran the gtf utility to get a modeline to generate refresh rate:
Code:

MyPC:~# gtf 1024 768 70 -x

 # 1024x768 @ 70.00 Hz (GTF) hsync: 56.00 kHz; pclk: 76.16 Mhz
 Modeline "1024x768_70.00" 76.16 1024 1080 1192 1360  768 769 772 800 -HSync +Vsync

And my xorg.conf file looks like this
Code:

#all the code at the beginning...
Section "Monitor"
      Identifier      "Configured Monitor"
      #the code generated by gtf
End Section
#all the code afterwards

Any help would be greatly appreciated! thank you in advance!

Wim Sturkenboom 08-05-2009 07:06 AM

First question is what happens when you take the modeline out?

I would start by taking the modeline out and add the refresh rates (look them up in the manual of the monitor or on the internet) in the section monitor.

Code:

Section "Monitor"
#DisplaySize      320  240    # mm
Identifier  "Monitor0"
VendorName  "DEL"
ModelName    "DELL P790"
HorizSync    31.0 - 92.0
VertRefresh  50.0 - 150.0

Option      "DPMS"
EndSection

If that is not sufficient, we will look further. Can you let us know the make and model of the monitor (and maybe an indication of its age).

PS Not familiar with debeian, so can't say which tools are available fot configuration of X.

mf93 08-05-2009 02:53 PM

with or without the Modeline I'm getting the frequency too high message so I took it out...
However atm I'm having a problem with the power supply so when I get that working I'll try your solution.
Thank your for replying though

mf93 08-05-2009 02:57 PM

Also the monitor is an emachines E15T4 LCD...its about 7-8 years old and has a max refresh rate 70hz

Testeroni 12-20-2009 09:14 AM

Hi all!
Recently bought\built my baby:)
AMD Phenom II X4 955 Quad 3.2
Motherboard - Asus M4N72-E
Gigabyte ATI Radeon HD 5700 Series 1GB
Monitor - Asus VH222D

other info is rather irrelevant.
Installed Debian Lenny 5.03
With 2.6.26 atm
After installation got "Out of range" message on screen
fixed it with downloading ati driver n launching Xorg(just launching it n then rebooting, just installing driver and fixing xorg.conf wouldn't fix it for some reason)

Atm system is running, though I still want to installl drivers for Processor (doesn't seem to work right atm, frequency is incorrect)
drivers for motherboard
and once again for video card and monitor.
Since it's huge and resolution is 1920*1080 i got unpleasant experience when scrolling pages for example.
Where shoud i start "digging" :) fixing data for monitor or is it video card issue?

mf93 02-07-2010 03:04 PM

alright fixed my problem-there is no native radeon HD support on lenny, so i went to the manufacturers website downloaded the ati catalyst driver for linux 86_64 and now it is not working properly...
testeroni-to you- the driver package in the repository is not very good. Go to this link,
http://www.amd.com/us/Pages/AMDHomePage.aspx
download the ati catalyst driver, and then issue these commands as root
Code:

# apt-get install module-assistant
# m-a

then select prepare-this will install all the necessary dependencies
after that is done exit out of module-assistant(press esc key) and type this in the folder of the driver which you just downloaded
Code:

# ./ati-driver-installer-10-1-x86.x86_64.run
do a general normal install and then run as root
Code:

# aticonfig --initial
reboot the computer and it should all work great with the fancy effects and everything!


All times are GMT -5. The time now is 01:05 PM.