LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-20-2003, 11:17 AM   #1
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Rep: Reputation: 15
Redhat9 + gAIM + MSN


Ok, the new MSN9 has SSL apparently and I've been trying to get this to work for the last few days. Has anyone actually gotten this to work from the RPM? It says you can use the NSS Mozilla files for SSL but I have yet to get it to work.

When I try to compile from the source instead of install from the RPM it gives a glib error:

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at (URL removed to get post through SPAM filter)

Any ideas? Has anyone actually gotten this to work from the RPM?
 
Old 10-20-2003, 11:39 AM   #2
abhay
Member
 
Registered: Oct 2003
Location: New Delhi, India
Distribution: Mandrake 9.1, Redhat 9.0, Slackware 9.1
Posts: 58

Rep: Reputation: 15
i don't know about RPM but for source you need to get glib-devel. it must be on your CD. there are loads of threads around here regarding GAIM and MSN. if you don't mind much then try searching
 
Old 10-20-2003, 12:06 PM   #3
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
can I install glib-dev from RPM? If so I cant find anything above like glib 1.2.10

Do I have to install glib from source too? That's going to suck...
 
Old 10-20-2003, 12:09 PM   #4
abhay
Member
 
Registered: Oct 2003
Location: New Delhi, India
Distribution: Mandrake 9.1, Redhat 9.0, Slackware 9.1
Posts: 58

Rep: Reputation: 15
i don't use redhat much (though i do have it as a distro) but i can tell you what all packages does gaim depend on and where can you find them on Mandrake CDs. please change the paths according to your CD structure.

/mdk/cdrom1/Mandrake/RPMS/glib-gettextize-2.2.1-1mdk.i586.rpm
/mdk/cdrom1/Mandrake/RPMS/libglib2.0_0-devel-2.2.1-1mdk.i586.rpm
/mdk/cdrom1/Mandrake/RPMS/libnspr4-1.3-1mdk.i586.rpm
/mdk/cdrom1/Mandrake/RPMS/libpango1.0_0-devel-1.2.1-1mdk.i586.rpm
/mdk/cdrom1/Mandrake/RPMS/pkgconfig-0.15.0-1mdk.i586.rpm
/mdk/cdrom1/Mandrake/RPMS/tk-8.3.3-21mdk.i586.rpm
/mdk/cdrom1/Mandrake/RPMS/tkinter-2.2.2-6mdk.i586.rpm
/mdk/cdrom2/Mandrake/RPMS2/libaspell15-devel-0.50.3-1mdk.i586.rpm
/mdk/cdrom2/Mandrake/RPMS2/libatk1.0_0-devel-1.2.2-1mdk.i586.rpm
/mdk/cdrom2/Mandrake/RPMS2/libgdk_pixbuf2.0_0-devel-2.2.1-2mdk.i586.rpm
/mdk/cdrom2/Mandrake/RPMS2/libgdk_pixbuf2.0_0-devel-2.2.1-2mdk.i586.rpm
/mdk/cdrom2/Mandrake/RPMS2/libgtk+2.0_0-devel-2.2.1-2mdk.i586.rpm
/mdk/cdrom2/Mandrake/RPMS2/libgtk+-x11-2.0_0-devel-2.2.1-2mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/libao2-devel-0.8.3-2mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/libgtkspell0-devel-2.0.3-3mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/libnspr4-devel-1.3-1mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/libnss3-devel-1.3-1mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/libtclink3-3.3.1-12mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/libtclink3-devel-3.3.1-12mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/tcllib-8.3.3-21mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/tclx-8.3.3-21mdk.i586.rpm
/mdk/cdrom3/Mandrake/RPMS3/tkxinput-1.0-4mdk.i586.rpm

you don't need to install glib-devel from source. rpm would do fine.

Last edited by abhay; 10-20-2003 at 12:10 PM.
 
Old 10-20-2003, 12:22 PM   #5
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
Ok I got glib2-2.2.1-1.i386.rpm and glib2-devel-2.2.1-1.i386.rpm installed yet I still get the error.

Does glib need anything else? Maybe I need to specify the path or something on configure
 
Old 10-20-2003, 12:58 PM   #6
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
Now what I really need is that list for redhat, I'm still hunting for fucking dev RPMs
 
Old 10-20-2003, 01:03 PM   #7
motard
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Rep: Reputation: 0
msn/gaim

please read my thread
 
Old 10-20-2003, 01:43 PM   #8
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
I'm trying to get to the point where I can do your thread, I need to get the configure to recognize glib first, read my error message.

I think I'm still missing some dev RPMs
 
Old 10-20-2003, 01:46 PM   #9
abhay
Member
 
Registered: Oct 2003
Location: New Delhi, India
Distribution: Mandrake 9.1, Redhat 9.0, Slackware 9.1
Posts: 58

Rep: Reputation: 15
i m getting out of answers now.
did you install pkgconfig as it keeps track of all these configs.
 
Old 10-20-2003, 02:50 PM   #10
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
yeah I have pkgconfig-0.14.0-3.i386.rpm installed
 
Old 10-20-2003, 03:18 PM   #11
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
w00t, I'm getting a lil further now, now here is the error:

checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
*** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
*** development headers installed. The latest version of GTK+ is
*** always available at http://www.gtk.org/.

I've installed all the gtk RPMs *AND* dev RPMs though and it still gives me that error.

What else do I need, ugh....
 
Old 10-21-2003, 03:32 AM   #12
abhay
Member
 
Registered: Oct 2003
Location: New Delhi, India
Distribution: Mandrake 9.1, Redhat 9.0, Slackware 9.1
Posts: 58

Rep: Reputation: 15
i just looked in my redhat CD. imo you need gtk2-devel-2.2.1-4.i386.rpm from second CD and not gtk+-devel-1.2.10-25.i386.rpm. which one did you install?
[EDIT]btw how did you get rid of that glib error?[/EDIT]

Last edited by abhay; 10-21-2003 at 03:33 AM.
 
Old 10-21-2003, 09:59 AM   #13
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 42

Original Poster
Rep: Reputation: 15
[root@csg2 upgrade]# rpm -Uvh gtk2-devel-2.2.1-4.i386.rpm
Preparing... ########################################### [100%]
package gtk2-devel-2.2.1-4 is already installed

checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
*** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
*** development headers installed. The latest version of GTK+ is
*** always available at http://www.gtk.org/.

Same error Missing something else but I dunno what, or it's just looking in the wrong place...
 
Old 10-23-2003, 09:18 AM   #14
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Rep: Reputation: 30
seems like you have not run ldconfig.
become root and then type ldconfig in root.
also read my howto here:
http://manocha.wildinamerica.com/gaim.html
most probably you do not have the correct paths set and hence the compiler cannot find the gtk libraries.
hope this helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MSN in Gaim Seiken Slackware 5 04-11-2005 07:43 PM
gaim and msn sub_slack Slackware 42 06-14-2004 03:36 PM
Gaim/MSN protocols and problems upgrading Gaim and Kopete. sergeantroach Linux - Software 5 11-01-2003 08:27 PM
Recomend any msn massnger Equlent in Redhat9 mobassir Linux - Software 8 07-27-2003 02:38 PM
msn with gaim Netforce Linux - Software 9 06-13-2003 10:30 PM


All times are GMT -5. The time now is 08:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration