LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-24-2003, 03:04 PM   #1
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Rep: Reputation: 0
Redhat And Web Svr


ok i installed Linux Red Hat 9.0 i chose to install the Server and http and ftp enabled


after the instalation was conplete i found out apache 2.0 was installed, i also found out that my home directory was / var /www /html

now in normal cases i should be able to c the home page (index.html placed inthe above mentioned dir.) by typing hxxp:// localhost / index.html or hxxp://x.x.x.x/index.html

but i dont get nething and i couldnt try hxxp:// x.x.x.x cause i dont know wat is the ip it took from my dhcp server (win2k) the host name of the pc is ftpsvr ... i tried hxxp:// ftpsvr and mozilla forwards that to hxxp://www.ftpsvr.com

i hope some one can give me some really basic tipes on wats going on, and i would love to find out where to change my ip from dynamic to static.

remember that i am a beginer and anything technical you explain should have a small description.


thanx in advance

Ramzi Chekkath
_____________________________________

replace hxxp: tp h t t p since the forum doesnt allow me to post urls ( i dont have enough number of posts; how can i i just started using linux )
 
Old 09-24-2003, 03:09 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Make sure httpd is started:
service httpd status

You can start it with:
service httpd restart

Also make sure you don't have any firewall rules:
iptables -L
 
Old 09-24-2003, 03:14 PM   #3
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Original Poster
Rep: Reputation: 0
re

yeah i started the service

but no good ...

i wanna know how to change the ip or find out my current ip (in windows i do ipconfig)
 
Old 09-24-2003, 03:42 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
To find out your ip:
ifconfig

To change it use:
netconfig
 
Old 09-24-2003, 04:06 PM   #5
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
OK.

Question: Do you have a switch/router connected? If so, we have to forward 80 that to the ftpsvr box.

Also, if you go to mozilla and type in http://localhost (without the index.html) What do you see? - this is important because if you don't get the default apache screen, we will have to look at your httpd.conf file most likely.
 
Old 09-24-2003, 04:36 PM   #6
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Original Poster
Rep: Reputation: 0
RE:

OK

i solved that problem. (the problem was sith the dns svr that i have.
i am in a LAN network where my DNS is a win2k box and linux didnt register the name so i did it manualy and it worked i also addes the name under etc/host. to get it working.


Now my new problem is ftp How do i config an ftp svr on this box ?
how do i know if there is one already ( i cant connect to it by typing ftp://ftpsvr from IE on a remote box i tried the ip that doesnt work either)
 
Old 09-24-2003, 04:39 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Vsftpd (very good ftp server) come with redhat. Personally I run it in standalone mode. Edit /etc/vsftpd/vsftpd.conf and uncomment he lines as specified at the bottom.

Then start it with:
service vsftpd start
 
Old 09-24-2003, 04:55 PM   #8
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Original Poster
Rep: Reputation: 0
re

ok you guys are really helping thanx alot


david i just want to know something now ... is the ftp service started when i restart now .. or should i start the service everytime i restart?

another thing is ... where can i find details on chmod... i am not sure wat that is but i think its something like the NTFS permisions in windows ( i am just assuming ) any way .. if you can give me a place where i can learn these things it would be great and i wouldnt have to bother you so much


thanx again
ramzi chekkath
 
Old 09-24-2003, 05:07 PM   #9
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
To ensure that the server starts each time in runlevels 3, 4 and 5:
chkconfig --levels 345 vsftpd on

The commands that make up the nt type functions are chmod, chgrp, chmod. To find out their usage - as like any command - try the man page:
man chown
man chgrp
man chmod

There is a good list of unix/linux commands here:
http://www.onlamp.com/linux/cmd/
 
Old 09-24-2003, 05:17 PM   #10
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Original Poster
Rep: Reputation: 0
David check this out

http://www.linuxquestions.org/questi...threadid=96033
check that out i have the same problem


but his solution did not work for me wat to do ?
 
Old 09-24-2003, 05:22 PM   #11
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
What do you want to acheive?

Can you post your vsftpd.conf as well.
 
Old 09-24-2003, 05:25 PM   #12
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Original Poster
Rep: Reputation: 0
RE

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are very paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
#
# Allow anonymous FTP?
anonymous_enable=no
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES

pam_service_name=vsftpd
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES

#this line is added by ramzi
chroot_local_user=YES
_________________________________




ok now wat i want to do is as follow:


the user ftpuser wants to log into home directory /var/www/

but once he is there he should not be able to go to a lower level and access the root or anything else thats means he should be able to browse /var/www/ but not /var/

i know my english is not very good and its hard to understand me, forgive me

david do you know where i can get a PDF about linux (red hat bible or red hat for dummies would be great)
 
Old 09-24-2003, 06:07 PM   #13
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
If you chroot local users there you will need to make sure that the home directory set in /etc/passwd is /var/www. You will also need to have "passwd_chroot_enable=yes" in the config.

I don't know of any PDFs but you can read the manuals online:
http://www.redhat.com/docs/manuals/linux/
 
Old 09-25-2003, 02:40 AM   #14
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Original Poster
Rep: Reputation: 0
RE:

yesterday my vsftp was working perfectly i shut down came today morning started up and it doesnt work :'( i started the service so i am sure its working
 
Old 09-25-2003, 08:24 AM   #15
ramzi
LQ Newbie
 
Registered: Aug 2003
Posts: 19

Original Poster
Rep: Reputation: 0
any one out there ?
i really need help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Req]: How to config WebSvr & DNS Svr from console by Bash shell script CiF Linux - Networking 2 03-22-2005 01:31 AM
wireless web on redhat JoeUser11 Linux - General 0 01-12-2005 09:30 AM
Linux SMB Svr <-> Linux Clnt and roaming profiles Normanu Linux - Networking 1 11-24-2004 11:29 AM
RHEL 3 WS & Windows 2003 Svr Problems sfagundes Linux - Networking 1 07-07-2004 02:03 PM
RedHat 9 as a web server ETarpley Linux - Software 0 05-19-2003 08:25 PM


All times are GMT -5. The time now is 05:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration