LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-12-2002, 01:21 PM   #1
sstang
LQ Newbie
 
Registered: Jan 2002
Posts: 5

Rep: Reputation: 0
Exclamation RedHat 7.2 windows lost mouse and keyboard focus


Dear Linux experts there,

I recently installed RedHat Linux 7.2 and I constantly got X-window frozen. The system seemed to lose contact with keyboard and mouse. Even the light on keyboard is gone. So the system looks like running without keyboard and mouse.

Any explanation and fix for this urgent problem. I also run W2K and never have this problem.

Please email me any of your advice to:

sstang@shaw.ca

Steven

Last edited by sstang; 01-12-2002 at 04:31 PM.
 
Old 01-12-2002, 04:10 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
Are they usb?
 
Old 01-12-2002, 04:19 PM   #3
sstang
LQ Newbie
 
Registered: Jan 2002
Posts: 5

Original Poster
Rep: Reputation: 0
Mouse is Logitech OEM MouseMan PS/2 mouse, Keyboard is normal one.
 
Old 01-12-2002, 04:27 PM   #4
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
does ctrl+alt+backspace do anything when it's locked?
 
Old 01-12-2002, 04:34 PM   #5
sstang
LQ Newbie
 
Registered: Jan 2002
Posts: 5

Original Poster
Rep: Reputation: 0
I tried to turn on CapsLock and Num Lock and Scroll Lock on the keyboard, but nothing happened. It seemed the mouse and keyboard were disconnected from the computer system which I have never seen under Windows.

Steven
 
Old 01-12-2002, 04:48 PM   #6
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
I never saw it in linux either, unless it was locked up.

have you tried a different window manager?
 
Old 01-12-2002, 04:54 PM   #7
sstang
LQ Newbie
 
Registered: Jan 2002
Posts: 5

Original Poster
Rep: Reputation: 0
Probably I should try. I am using swarmfish(?), the other one can be used is tvm(?).

I should clear it out that I could work on this puppy either for a few minutes to an hour. But it could be got frozen on anther app.

My computer is P4 1.5GHz, with 512M RAM, 40 GB disk AOpen mother board and V card.

Steven
 
Old 01-12-2002, 09:57 PM   #8
speck
Member
 
Registered: Nov 2001
Location: California
Distribution: Slackware 14.1
Posts: 271

Rep: Reputation: 54
Do a search in the /etc/X11/XF86Config-4 for "InputDevice" and post all the text that's between Section and EndSection. You should at least have an entry in the "ServerLayout" section and a couple of "InputDevice" sections (one for keyboard and one for mouse).


Speck
 
Old 01-13-2002, 07:28 PM   #9
sstang
LQ Newbie
 
Registered: Jan 2002
Posts: 5

Original Poster
Rep: Reputation: 0
Here is part from XFree86.0.log:

(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(**) Option "Protocol" "PS/2"
(**) Mouse0: Protocol: "PS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/mouse"
(==) Mouse0: Buttons: 3
(**) Option "Emulate3Buttons" "on"
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
SetKbdSettings - type: 2 rate: 30 delay: 500 snumlk: 0
SetKbdSettings - Succeeded
AUDIT: Sat Jan 12 10:06:03 2002: 1762 X: client 6 rejected from local host


Any clue from this log?

Steven
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Focus follows mouse... Andreal Linux - Newbie 1 11-28-2005 07:24 PM
Mouse Focus iomari Linux - Hardware 0 12-02-2004 12:58 AM
redhat recompiled mouse lost dyson214 Red Hat 0 09-01-2003 06:50 PM
Mouse focus goes haywire svb4u Linux - Hardware 1 12-11-2002 01:33 PM
Lost Keyboard and Mouse with GNOME/KDE rkrishnam_can01 Linux - Software 1 02-09-2002 10:57 PM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration