LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-07-2005, 12:39 PM   #1
Einar Schlereth
LQ Newbie
 
Registered: Oct 2003
Location: Klavreström
Posts: 9

Rep: Reputation: 0
REd Hat + file permission + writing protection


Dear friends,
I got Red Hat 9.0 just recently. And I'm not not an expert either.
So today I was burning for the first time a cd-rw with documents.
As a test. Afterward I wanted to continue. Impossible: the answer was that the cd has a
writing protection (or file permission???) and that I'm not the owner. How is that possible?
I'm the owner of my PC, the only user, a lot of the documents I'm writing myself but the
PC tells me I'm not the owner. Is this socalled protection put on automatically?
Otherwise you're always asked for every shit. But here the program is setting things that you don't ask for.
Second: There are obviously two burning programs: toaster and simply burn (it was popping up automatically the first time I was burning but not the second time). How comes? And how can I get in there again?
Thanks in advance
Einar Schlereth
 
Old 01-07-2005, 02:36 PM   #2
jeickal
Member
 
Registered: Oct 2004
Distribution: Mandrake, DSL, SuSE, RedHat
Posts: 71

Rep: Reputation: 15
I beleive what you call "simply burn" is Nautilus CD creator. To get it back open a Nautilus window (you can get one by double-clicking on you home folder on the desktop), and replace "/home/your_username" in the location bar by "burn:///" (without the quote)

Now about your file permission problem, did your burn your "test" document as "root" by any chance? And now you're trying to do it again as a user? Just a guess...

If you want an easy-to-use very nice looking program to burn CD/DVD, I suggest you install K3B. Maybe it's in your RedHat distro (not sure) otherwise, you can get it here ==> http://www.k3b.org/
Then, always launch your CD writer program (no matter which one you use) as "user" never as "root".
 
Old 01-08-2005, 07:12 AM   #3
Einar Schlereth
LQ Newbie
 
Registered: Oct 2003
Location: Klavreström
Posts: 9

Original Poster
Rep: Reputation: 0
Dear Jeickall,
thank you very much for your promt reply.
You're right - the problem is this damned root thing. I must have done something wrong from the beginning. When installing Red Hat probably.
But how can I deavtivate it? Because it is irritating. When I turn on the modem I'm asked for the root, the same when I'm going to Gnome.
Well. My burner is called Gnome Toaster 1.0Beta6.
The K3 burner I have on two harddisks with Suse. I'm still experimenting you know. I like Suse very much - I think it's easier to handle, but I'm not yet really sure. Their K3 burner I thought was very sophisticated for me. I don't want to burn musik, videos etc. only documents, information from the internet you know.
Many greetings and thankful looking forward for your reply
Einar Schlereth
 
Old 01-08-2005, 08:25 AM   #4
jeickal
Member
 
Registered: Oct 2004
Distribution: Mandrake, DSL, SuSE, RedHat
Posts: 71

Rep: Reputation: 15
"this damned root thing" lol OK easy there, you cannot de-activate this, it is what make linux so robust and usermistake-proof. Now if you're new to Linux that would be good that you know some basics.
I'm assuming that you created one user during the install. So you have "root" and your "user".
You should always log in as "user" and do everthing with it. You only need root access for the following things:
- configuring your PC
- installing software (even though you could install a soft on your /home/user directory)

Normally redhat should ask you for you root password when needed. So it's not really a problem, you are just aware that in order to do what you ask it to do the system has prompt you for your root password because it needs to modify some system files.
With such a system, you can relax knowing that being logged as a "user" you can in no way mess up your system. Or if you get a virus opening an email you shouldn't have, the effect of it will be limited since the virus won't have access to your system files. So there are EXTREMELY good reasons for "this damned root thing" Get it?

Another important things for you to understand is this "permission" thing. Any file/folder has an owner and some permission attibut. You can graphically see this by right-clicking on a file in Nautilus + properties, then click on the permission tab. There you see the file owner, and the permission granted to this file. "Read" "Write" "Execute". You see it 3 times because the 1st one applies to the owner (if you created a file and don't want to risk to damage it you can prevent yourself from "Writing" on this file by un-ticking the "writing" box), the 2nd one is for the group (a group is a set of users, like collegues who share the same files), the 3rd to everybody else.
You can only change those attibute if you are the owner of the file or if you're root.

I also think Suse is easier than RedHat for a newbie, but that's a personal opinion. I'm personnaly very happy with Mandrake. If you have another hard disk to try other distros that's a perfect way to test which one works the best for you.
If you're happy with Gnome-toaster then keep it. Linux is about freedom

I know that's alot of things to get when freshly coming from the microsoft world, but we're here to help
 
Old 01-09-2005, 01:44 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,533

Rep: Reputation: 148Reputation: 148
Moved: This thread is more suitable in Linux-Software and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 01-11-2005, 01:11 PM   #6
Einar Schlereth
LQ Newbie
 
Registered: Oct 2003
Location: Klavreström
Posts: 9

Original Poster
Rep: Reputation: 0
Dear Jeickal, don't know where you are, but perhaps you learned from the news that we in southern Sweden had a terrible hurricane. So I was 4 days without phone & internet. Well I understand that root is an important security thing. Does that mean that I can never use that RW CD again and never work with those docs? 2. Why the root is demanded if you want to switch On or Off your modem?
Or anohter practical thing: most of the letters I'm writing are in Swedish, but I installed German. How to switch to Swedish? And if you yourself write a text and you save it: why you're not asked whether you want to block it? And how and where do you decide to act only as user? Is it just before RED HAT pops up and you can read: " Local host: "? Do you put in your name there?
Oh, and one more decisive question: During these four days I couldn't even write on my PC because it is always mounting the Interface when starting up. And as the server didn't answer the PC stopped altogether. Really nasty.
Pardon. So many questions.
Fraternally
Einar
 
Old 01-11-2005, 04:04 PM   #7
jeickal
Member
 
Registered: Oct 2004
Distribution: Mandrake, DSL, SuSE, RedHat
Posts: 71

Rep: Reputation: 15
Yeah I'm aware of what happened in northern Europe
Me I'm in Switzerland, nothing ever happens here. I guess nowadays I realize even more than ever how lucky we are.
Anyway, Lets talk about good thing: Improving your Linux experience

Quote:
Does that mean that I can never use that RW CD again and never work with those docs?
OK so you burned some docs on a CD-RW as root and you're having trouble using it? Well, since I never did this, I don't have any "garantee" answer, but here is what I would do. Copy those docs on your hard drive (as root if it ain't working as a user. if you do it as root, once the docs are copied you can change the owner back to your user using the command: "chown username doc" or for a folder and all the files inside: "chown -R username folder"). Then erase the CD-RW with the soft you use to burn (gnome-toaster, it is, right?). Try to do is as user first, and if it doesn't work, do it as root. Then, open gnome-toast as user and try to re-burn your file on the CD-RW. Finally I'd say that if you really cannot burn as user on the CD-RW, well get another one, CD-RW cost only couple of Euro it's not worth the pain...

Quote:
Why the root is demanded if you want to switch On or Off your modem?
Hum... what kind of modem do you have? ADSL, ISDN, Analogic? what sort is it? PCI card, USB, serial?

Quote:
most of the letters I'm writing are in Swedish, but I installed German. How to switch to Swedish?
OK I'm not sure exacly what you're trying to do. So you installed ReHat in German and you write letters using a soft like openoffice writer (right?), so what do you want to switch to Swedish? Is it Openoffice (like having the menu "file", "edit", ...) in Swedish? Is is the spell checker? Is it the keyboard, if I'm not mistaken you Swidish have some special characters? Try to be a little more specific

Quote:
And if you yourself write a text and you save it: why you're not asked whether you want to block it
Sorry but I think I'm also a bit confuse on this one: If I write a text (with what? like any word processor?) and you save it (like file+save I assume), why am I not being asked if I want to block what? Are you still confuse about being root or not? I'd rather have some clarification on the meaning of your question before trying to answer it.

Quote:
And how and where do you decide to act only as user? Is it just before RED HAT pops up and you can read: " Local host: "? Do you put in your name there?
OK this one is clear It is when you log in your desktop. Which desktop are you using (Gnome, KDE, icewm, ...)? When you boot, you are prompt to enter a username (or to click on an icon, depends how you start your Xserver) and a password (unless you configured your system to boot straight into your desktop without asking for authentication). There you click (or type) on your username, and you will enter your desktop "acting only as a user". Now if you need to do sth specific that require root access, either the system will prompt you for your root password or you can switch user in a terminal (tell me if you need help to do this). Then you will be root only in this terminal from which one you could start a soft as root (like gnome-toaster if needed).
Quote:
During these four days I couldn't even write on my PC because it is always mounting the Interface when starting up. And as the server didn't answer the PC stopped altogether.
Here also I'm gonna need you to be more specific. What "interface" are you talking about when you say "it is always mounting the Interface"? You also mentionned a "server" and a "pc". Are you talking about 2 different PC or you mean you have some servers install on your RedHat and for some reasons they did not answer (to who?). The PC stopped? Like... powered off? Froze? I'm guessing you mean that since the phone line was down your PC couldn't connect to the Internet and... stopped working?

Quote:
Pardon. So many questions
hey, you don't need to be sorry, like I said we're here to help And anyway to learn you need to ask questions But we're gonna need to know a little more about your system to really be able to help and specially that'll be good if you can be more specific about what work, what doesn't and what you're trying to do.
 
Old 01-14-2005, 12:45 PM   #8
Einar Schlereth
LQ Newbie
 
Registered: Oct 2003
Location: Klavreström
Posts: 9

Original Poster
Rep: Reputation: 0
Lieber Jaickal,
es ist vielleicht einfacher, das in deutsch zu erklären.
Das Problem mit der Root-Sperrung liess sich einfach lösen. Wenn ich einschalte, dann wird ja auf der schwarzen Seite erst einmal alles hochgeladen. Und irgendwann kommt: Lokal host: ................. Und da tippe ich dann : einar (mein username) ein. Und da war auf einmal die Sperrung auf der CD aufgehoben. Damit ist Deine Antowort nach "OK this one is clear" auch hinfällig. Irgendwie ist es mir gelungen, die Abfrage nach username und Losungswort auszuschalten (hatte aber trotzdem die Sperrungen!).
Dann gibt es in den Mappen viele gesperrte Dokumente. Da kann man auf "Eigenschaften", dann "Berechtigungen" gehen und tippt bei "schreiben" ein Häkchen ein. Dann verschwindet die Sperrung.
Tja, mein Modem ist ein TARGA, das hier in Schweden kein Mensch kennt. Und es ist extern (56000 ist es eingestellt und läuft auf COM 1). Mehr weiss ich nicht. Wie gesagt, in der Terminologie kenne ich mich nicht so gut aus. Das Problem ist also, dass auf dem schwarzen Schirm zu Anfang die Zeile kommt: INTERFACE wird hochgefahren. Das Modem wird eingeschaltet und stellt die Verbindung zum Server her. Da ich aber oft gar nicht gleich in den Briefkasten oder das Internet schauen will, sondern erst Briefe lese oder schreibe, muss ich das Modem abstellen. Dazu muss ich auf "Netzwerk" gehen. Dann werde ich zuerst nach meinem ROOT gefragt. Danach kommt das Fenster mit meinen vorhandenen Modems (nur eins) und dann kann ich "aktivieren" oder "deaktivieren". Das Fenster rolle ich ein, damit ich später nicht wieder das ROOT eingeben muss. Ein bisschen umständlich, aber man kann ja damit leben. Ich dachte nur, dass es vielleicht eine einfache Lösung gibt, das zu ändern (also nicht automatisch das Modem anschalten, sondern bei Bedarft). Ausserdem entstand ja das Problem, dessen Formulierung so schlecht war, dass Du sie nicht verstanden hast. Wir hatten durch die 4 Tag Telefonausfall natürlich auch keinen Zugang zum Internet. Deswegen erhielt das Modem (Interface) auch keine Antwort und der PC hängte sich auf (froze?). Ich konnte ihn nur noch ausschalten..
Zur 2. Frage: Mein RED HAT ist ja auf englisch. Irgendwann wird man bei der Installation nach der Sprache gefragt, und da habe ich deutsch gewählt, weil ich dachte, das sei für mich als Anfänger vielleicht leichter, und weil ich ausserdem viel auf deutsch schreibe (und meine deutschen Freund/innen sonst jaulen wegen der falschen Zeichen). Aber es war eine keine grosse Erleichterung, weil gerade bei der Hilfe viele Kapitel doch auf englisch geschrieben sind). Da ich nun viel mehr auf schwedisch schreibe, würde ich also gerne die Einstellung ändern.
Linux ändert ja automatisch auch die Einstellung auf der Tabulatur (y und z sind ausgetauscht, statt schwedisches a mit Kringel ein ü etc).
Die Fragen haben sich also auf zwei reduziert: Modem und Sprache.
Abschliessend wollte ich noch etwas zu Deinem Satz "Hier passiert nie was" sagen. Ich habe u.a. 25 Jahre für den Norddeutschen Rundfunk gearbeitet und da auch einmal eine Serie über Umweltprobleme. Muss Anfang der 90-er gewesen sein. Und da hattet Ihr in der Schweiz eine riesige Katastrophe, bei der ganze Berghänge runtergekommen sind, was viele Bahnlinien und Strassen sperrte, Menschenleben kostete und Häuser etc zerstörte. Darüber machte ich einen meiner wenigen direkt aktuellen Berichte. Interviewte den damaligen Umweltminister (?? bin mir nicht ganz sicher) in Bern. Vielleicht hast Du das ja nicht mitgemacht, weil Du gerade in Australien warst?!
Mit herzlichen Grüssen
Einar
 
Old 01-14-2005, 01:15 PM   #9
jeickal
Member
 
Registered: Oct 2004
Distribution: Mandrake, DSL, SuSE, RedHat
Posts: 71

Rep: Reputation: 15
Sorry buddy, but I'm from the french section of Switzerland, don't speak no german well only very little bit from school...
It might be a tiny country but we have 4 different language regions... We actually often need english to understand each other... funny ain't it
But still I feel sorry that you wrote all that and I can't understand

Last edited by jeickal; 01-14-2005 at 03:37 PM.
 
Old 01-15-2005, 11:25 AM   #10
Einar Schlereth
LQ Newbie
 
Registered: Oct 2003
Location: Klavreström
Posts: 9

Original Poster
Rep: Reputation: 0
Dear buddy,
sorry. All my swiss friends are from the german side and therefore I didn't think about the other sides. And you know the PC chinese sometimes is a little difficult. I even lived in Switzerland for some time: in Grenchen (capital of the clocks) where I had a gallery of arts in 1965. Long long ago.
Well, I'll try.
In the meanwhile I could resolve some of my problems. I could switch to swedish (then everything on the desktop is in swedish and the tabulator is in swedish too. There are some signs that are different from german. Okey.
Second: When at the start "Lokalhost: ........." is popping up I put my username there. So suddenly I could read and write on the CD-RW again.
The only problem now is the following:
When you start there is a black desktop and all the things are mounted. At a certain point comes: Interface pp0 will be mounted. Then my extern modem TARGA (that nobody in Sweden knows. But in Germany, Norway etc it is well known) is connecting with the server. This is annoying because often you don't need immidiatly an internet-connection (you first want to read or write some mails). Therefore I have to go first to "the net", then root is popping up I have to fill in , then the modem-window is popping up with the options "activate and deactivate". I deactivate and roll the window in. Then there are no more questions for the root. Well you can live with that. But naturally it is easier when you can start the modem when you need it.
BUT - when we were without telefon after the hurricane I wanted to use the PC and I could not. Because the modem could not connect to the server and than everything stopped or froze as you said. As telefonbreaks happen quite regularly it would be nice if I could stop that thing.
I hope I could make it clear now.
A word to your saying that nothing ever happens over there. I remember - it was in the nienties I think - when in Switzerland there were many landslides with many deads and a lot of destruction (houses, cars etc) and many communications were cut off (trains, roads etc). So I did a radio-program on it where I interviewed the minister for environment in Bern. But may be you have been in Australia at that time?
Alors c'était tout pour le moment. Je sais français mais pas le PCfrançais. Tu me pardonne j'éspère.
À bientôt
Einar
 
Old 01-18-2005, 02:45 PM   #11
jeickal
Member
 
Registered: Oct 2004
Distribution: Mandrake, DSL, SuSE, RedHat
Posts: 71

Rep: Reputation: 15
Quote:
Then you start there is a black desktop and all the things are mounted. At a certain point comes: Interface pp0 will be mounted. Then my extern modem TARGA (that nobody in Sweden knows. But in Germany, Norway etc it is well known) is connecting with the server. This is annoying because often you don't need immidiatly an internet-connection (you first want to read or write some mails)
Oh ok, so when you boot and everthing is coming up (you see all the "OK" next to each service) you have ppp starting, right? Then you need to look at the script in /etc/init.d
All those scripts are ran during the boot sequence with the arguement "start". When you shut down, They are ran again with the argument "stop". Like if I take as an example my print server (cups) it is started by the script /etc/init.d/cups. So if you wanna start your print server (this is what happens during the boot process of my PC):
Code:
[root@linux init.d]# ./cups start
and you get
Code:
Starting CUPS printing system:                                  [  OK  ]
Then when you want to stop it (or during the shutdown process):
Code:
[root@linux init.d]# ./cups stop
The output would be:
Code:
Stopping CUPS printing system:                                  [  OK  ]
Get it? Now about you ppp, you need to find which of those script in etc/init.d is starting your internet connection.
Maybe this command could help:
Code:
grep pp0 /etc/init.d/*
To see which file contain "pp0". then you can edit this file and comment the line starting your Internet connection. Or eventullay move this file in another folder, and run it mannually whenever you need Internet access.

The landslides? Oh yeah I remember it was pretty bad. But I meant this is not comparable to the scale of what happened to the world lately (and to you country...) so I feel really safe here. We also get few snow avalanche specially with those jackasses who know nothing about montains and go ski off-tracks.. Anyway, we're sliding away from the subject. Let me know if you could find the script that launch you Internet connection.
 
Old 01-22-2005, 01:21 PM   #12
Einar Schlereth
LQ Newbie
 
Registered: Oct 2003
Location: Klavreström
Posts: 9

Original Poster
Rep: Reputation: 0
RedHat +file permission

Dear jaickal,
I'm certainly a real idiot, as far as the mysteries of the PC world are concerned.
Well, the first bit of your letter I understood and I could even follow that process in the start-up and opened the cups file.
And then I was looking for this damned ppp0. I opened every map and every file but nowhere I could find ppp0.
The nearest I could come: there is a map called ppp. There I found /etc/ppp/ip-down and etc/pppoe-server-options. But in the maps I could not find ppp0.

# PPP options for the PPPoE server
# LIC: GPL
require-pap
login
lcp-echo-interval 10
lcp-echo-failure 2

There you see require-pap. But that file I cannot open.
The grep ppp0 thind didn't work either.
Besides - there are still many files and maps incl. the CD-RW that I can't work with -
only the red stop-sign disappeared.
And I still don't understand why the owner/user is blocked and stopped by root. I could understand if you were asked your username and password and even root. But you are definitely not asked - simply shut up.
Please if you explain something then do it step by step. For instance when you wrote "you comment the file" - that's chinese for me.

Besides - I understand that you love your country. It is beautiful and I always liked it.
Fraternally
Einar
 
Old 01-25-2005, 05:13 AM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,533

Rep: Reputation: 148Reputation: 148
Re: RedHat +file permission

Quote:
Originally posted by Einar Schlereth
And then I was looking for this damned ppp0. I opened every map and every file but nowhere I could find ppp0.
The nearest I could come: there is a map called ppp. There I found /etc/ppp/ip-down and etc/pppoe-server-options. But in the maps I could not find ppp0.
ppp0 is representing modem connection (like eth0 is representing network card). It should exist after you dial in (or after boot if you configure your system to dial automaticaly). To see a list of your interfaces use
ifconfig
ppp0 should be on the list.
 
Old 01-25-2005, 01:41 PM   #14
Einar Schlereth
LQ Newbie
 
Registered: Oct 2003
Location: Klavreström
Posts: 9

Original Poster
Rep: Reputation: 0
Thank you very much, Mara,
in the map sbin I found ifconfig. BUT I can't open it. It's a program.
And I wouldn't know what to do. I'm a bloody newcomer and you
have to explain step by step.
Sincerely
Einar
 
Old 01-27-2005, 07:09 AM   #15
jeickal
Member
 
Registered: Oct 2004
Distribution: Mandrake, DSL, SuSE, RedHat
Posts: 71

Rep: Reputation: 15
You just have to run ifconfig, like , open a console, type "su" and enter your root password, and now that you are root, you just type
Code:
ifconfig
Can you post the result of this command, so that we can see how your ppp interface is configured?
Note that I'm going skiing for a week, but maybe someone else can help in the meanwhile. Or otherwise, wait til I'll come back.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Writing a script in Red Hat 7.3 mustang05 Linux - Newbie 1 04-20-2004 03:07 PM
Device Driver Writing Red Hat 8 & 9 unicorn21 Red Hat 2 12-14-2003 03:01 AM
File Corruption in Red Hat 7.3 File Server dmurph2k2 Red Hat 3 10-09-2003 02:30 PM
File Corruption on Red Hat 7.3 File Server dmurph2k2 Linux - General 2 10-09-2003 12:38 PM
Writing files from Hdd to CDRW in Red Hat 8 jefx Linux - General 4 05-15-2003 03:39 AM


All times are GMT -5. The time now is 02:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration