LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-16-2003, 08:09 AM   #1
i003783
LQ Newbie
 
Registered: Jun 2003
Location: Olifantsfontein
Posts: 5

Rep: Reputation: 0
Red Hat 9 - unable to login


I have been running RH since 6.2. I currently have a machine with 2 RH versions 7.3 and 8.0 (I had no problems with any installation up to 8.0) I added RH 9 to this machine (plenty of space). The installation went fine , the machine reboots at the end of installation and GRUB gives you list of system. I select RH 9 and it takes me to logon screen. This is where the problem starts. When loging on it takes userid (root) and password and go strait into the text display mode and back into graphical mode a few seconds later and ask to login again. You can do this for a couple of times and eventually it displays the following message: "Failed to start the display server several times in a short time period; disabling display:0". My other two linux systems still works fine, no login problems there. I've created an additional login id during the second install of RH 9, even using this id gives the same problem. If I used CNTL + ALT + F1 I go into text mode, but I'm unable to login it just keeps on redisplaying the text login screen.
 
Old 06-16-2003, 04:34 PM   #2
0x4B
Member
 
Registered: May 2003
Location: Nashville TN, USA
Distribution: Debian (I'm unstable)
Posts: 117

Rep: Reputation: 15
can you login at a terminal (instead of through X Windows)?
 
Old 06-16-2003, 04:40 PM   #3
jchristman
Member
 
Registered: Mar 2003
Distribution: Fedora Core 3
Posts: 125

Rep: Reputation: 15
edit the RH9 entry in grub and add a
s
at the end of the line and then boot the machine
you will be in sigle user and now change roots passwd and add a user. then try logging in again as root then as the user to check if you can log in.
 
Old 06-18-2003, 04:13 AM   #4
i003783
LQ Newbie
 
Registered: Jun 2003
Location: Olifantsfontein
Posts: 5

Original Poster
Rep: Reputation: 0
Question

Thanks for the replies. I did however change root's password in single user mode, but the problem persists. After graphical logon supplying userid and password it goes to text login screen and back into graphical login screen after a few seconds. This happens over and over about 3-4 times before going into text login permanently and here it stays no matter how many times you login. Same scenario except I did not get the display disable error message although I believe its disabled as I exit the graphical login after a few attempts. I tried the same and a different password for root with no difference. Could the fact that I have selected "high" security and all other security setting in the installation have anything to do with this? I have however selected the same settings in RH 7.3 and 8.0 with no problem.
 
Old 06-19-2003, 12:06 PM   #5
i003783
LQ Newbie
 
Registered: Jun 2003
Location: Olifantsfontein
Posts: 5

Original Poster
Rep: Reputation: 0
Question

I've basically run out of ideas. Would anyone know what log file I can access to maybe get some more info on this problem?
 
Old 06-19-2003, 01:58 PM   #6
jvannucci
Member
 
Registered: Jan 2003
Location: Connecticut, US
Distribution: Red Hat 9.0
Posts: 98

Rep: Reputation: 15
Sounds to me like you're defaulting to runlevel 5 - graphical login - and X is having a problem. So, try appending '3' to the kernel line in GRUB. This will boot into runlevel 3. From there you should be able to log in as root and change /etc/inittab:

id:5:initdefault:

changes to:

id:3:initdefault:

Then you can boot without X and figure out your X problem. (Look at /var/log/message).

From runlevel 3 you can just use 'startx' to start X.
 
Old 06-21-2003, 09:40 AM   #7
i003783
LQ Newbie
 
Registered: Jun 2003
Location: Olifantsfontein
Posts: 5

Original Poster
Rep: Reputation: 0
Question

Thanks for the reply but my problem is still there. It does not matter what run level i'm in either 3 or 5 it does not allow me to login, it just redisplays the login screen. I found the following error messages in /var/log/messages:
Jun 21 14:53:03 localhost modprobe: modprobe: Can't locate module char-major-188
Jun 21 14:53:04 localhost last message repeated 15 times
Jun 21 14:53:04 localhost modprobe: modprobe: Can't locate module char-major-180
Jun 21 14:53:05 localhost last message repeated 31 times
Jun 21 14:53:05 localhost cups: cupsd startup succeeded
Jun 21 14:53:08 localhost xfs: xfs startup succeeded
Jun 21 14:53:08 localhost anacron: anacron startup succeeded
Jun 21 14:53:08 localhost atd: atd startup succeeded
Jun 21 14:53:15 localhost modprobe: modprobe: Can't locate module char-major-226
Jun 21 14:53:15 localhost last message repeated 3 times
Jun 21 14:53:15 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Jun 21 14:53:15 localhost kernel: agpgart: Maximum main memory to use for agp memory: 60M
Jun 21 14:53:15 localhost kernel: agpgart: Unsupported SiS chipset (device id: 5600), you might want to try agp_try_unsupported=1.
Jun 21 14:53:16 localhost kernel: mice: PS/2 mouse device common for all mice
Jun 21 14:53:40 localhost gdm(pam_unix)[1468]: session opened for user root by (uid=0)
Jun 21 14:53:40 localhost gdm-binary[1468]: pam_krb5: Configuration file does not specify default realm building user principal for `root'
Jun 21 14:53:42 localhost gdm[1487]: Display :0 is busy. There is another X server running already.
Jun 21 14:53:50 localhost modprobe: modprobe: Can't locate module char-major-226
Jun 21 14:53:50 localhost last message repeated 3 times
Jun 21 14:53:50 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Jun 21 14:53:50 localhost kernel: agpgart: Maximum main memory to use for agp memory: 60M
Jun 21 14:53:50 localhost kernel: agpgart: Unsupported SiS chipset (device id: 5600), you might want to try agp_try_unsupported=1.
Jun 21 14:54:17 localhost gdm(pam_unix)[1526]: session opened for user root by (uid=0)
Jun 21 14:54:17 localhost gdm-binary[1526]: pam_krb5: Configuration file does not specify default realm building user principal for `root'
Jun 21 14:54:18 localhost gdm[1542]: Display :0 is busy. There is another X server running already.
Jun 21 14:54:26 localhost modprobe: modprobe: Can't locate module char-major-226
Jun 21 14:54:26 localhost last message repeated 3 times
Jun 21 14:54:27 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Jun 21 14:54:27 localhost kernel: agpgart: Maximum main memory to use for agp memory: 60M
Jun 21 14:54:27 localhost kernel: agpgart: Unsupported SiS chipset (device id: 5600), you might want to try agp_try_unsupported=1.
Jun 21 14:54:50 localhost gdm(pam_unix)[1581]: session opened for user root by (uid=0)
Jun 21 14:54:50 localhost gdm-binary[1581]: pam_krb5: Configuration file does not specify default realm building user principal for `root'
Jun 21 14:55:18 localhost login(pam_unix)[1413]: session opened for user chrisl by LOGIN(uid=0)
Jun 21 14:55:18 localhost login[1413]: pam_krb5: Configuration file does not specify default realm building user principal for `chrisl'
................
From the above you can see 2 main problems:
1. The unsupported chipset for SIS and
2. The gdm problem
I used the gdm.conf file from RH 8.0 and the problem still persist
Could this be the unsupported chipset for SIS? Why are the 7.3 and 8.0 Red Hat system working and not 9.0?
PS. the only way to get into the system is via linux rescue.

Last edited by i003783; 06-21-2003 at 09:43 AM.
 
Old 06-21-2003, 11:47 AM   #8
senthil
Member
 
Registered: Apr 2003
Posts: 43

Rep: Reputation: 15
Hello,

I had the exact same problem with RH 9 on my laptop HP zt1195. Up until RH 8 it was working fine although with VESA video driver. I also tried to text login screen and even that crashes onto the same login prompt after a few seconds. Tried a few other things and finally gave up. I don't understand how a bad video driver can affect even text login. Another interesting thing is the graphical login screen appears fine. Only that I can't login.

I had the similar problem in RH 8 when I tried the S3 video driver but with VESA generic it works fine. So my guess, is in RH 9 both S3 and the VESA drivers r broken.

I am using Mdk 9.1 and it works great. No problems.

Cheers,
Senthil
 
Old 06-22-2003, 12:22 PM   #9
jvannucci
Member
 
Registered: Jan 2003
Location: Connecticut, US
Distribution: Red Hat 9.0
Posts: 98

Rep: Reputation: 15
Could your problem be kerberos related?


Jun 21 14:54:50 localhost gdm(pam_unix)[1581]: session opened for user root by (uid=0)
Jun 21 14:54:50 localhost gdm-binary[1581]: pam_krb5: Configuration file does not specify default realm building user principal for `root'

If kerberos is enabled, try turning it off.

Let's see, from rescue mode you should be able to chroot to your real '/' directory, then run:

# authconfig

Either deselect Kerberos or properly configure it.

If this doesn't work, try poking around in the PAM area. /etc/pam.d, man pam, /usr/share/doc/pam, ...

Sorry, I don't run kerberos, so I can't be more specific.
 
Old 06-22-2003, 02:20 PM   #10
Allen614
Member
 
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
Maybe a kernel problem? I've recently installed both RH9 and ML9.1 and both had a problem with "agpgart" and an ATI Rage 128 that's always loaded up fine with earlier kernels.
 
Old 06-26-2003, 09:22 PM   #11
spyghost
Member
 
Registered: Jun 2003
Distribution: Redhat
Posts: 245

Rep: Reputation: 30
hi, i am a linux newbie and i also have a similar problem, however i am booted at text mode right after the installation runlevel3, but the problem still persists... what can i do to fix this???

by the way, i've done two instalations of redhat and the result is still the same
 
Old 07-02-2003, 01:52 PM   #12
jrd154
LQ Newbie
 
Registered: Jul 2003
Location: PA
Distribution: RH, YD, MDK
Posts: 3

Rep: Reputation: 0
I've had similar problems with RH8, and they were all kerberos related. Try turning off Kerberos, and then login. Configuring kerberos can be tricky, so try without it first.
 
Old 07-19-2003, 06:58 PM   #13
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 30
Hello,

This discussion seems to be closed considering the last posting, but I thought I should say something about a trouble I've had (still have, BTW) with the agpgart. I've been fighting with installing MDK 9.1 on Dell's laptop Latitude D600 that has the ATI Mobility Radeon 9000 video card. I totally recognize the error message concerning the agpgart in your log. I tried to use the agp_try_unsupported=1 by adding

options agpgart agp_try_unsupported=1

in my /etc/modules.conf. What happened now was that when I logged out (I'm using KDE) the screen just blanked when the login splash should appear. After many different tries and as many difficult reboots (LOOOT's of disk scans...) I gave up, and the only reference to agpgart in the /etc/modules.conf is now

alias agpgart off

and it works.

I also noticed you problems with the char-major-226 (among others =)). I had the same, but at least I got rid of the error message by adding the same line for char-major-226 as for the agpgart in the /etc/modules.conf.

Don't forget to give the command depmod -a after fiddling with the modules.conf.

Cheers!

Last edited by Bebo; 07-19-2003 at 07:46 PM.
 
Old 07-19-2003, 11:57 PM   #14
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 49
[QUOTE]Originally posted by i003783
========================================
X - Problem Area
-------------------
Jun 21 14:53:50 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Jun 21 14:53:50 localhost kernel: agpgart: Maximum main memory to use for agp memory: 60M
Jun 21 14:53:50 localhost kernel: agpgart: Unsupported SiS chipset (device id: 5600), you might want to try agp_try_unsupported=1.
Jun 21 14:54:17 localhost gdm(pam_unix)[1526]: session opened for user root by (uid=0)
Jun 21 14:54:17 localhost gdm-binary[1526]: pam_krb5: Configuration file does not specify default realm building user principal for `root'
Jun 21 14:54:18 localhost gdm[1542]: Display :0 is busy. There is another X server running already.
Jun 21 14:54:26 localhost modprobe: modprobe: Can't locate module char-major-226
Jun 21 14:54:26 localhost last message repeated 3 times
Jun 21 14:54:27 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Jun 21 14:54:27 localhost kernel: agpgart: Maximum main memory to use for agp memory: 60M
Jun 21 14:54:27 localhost kernel: agpgart: Unsupported SiS chipset (device id: 5600), you might want to try agp_try_unsupported=1.
------------------------------------------------------------
Login Problem Area
-----------------------
Jun 21 14:54:50 localhost gdm(pam_unix)[1581]: session opened for user root by (uid=0)
Jun 21 14:54:50 localhost gdm-binary[1581]: pam_krb5: Configuration file does not specify default realm building user principal for `root'
Jun 21 14:55:18 localhost login(pam_unix)[1413]: session opened for user chrisl by LOGIN(uid=0)
Jun 21 14:55:18 localhost login[1413]: pam_krb5: Configuration file does not specify default realm building user principal for `chrisl'
=========================================
You seem to have 2 distinct problems

1. X
2. KRB5

Take it one at a time, resolve your login problem first.

Follow jvanucci's suggestion -
- get into rescue mode
- edit inittab to into runlevel3
- disable KRB authorization for the time being

Your login problem should go away

- now you can try figuring out your X problem
 
Old 08-10-2003, 12:44 PM   #15
i003783
LQ Newbie
 
Registered: Jun 2003
Location: Olifantsfontein
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks very much, I manage to crack this one. There is no problem with X as I was unable to login either in run level 5 or 3. The problem was in selecting Kerberos, but why? This works in RH 7.1 , 7.3 and 8 but not 9? At least now my RH 9 is up and running.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to edit grub in red hat randrake Linux - Enterprise 1 05-14-2004 02:28 AM
unable to use internet in red hat linux 9.1 mani_1t Linux - Hardware 3 02-19-2004 12:56 PM
Unable to start Red Hat Linux 9 ffilc7373 Linux - Newbie 2 02-10-2004 01:51 PM
Unable to boot up Red Hat 7.1 0r 7.2 biill robinson Red Hat 1 09-02-2003 05:22 PM
Unable to boot Red Hat Linux 7.2 rajanr Linux - Newbie 4 07-16-2003 11:58 AM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration