LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-02-2008, 08:54 AM   #1
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Rep: Reputation: 30
recording volume for capturing sound


Whenever I capture sound from my sound card (in Audacity), the volume is low. I've looked around in alsamixer but I don't know which control the capture uses. Which one controls the input level?

My sound card is a Creative Labs SB0090 Audigy Player
I have Alsa Mixer 1.0.13 and my kernel is 2.6.13-15.15-smp
I've also used KMix but like I said, I don't know if line, line1 or line2 is being used.
 
Old 03-02-2008, 09:03 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
In Audacity, do you have the slider for the mic all the way up?
 
Old 03-02-2008, 09:04 AM   #3
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
Yes, the slider is all the way up.
 
Old 03-02-2008, 09:15 AM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Open up alsamixer and use the tab to get to capture. It is a little hard to explain but you will get the hang of it. Then use the -> to see it. Up arrow to raise it.
 
Old 03-02-2008, 09:32 AM   #5
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
There is PCM capture, line and line 2. Which one should I move?

Line is set to 97 and line 2 set to 88 line2 capture is 0 there is also Aux capture and that is set to 97
 
Old 03-02-2008, 10:06 AM   #6
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Mine only has just capture L R and mic L R.
Is the mic pluged in to the pink port?
 
Old 03-02-2008, 10:27 AM   #7
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
I'm not recording from the mic, I'm recording directly from what the sound card is receiving (from the internet).
 
Old 03-02-2008, 11:44 AM   #8
The Other Guy
Member
 
Registered: Jan 2008
Location: Canada
Distribution: Vector Linux 6.0
Posts: 41

Rep: Reputation: 15
Wow! I thought I was the only one who had this problem when I got Audacity for Linux. When I was recording, it didn't matter whether the input volume on Audacity was at the top or right at the bottom, it always had the same input. What I did then (just a couple of weeks ago) was select the entire recording and use the amplify tool under the "Effects" menu. But now, I followed your advice, Comprookie, and looked in my Volume Control menu. I went to Edit -> Preferences and clicked the box for "Line-In Capture". Hopefully, the next time I'm recording, it will work. I would try this, gymnart. If that doesn't work, you can always use "Amplify". Good luck!
 
Old 03-02-2008, 03:10 PM   #9
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
@ The Other Guy
I will look at the Line-in Capture in Audacity.
When I try the Amplify tool, the quality gets distorted sounding, like it is in a tin can. Also, "Clipping" happens. I'm wondering if there are certain special settings so that won't happen if I use the Amplify tool.
 
Old 03-12-2008, 01:31 PM   #10
The Other Guy
Member
 
Registered: Jan 2008
Location: Canada
Distribution: Vector Linux 6.0
Posts: 41

Rep: Reputation: 15
Lightbulb

I solved the problem on my system! The problem was the "Capture" level on the volume control. I'm using Ubuntu, but hopefully this will be mostly the same on what you're using:
  • Right-click on the speaker/volume control on your taskbar
  • From the menu that pops up, click on "Preferences"
  • What opens up on my system is a window called "Volume Control Preferences". This lets you pick which part of the audio setup you want to adjust the level for. Scroll down until you see "Capture", click on it it once and then click OK.
  • Now go back up to the speaker control icon on your taskbar and left-click on it. You should now be adjusting the input level for sound capturing. Drag it up until it is at a good volume (it's best to do this while recording something in Audacity so that you can see how loud the recording is).
  • After you're done, you can go back to the original volume control by following the same steps, but this time clicking on "Master" under Volume Control Preferences.

That's how I did it; I assume this should work for every kind of recording, your setup may be a bit different. Also, once you're done, the MIC input level on Audacity is irrelevant; you adjust the Capture level to change the volume. Good luck!

Last edited by The Other Guy; 03-12-2008 at 01:33 PM.
 
Old 03-12-2008, 05:28 PM   #11
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
Thank you so much! I will try it when I'm on that computer.
 
Old 03-13-2008, 08:37 AM   #12
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
ok, i have now tried that and I just have KAMix and QAMix (both are the same thing) and neither has anything in the capture feature. Under that tab, it just has a Mic Boost box which I can check and uncheck but there are no volume levels.

I also looked into Audacity's controls and toolbars but I noticed that I do not have a Device Control toolbar either.

I'm glad that you solved your problem on your system, "The Other Guy".
 
Old 03-24-2008, 07:02 PM   #13
The Other Guy
Member
 
Registered: Jan 2008
Location: Canada
Distribution: Vector Linux 6.0
Posts: 41

Rep: Reputation: 15
Thanks; did your controls have anything similar to "Capture"? Like "input volume" or something?
 
Old 03-25-2008, 01:01 PM   #14
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
For KAMix and QAMix, nope. I've tried turning up "Line 2 capture" in Alsamixer and there was no difference.
 
  


Reply

Tags
alsamixer, audacity, capture, control, kmix, sound, volume


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
need a program for screen capturing/recording cisco4networking Linux - Software 5 07-06-2007 10:30 AM
recording/capturing audio gymnart Linux - Distributions 8 01-05-2007 08:37 PM
Sound capturing problem only as root ??? flocke_3055 Linux - General 1 03-28-2006 07:35 AM
audacity not capturing sound joelescoulie Slackware 4 05-24-2005 08:26 PM
capturing sound from external source ankscorek Linux - Hardware 7 12-08-2004 01:55 AM


All times are GMT -5. The time now is 07:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration