LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-17-2003, 05:39 PM   #1
vetro91
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Rep: Reputation: 0
Recompiled kernel error - "Unable to mount root fs on 21:42"


Hey guys,

So here's what happend...

I have RedHat 7.3 installed. I need to have the option of booting to a 2.2.23 kernel, so I downloaded the source and preceeded to make/compile it. Everything went fine. After compiling I did make modules, then make modules, then make install.

From that point, the bzImage (linux-2.2.23) was copied into my /boot dir, as was an initrd-2.2.23.img file. Also, the make install utility modified grub and placed a new entry to boot to the new kernel. This entry is exactly the same as what appears for my 2.4.18-3 kernel, just points to the 2.2.23 files.

At this point i rebooted into 2.4.18-3 just to make sure everything worked still, and it did, so i was fine.

I then tried booting into the new kernel (2.2.23) and it starts to boot, then i get this error message:

"Kernel Panic: VFS: Unable to mount root fs on 21:42"

Any ideas guys??? Your help is appreciated.




System:
Asus A7V Apollo-133 chipset
AMD Athlon 1300Mhz (Thunderbird)
Promise 100 IDE Controller
Maxtor 20gig
Fujitsu 40gig
Geforce4 4200
SB Live!
 
Old 02-17-2003, 06:53 PM   #2
yngwin
Member
 
Registered: Dec 2002
Location: China
Distribution: Arch
Posts: 359

Rep: Reputation: 33
Did you compile in the right filesystem support?
 
Old 02-17-2003, 07:01 PM   #3
vetro91
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Yes, ext2.

My install is "using" ext3, which came with the RedHat 7.3 install. The 2.2.23 kernel doesn't have ext3, however it does have ext2, and from what I've read (and people have told me), ext2 should be able to mount and work with ext3
 
Old 02-17-2003, 07:08 PM   #4
vetro91
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Promise 100 IDE Controller

I had a thought...

I notice that the xconfig for the 2.4.18-3 kernel has the option of including support for the Promise series of IDE controller cards. The 2.2.23 kernel does not have this option.

Could I be getting this error because the custom kernel I made doesnt recognize and support my IDE controller card?

If so, is there a patch or module I could use to get around this?

again, thanks guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible solution to common "unable to mount root fs" kernel panic while installing pergesu Linux - Software 2 12-26-2005 03:11 PM
That darn "VFS: unable to mount root..." again! CPUguy387 Linux - Newbie 14 03-01-2005 11:41 AM
Cannot install fedora core 1 or core 2: Initial setup crashes: "Unable to mount root" ovelasco Linux - Newbie 10 07-15-2004 07:19 PM
"Unable to mount root fs" error Seventh Linux - Newbie 11 03-03-2004 03:47 PM
error:"kernel panic: VFS: Unable to mount root fs":-( shyguy Linux - Newbie 1 07-23-2001 04:03 PM


All times are GMT -5. The time now is 12:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration