LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-01-2003, 11:06 AM   #1
v4su
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
recompile php on redhat 9


hello there

I am trying to connect to SQL Server using freetds. for this purpose i need to recompile php with mssql support. However since php and apache gets installed on RedHat Linux 9 by default, i am not able to find the top directory of php to do a ./configure again. Please could somebody help me by providing the steps to recompile php on RH Ver 9..

regards
su
 
Old 10-01-2003, 11:22 AM   #2
m0rl0ck
Member
 
Registered: Nov 2002
Distribution: A totally 133t distro :)
Posts: 358

Rep: Reputation: 31
I suppose the easiest way would be to get the php source rpm and install it "rpm -i *src.rpm" That'll create a spec file somewhere under /usr/src/redhat. Find the spec file, edit the configure flags and then recompile the installable binary rpms with "rpm -ba php.spec"
 
Old 10-03-2003, 06:46 AM   #3
v4su
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
hi there

many thanks for your kind response. I have downloaded the php source rpm package. However i am not sure what i have to do next? Should i do a ./configure with the appropriate options or do i need to configure the flags in someother way. Please help me

su
 
Old 10-03-2003, 08:01 AM   #4
v4su
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
hello again

I am able to find out what to do to recompile the source rpm. However now when i try to recompile the spec file "rpmbuild -ba php.spec", it throws up the following errors

cat: /usr/include/htpd/.mmn: No such file or directory
error: Failed build dependencies
bzip2-devel is needed by php-4.2.2-17
pspell-devel is needed by php-4.2.2-17
httpd-devel is needed by php-4.2.2-17
imap-devel is needed by php-4.2.2-17
mysql-devel is needed by php-4.2.2-17
postgresql-devel is needed by php-4.2.2-17
unixODBC-devel is needed by php-4.2.2-17
net-snmp-devel is needed by php-4.2.2-17

I have tried in both ways: modifying the configure options and without modifying. But in both cases it throws the same errors

Please help me

regards
su
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to recompile PHP? griffey Linux - Software 4 02-18-2009 07:52 PM
Recompile PHP dominodivine SUSE / openSUSE 3 08-02-2005 04:49 PM
Recompile PHP for Slackware? [GOD]Anck Slackware 12 03-15-2005 06:08 PM
how to recompile php to activate --with-dom phamtranquocvie Linux - Newbie 8 03-16-2004 01:17 PM
php recompile te_conway Linux - General 1 01-17-2002 08:41 PM


All times are GMT -5. The time now is 08:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration