LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-19-2008, 01:55 AM   #1
fallsoff
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Rep: Reputation: 0
re:pclinuxos not printing after cups install


Hi
I have PCLOS 2007 Gnome. It was printing OK with my HP LaserJet 1100. I had to do a reinstall of the OS, and I wound up with a CUPS package that was somehow different from the original functioning install that I had going. I had whatever PCOS defaults to. I am still new at this non .exe business and it really throws me sometimes, especially with repositories and tarballs in general.

Now I have a running printer and a functioning OS that seems to be sending things to the printe, but I get nothing coming out.

I just now reset the printer because I noticed large green light being on. The cable was actually disconnected, but it printed a weird page with the character for <alpha>, then <0> and then <alpha> again [like 'a0a'with no commas and nonstandard 'a' characters. Strange stuff.

So I then tried printing this post and the print light blinked, I heard the the paper starting noise, and it died to nothing. Same as it was before I began the post. That is what it was doing except for the odd page that just came through.

Can anyone help sort this out? I think it is a CUPs issue and probably more appropriate here than a printers group, but what do I really know?

If anyone can make sense of this and help thank you very much.
fallsoff
 
Old 03-19-2008, 02:06 AM   #2
fallsoff
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
ps
I tried <chkconfig --list cups> from terminal and got <unrecognized command> But maybe that one was to only be run at boot in GRUB.
 
Old 03-24-2008, 08:01 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
Just set up my hp_LaserJet 1100 on PCLinuxOS (KDE) and it works fine.
I have these package-versions:

Quote:
cups-1.2.4-1pclos2007
cups-common-1.2.4-1pclos2007
cups-drivers-2007-7pclos2007
enscript-1.6.4-5pclos2007
foomatic-db-3.0.2-1.20060906.3pclos2007
foomatic-db-engine-3.0.2-1.20060711.2pclos2007
foomatic-db-hpijs-2.6.7-1.20060828.2pclos2007
foomatic-filters-3.0.2-1.20060827.2pclos2007
gutenprint-common-5.0.0-3pclos2007
gutenprint-cups-5.0.0-3pclos2007
gutenprint-escputil-5.0.0-3pclos2007
gutenprint-foomatic-5.0.0-3pclos2007
gutenprint-gimp2-5.0.0-3pclos2007
gutenprint-ijs-5.0.0-3pclos2007
hplip-1.6.9-3pclos2007
hplip-hpijs-1.6.9-3pclos2007
hplip-hpijs-ppds-1.6.9-3pclos2007
hplip-model-data-1.6.9-3pclos2007
printer-filters-2007-7pclos2007
printer-testpages-2006-3pclos2007
printer-utils-2007-7pclos2007
This printer have worked on all (25up) linux OS's I have used since 2002.
Should work with any version of CUPS.
Known issues: only with wXP, and of course the cable is critical.

forgot these:
ghostscript-common-8.15-47pclos2007
ghostscript-fonts-8.11-6pclos2007
ghostscript-module-X-8.15-47pclos2007

Last edited by knudfl; 03-24-2008 at 08:06 AM. Reason: missing ghostscript-packages
 
  


Reply

Tags
cups, pclos, printer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Whats the difference between CUPS printing and Samba shared printing? depam Linux - Software 1 03-17-2006 02:56 PM
Cups Daemon Freezes under PCLinuxOS on Boot b18b Linux - Software 8 01-02-2006 10:53 PM
Printing Problem (cups / cups-lpd) daleman Linux - Software 3 04-08-2005 09:01 AM
remote cups printing to a smb/cups print server? justanothergeek Linux - Networking 2 09-15-2004 09:31 AM
Slackware 9 and CUPS (CUPS=crap) - printing carboncopy Slackware 21 07-29-2003 04:27 PM


All times are GMT -5. The time now is 03:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration