LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-23-2004, 06:26 AM   #1
georgee
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Rep: Reputation: 0
RAID 1 / Partition won't sync?


Hi,
i'm not a linux-pro, so I'll need some help on this one.

I installed Fedora Core 2 with 2 Drives (160GB IDE), and during installation I Created a RAID Level 1, so that if one drive fails, the other will boot and contain all data.

Now the problem is, after unplugging the primary master, the secondary didn't boot. Nothing happened. When I looked at mdstat, it shows me that md0 is not synced.

Code:
 [root@localhost root]# cat /proc/mdstat
Personalities : [raid1] 
md1 : active raid1 hda2[0] hdc2[1]
      1052160 blocks [2/2] [UU]
      
md2 : active raid1 hdc3[1]
      154713856 blocks [2/1] [_U]
      
md0 : active raid1 hdc1[1]
      521984 blocks [2/1] [_U]
MDADM tells me the same:

Code:
 [root@localhost root]# mdadm --detail /dev/md0
/dev/md0:
        Version : 00.90.01
  Creation Time : Fri Oct 15 22:03:33 2004
     Raid Level : raid1
     Array Size : 521984 (509.75 MiB 534.51 MB)
    Device Size : 521984 (509.75 MiB 534.51 MB)
   Raid Devices : 2
  Total Devices : 1
Preferred Minor : 0
    Persistence : Superblock is persistent
 
    Update Time : Sat Oct 23 11:05:55 2004
          State : clean, no-errors
 Active Devices : 1
Working Devices : 1
 Failed Devices : 0
  Spare Devices : 0
 
 
    Number   Major   Minor   RaidDevice State
       0       0        0       -1      removed
       1      22        1        1      active sync   /dev/hdc1
           UUID : f92b0458:fd8f264f:fa615ecf:a59d9ea4
         Events : 0.182
I don't have a clue why it sais that the RaidDevidce is removed, since it isn't.
md2 works perfectly:

Code:
[root@localhost root]# mdadm --detail /dev/md1
/dev/md1:
        Version : 00.90.01
  Creation Time : Fri Oct 15 22:00:12 2004
     Raid Level : raid1
     Array Size : 1052160 (1027.50 MiB 1077.41 MB)
    Device Size : 1052160 (1027.50 MiB 1077.41 MB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 1
    Persistence : Superblock is persistent
 
    Update Time : Fri Oct 15 22:00:12 2004
          State : clean, no-errors
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0
 
 
    Number   Major   Minor   RaidDevice State
       0       3        2        0      active sync   /dev/hda2
       1      22        2        1      active sync   /dev/hdc2
I don't have any Idea what causes md0 not to sync. Any Ideas are welcome!

thanks,
mat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva 10.1 on raid 0? how to partition? abcampa Mandriva 3 04-25-2005 07:12 AM
Converting an ordinary partition to RAID 1 or RAID 5? krishvij Linux - Newbie 1 03-20-2005 09:39 PM
Will RAID-1 sync changes made under another OS ? cbonar Linux - Hardware 0 01-08-2005 12:20 PM
software RAID on the root partition spuzzzzzzz Linux - Hardware 5 08-12-2004 11:28 PM
Raid 1 stopping sync problem after swap guanyu Linux - Networking 0 03-07-2003 01:00 PM


All times are GMT -5. The time now is 07:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration