LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-07-2003, 04:26 PM   #1
qmic
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Unhappy Radeon 7500 3D Acceleration Problem


Hi.
I have problem in 3D acceleration with Radeon 7500. I have Redhat 9.0. When I run quake 3, console returns:


----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Using 8/8/8 Color bits, 16 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


***********************************************************
You are using software Mesa (no hardware acceleration)!
Driver DLL used: libGL.so.1
If this is intentional, add
"+set r_allowSoftwareGL 1"
to the command line when starting the game.
***********************************************************
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

When I run with option +set r_allowSoftwareGL 1 it`s working but you very slowly (software mode) . I have DRI, XFree 4.3.0. Maybe I need something else? Please help.
 
Old 08-08-2003, 10:23 AM   #2
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
check /proc/dri
and also your XF86config file
are you sure that you have both glx,and dri extensions?
check those out by the log files in
/var/logs/xfree....
 
Old 08-10-2003, 12:27 PM   #3
qmic
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Yes I have both glx and dri extensions. I have directory /proc/dri. My XFREE config file:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "NEC FE770"
DisplaySize 330 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Radeon 7500"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 08-22-2003, 02:07 AM   #4
sput
Member
 
Registered: Jul 2002
Location: MN
Distribution: Slackware 9.1+
Posts: 70

Rep: Reputation: 15
Strange, I have the same card and distro, did you install red hat 9 with the card already in, or did you add that later? Mine worked right out of the box. Your XF86Config looks like it should work..

please respond.
 
Old 08-22-2003, 04:20 AM   #5
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
add the line

Load "GLcore"


to the "Module" section.

Everything else looks right.

Another thing to consider, my fglrx driver for my Radeon 9000 Pro requires the color depth to be at 24bpp.

try adding that line, above "dri" and "glx" somewhere.

Also, run lsmod to see if agpgart is loaded.

-Shade
 
Old 08-22-2003, 07:37 AM   #6
White R4bbit
Member
 
Registered: Aug 2003
Location: Italy
Distribution: Debian sid 2.6.1
Posts: 54

Rep: Reputation: 15
You have to load agpgart and radeon modules (in this exact order, or they won't work); try also $glxinfo | grep dir, to see if DRI is activated
 
Old 08-27-2003, 09:32 AM   #7
weaky
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
The answer might be in "libGL.so.1" link libGL.so in your quake 3 directory and rename it libGL.so.1

Also some drivers wont work in 24 bits mode, try 16 and 32 bits
 
Old 11-03-2003, 06:43 PM   #8
membrax
Member
 
Registered: Nov 2002
Location: 50'48''N - 4'21''E
Distribution: SuSE7.1 - SuSE8.1 - SuSE8.2 - RH6.2 - RH7.1 - RH7.3 - RH8.0 - RH9.0 - Fedora Core 1
Posts: 281

Rep: Reputation: 30
In /etc/modules.conf just add (as root) :

options agpgart agp_try_unsupported=1


(Assuming that agpgart is loaded, obviously).
Try "modprobe agpgart" to see that.


Should run fine then.
Cheers !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
radeon 7500 Hardware acceleration support? Potatopopper Linux - Software 6 03-09-2005 04:55 AM
problem: XFree4.3 + Radeon 7500 - DDC? Zoidy Debian 7 09-22-2004 05:00 PM
Mobility Radeon 7500 problem. whitefox Slackware 1 02-07-2004 07:49 AM
ati all in wonder 7500 radeon XFree86 4.3 problem v_ger6 Linux - Hardware 1 10-24-2003 06:11 AM
ATI Radeon 7500 startup problem ajasax Linux - Hardware 0 10-04-2003 02:54 AM


All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration