LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-13-2003, 10:47 AM   #1
moly82
Member
 
Registered: May 2003
Location: Genoa - ITALY
Distribution: Debian SID
Posts: 84

Rep: Reputation: 15
R200 module for 2.6 kernel?


hi all!

I've tried for a long of time to isntall the new ATI drivers with the kernl 2.6. Untamed helped me to patch and install the drivers: I had no errors, but when I try to run startx, everytime I had a black screen...

for this reason does a free r200 module for 2.6 kernel exist? i think it could be an easier way to get the 3D acceleration with th e 2.6 kernel and my sapphire radeon 8550le...

thanx a lot i nadvance,
bye!
 
Old 10-13-2003, 06:21 PM   #2
moly82
Member
 
Registered: May 2003
Location: Genoa - ITALY
Distribution: Debian SID
Posts: 84

Original Poster
Rep: Reputation: 15
Unhappy

nobody?
 
Old 10-14-2003, 06:13 AM   #3
moly82
Member
 
Registered: May 2003
Location: Genoa - ITALY
Distribution: Debian SID
Posts: 84

Original Poster
Rep: Reputation: 15
up!
 
Old 10-14-2003, 12:51 PM   #4
PMorph
Member
 
Registered: Sep 2003
Distribution: Debian
Posts: 213

Rep: Reputation: 31
You sure you use the driver made for the XFree86 version you have (4.1, 4.2, 4.3)?

Did you check the XFree86 log, does it report any problems when you start X?

Also check this:
http://www.rage3d.com/board/showthre...eadid=33715874

Last edited by PMorph; 10-14-2003 at 01:05 PM.
 
Old 10-14-2003, 02:34 PM   #5
moly82
Member
 
Registered: May 2003
Location: Genoa - ITALY
Distribution: Debian SID
Posts: 84

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by PMorph
You sure you use the driver made for the XFree86 version you have (4.1, 4.2, 4.3)?

Did you check the XFree86 log, does it report any problems when you start X?

Also check this:
http://www.rage3d.com/board/showthre...eadid=33715874

for sure I got the correct 4.3 drivers, and about the log, I opened a thread few time ago where I tried a lot of things with the help of Untamed.... modules... logs and everything else: I found no solution!

if you want to check that thread ,you could see if I forgot something, but I can tell you that I performed many many tests, hours of working with no result.

now i'll look at the link you wrote, thanx! I hope to find something that could help me!
 
Old 10-14-2003, 02:36 PM   #6
moly82
Member
 
Registered: May 2003
Location: Genoa - ITALY
Distribution: Debian SID
Posts: 84

Original Poster
Rep: Reputation: 15
http://www.linuxquestions.org/questi...ati+drivers+.6

 
Old 10-19-2003, 04:10 PM   #7
moly82
Member
 
Registered: May 2003
Location: Genoa - ITALY
Distribution: Debian SID
Posts: 84

Original Poster
Rep: Reputation: 15
I still have this problem! I found this information:

"It works now, the final solution being to:

(Manually or via patch) fix the VMALLOC_VMADDR problem,
Force gcc3.3
Use external modules (not compiled into the kernel) [note: haven't actually tried using compiled into kernel agpgart stuff yet, but will later]
Changed the == to a >=

And now it works."

I have gcc 3.3, I use the etxternal agpgart module, but I don't know how to fix the VMALLOC_VMADDR problem, can someone please tell me how to do that or where I can find the patch?

thanx in advance bye!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can a kernel module call the function of another kernel module sceadu Programming 3 05-02-2011 03:22 AM
[Error] Kernel Module : No kernel module build environment saman007uk Debian 7 09-09-2006 07:34 PM
3D Acceleration on ATI R200 QL jimmi323 Linux - Hardware 1 06-19-2005 10:24 PM
Suse 9.1 and Epson r200 printer klfreese Linux - Hardware 5 06-29-2004 07:25 PM
kernel module ignorant newbie looking for any one with kernel module knowledge cpoet Slackware 4 11-24-2003 10:37 PM


All times are GMT -5. The time now is 02:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration