LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-01-2006, 12:56 AM   #1
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Rep: Reputation: 30
Quickcam Messenger working (but no sound)


I am really in the dark when it comes to compiling drivers. I am trying to install the "qc-usb-messenger-1.2" driver. Here is the lsusb:

Bus 001 Device 002: ID 046d:08ad Logitech, Inc.

and dmesg:

quickcam [27.949714]: ----------LOADING QUICKCAM MODULE------------
quickcam [27.949727]: struct quickcam size: 3084
usb.c: registered new driver quickcam


Here is the error I get when trying to install the driver:

Kernel source directory: /lib/modules/2.4.27-2-386/build
Detected kernel version is 2.4.x.
Kernel version name: 2.4.27-2-386
Kernel source version code: 132123
Driver file name: trying.o
Module install directory: /lib/modules/2.4.27-2-386
Driver source directory (PWD): /home/freaky/programs/qc-usb-messenger-1.2
Kernel source directory (LINUX_DIR): /lib/modules/2.4.27-2-386/build
Module install directory (MODULE_DIR): /lib/modules/2.4.27-2-386
Utility install directory (PREFIX): /usr/local
User options (USER_OPT):
Driver file name (use with insmod): quickcam.o
Kernel version code: 132123
[!] Using module-init-tools with 2.4.x/2.2.x kernel.
These kernels require older modutils.


Why is it saying that kernels require older modutile?

Should I update the kernel? I really don't know how to do it or where to get it.

I would appreciate any help anyone could give.

Last edited by natewlew; 04-02-2006 at 09:03 PM.
 
Old 04-01-2006, 01:11 AM   #2
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
It is saying that you are using the modinit-tools for a 2.6 kernel but you are building a module for a 2.4 kernel. Look in the /usr/src/linux-2.4.27-2-386/README file and it should tell you what version of modutils you need.
 
Old 04-01-2006, 12:35 PM   #3
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks for your reply!

I don't have:

/usr/src/linux-2.4.27-2-386/README

I have:

/usr/src/kernel-headers-2.4.27-2-386

I can't find a readme file in there. I did find "module-init-tools" in apt and the description says:

This package contains a set of programs for loading, inserting, and
removing kernel modules for Linux (versions 2.5.48 and above). It serves
the same function that the "modutils" package serves for Linux 2.4.


Do you know how I could downgrade that to an older one, if thats what I should do?
 
Old 04-02-2006, 03:42 PM   #4
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
I have solved my problem thanks to bretts5964.

http://www.linuxquestions.org/questi...=419827&page=2
 
Old 04-02-2006, 09:03 PM   #5
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
I am having sound trouble now. I can adjust the usb audio class driver in kmix, but I still get no sound. I have tried plugging in a microphone, but I get no sound with that either. I have tryed recording sound with audacity but I can't get any sound to show up on the meter.

When someone tries to start a voice chat in Mercury with me I get this error:

Quote:
[19:58] No history available.
[19:59] Conference [Requested:SIP_A,;] invite received
[19:59] Accepting conference
[19:59] Conference port info: Audio traffic comes in on UDP port 9000 SIP communication comes in on UDP port 9010
[19:59] Conference [Requested:SIP_A,;] accepted by contact
[19:59] Your connection: xxxxxxxxxxxxx & xxxxxxxxxxxx
[19:59] My connection: xxxxxxxxxxxx & null
[19:59] isInternal: true
[19:59] Your Sip Connection: xxxxxxxxxxx:xxxxx
[19:59] My Sip Connection: null:5060
[19:59] My Audio Connection: null:9010
[19:59] My Video Connection: null:9000
[19:59] Scanning available capture devices.
[19:59] No Audio Device found.
[19:59] Not doing video.
[19:59] No Audio or Video Device was found. This might cause problems
[19:59] Starting SipComm.2 error at 8
I can here someone else talk in skype but I can't talk to them.
Please if anyone can help.
 
Old 04-09-2006, 07:19 PM   #6
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Are you sure your mic is working? If you have another computer you can check your mic on that would help.

Also you might not have the device in /dev. Look for /dev/dsp, it may be a symlink to another device /dev/sound/dsp or something like that.

And check the permissions of the device and make sure you have r/w access.
 
Old 04-10-2006, 07:04 PM   #7
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks for the reply.

Yes, the device is working on windows.

I do have /dev/dsp?

I am able to change permissions on it. It is set on: users can read and write.

I can't figure out how to get any sound. I've tried plugging in a mic in my sound card and I get nothing there. I've tried recording with krec but it doesn't pick up any sound. I've tried testing them with skype and that doesn't work either.
I use skype on windows to video chat but I would like to record sound on linux just in case one of these days skype does come out with a linux video version.

Last edited by natewlew; 04-10-2006 at 07:10 PM.
 
Old 04-10-2006, 08:38 PM   #8
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
$ /sbin/lsmod
Quote:
Module Size Used by
udf 81989 1
lp 12077 0
autofs4 24773 0
i2c_dev 11329 0
i2c_core 22081 1 i2c_dev
sunrpc 162725 1
ipt_REJECT 6593 1
ipt_state 1857 1
ip_conntrack 40565 1 ipt_state
iptable_filter 2753 1
ip_tables 16705 3 ipt_REJECT,ipt_state,iptable_filter
button 6481 0
battery 8901 0
ac 4805 0
md5 4033 1
ipv6 235137 10
joydev 10241 0
spca5xx 610960 0
videodev 9793 1 spca5xx
uhci_hcd 31065 0
shpchp 82373 0
parport_pc 24577 1
parport 37129 2 lp,parport_pc
snd_usb_audio 59553 1
snd_usb_lib 12097 1 snd_usb_audio
snd_ens1371 24937 5
snd_rawmidi 26597 2 snd_usb_lib,snd_ens1371
snd_seq_device 8137 1 snd_rawmidi
snd_pcm_oss 49017 0
snd_mixer_oss 17985 5 snd_pcm_oss
snd_pcm 96841 3 snd_usb_audio,snd_ens1371,snd_pcm_oss
snd_timer 29893 1 snd_pcm
snd_page_alloc 9673 1 snd_pcm
snd_ac97_codec 63889 1 snd_ens1371
snd 55461 13 snd_usb_audio,snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd _ac97_codec
soundcore 9889 5 snd
ne2k_pci 8865 0
8390 11457 1 ne2k_pci
8139too 25921 0
mii 5185 1 8139too
floppy 58481 0
dm_snapshot 17029 0
dm_zero 2369 0
dm_mirror 27825 0
ext3 116809 2
jbd 71385 1 ext3
dm_mod 57557 6 dm_snapshot,dm_zero,dm_mirror
$ arecord -l
Quote:
**** List of CAPTURE Hardware Devices ****
card 0: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: U0x46d0x8ad [USB Device 0x46d:0x8ad], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
Old 04-10-2006, 10:30 PM   #9
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
It's got to be something in your alsamixer is disabled. Try running alsamixer from an xterm and turn everything on and off a couple times and adjust all the levels up and down. Sounds silly but everytime I have weird sound problems it's always alsamixer and that is how I fix it.
 
Old 04-11-2006, 12:13 AM   #10
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks for the advice but I just can't get it to work. When I run alsamixer I get an option for mic 1 or 2. I tried selecting mic 2 but nothing seemed to change. I ran all of the volumes up and down. There is a mic boost option but I can't figure out how to turn it on.

I tried turning off my mic on my soundcard with kmix.

The option for my usb device doesn't have a green button above it. It only has a red button below it. If that means anything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Web Cam Help : Logitech QuickCam Messenger AlexJ Linux - Hardware 4 06-07-2006 02:52 PM
Logitech QuickCam Messenger cootetom Suse/Novell 39 05-20-2006 05:04 AM
Logitech QuickCam Messenger Mic ntskelvin Linux - Hardware 0 09-20-2005 11:34 PM
Logitech quickcam messenger in mdk10.1 simeandrews Linux - Hardware 10 03-20-2005 08:18 PM
Logitech Quickcam Messenger - Problems compiling driver Yukino Linux - Hardware 0 02-01-2005 04:03 PM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration