LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Quick question for adding smb support to Cups (http://www.linuxquestions.org/questions/linux-software-2/quick-question-for-adding-smb-support-to-cups-444288/)

tgo 05-12-2006 11:23 PM

Quick question for adding smb support to Cups
 
I installed cups in hopes to print on the windows printer from linux but when i went to run lpadmin with -v smb://....... it said

Code:

lpadmin: Bad device-uri "smb://
So i googled some and found the lpinfo command

Code:

debian:/usr/src/cups-1.2.0# lpinfo -v
network socket
network http
network ipp
network lpd
direct
scsi
debian:/usr/src/cups-1.2.0#

Obviouslly i need smb support here but I am not sure how to add it. I was following

I had been following
http://www.faqs.org/docs/Linux-mini/...#basicprconfig

and it simply said to check lpinfo -v to see if it was tehre but didnt say what to do if it wasnt.

I thoguht it might of been a compile time thing but I grep'ped for smb in INSTALL.txt and nothing was there.

So basiclly how do i add smb support to cups

thanks

Jerre Cope 05-13-2006 01:26 AM

in /usr/lib/cups/backend, you should have a script named smb. If not:

ln -s /usr/bin/smbspool /usr/lib/cups/backend/smb

assuming smbspool exists.

tgo 05-13-2006 03:16 AM

I thought i had done that before strange ... Now that part is working and I seemed to come across a common bug.

The error seemed to be

Quote:

cupsdAuthorize: No authentication data provided.
And after this a few times it seems to default to some printer

Quote:

Print-Job ipp://localhost/printers/Printer
The only posts refering to this error were this bug:

https://launchpad.net/distros/ubuntu...mba/+bug/39484

They claim its a bug in the newest smbspool. When i first setup the printer I did not put the user:password@ in the line but I went back and I added the info in cupsd.conf and restarted/killed/restarted cupsd but still get the same error.

Is this bug truly in smbspool or is there something else that could be doing this error? Do you have to somehow authehintice wiht cupsd for each job ( that doesnt sound reasonable but I am really not sure ).

Thanks and I hope someone has had this issue and resolved it.

Jerre Cope 05-13-2006 09:07 AM

I tend to have trouble with smb on XP machines and above. Fortunately, XP can talk lpd, and I think maybe ipp. Anyway, for XP I usually print lpd from CUPS to lpd and share the samba drivers rather than XP drives.

tgo 05-13-2006 02:57 PM

Quote:

Originally Posted by Jerre Cope
Anyway, for XP I usually print lpd from CUPS to lpd and share the samba drivers rather than XP drives.

Could you explain that in more detail. I dont understand what you mean when you say "I print lpd from Cups to lpd".

Just to know we are on the right track I want to print on a windows shared printer from linux.

I am just really confused because cupsd keeps giving that error about no authentication but I do not see a way to even authorize with it. I did it all by hand and looked up other peoples cupsd.conf and the only auth stuff was for the web stuff. I even ran the gui thing that will create your cupsd.conf and it didnt have anyhitn related to authenticating with it so I am very confused.

I sniffed on my windows computer to see if any smb traffic was even coming to it but nothing was there so this has to be an issue with cupsd only.

Jerre Cope 05-13-2006 03:51 PM

Sorry.

What I meant was that you can turn on lpd services on a windows XP box and then use the lpd:// uri from cups as you would to any other lpd printer. I'd name the printer something simple like lp1 if you did it that way. I tend to use the http://localhost:631 interfaces, or the kde printer manager (kcmshell printmgr). Also, here are some of my other notes I refer to. Some of them may apply if you've got lprng and CUPS installed simultaneously (also accidently).

Must change links to lp commands in /usr/bin from lprng to cups. OR uninstall LPRNG and install CUPS.

Also, link /usr/bin/smbspool to /usr/lib/cups/backend/smb and then edit the DeviceURI? in /etc/cups/printers.conf

To provide lpd services you must add a printer line to inetd.conf OR printer file to xinetd.d directory. See CUPS Admin manual-Printing with Other Systems.

To share a printer to a windoze client the raw filters need to be uncommented in /etc/cups/mime.convs and mime.type

I think you're probably already watching the /var/log/cups logs as part of your debugging proces.

I just mention the lpd solution because I have run into some XP sharing issues that I didn't really want to spend the time fixing. I think lpd is faster anyway.

offs 01-31-2007 05:17 AM

Quote:

Originally Posted by tgo
I installed cups in hopes to print on the windows printer from linux but when i went to run lpadmin with -v smb://....... it said

Code:

lpadmin: Bad device-uri "smb://
So i googled some and found the lpinfo command

Code:

debian:/usr/src/cups-1.2.0# lpinfo -v
network socket
network http
network ipp
network lpd
direct
scsi
debian:/usr/src/cups-1.2.0#

Obviouslly i need smb support here but I am not sure how to add it. I was following

I had been following
http://www.faqs.org/docs/Linux-mini/...#basicprconfig

and it simply said to check lpinfo -v to see if it was tehre but didnt say what to do if it wasnt.

I thoguht it might of been a compile time thing but I grep'ped for smb in INSTALL.txt and nothing was there.

So basiclly how do i add smb support to cups

thanks

install smbclient to continue.
on debian run:

# apt-get install smbclient

:)


All times are GMT -5. The time now is 05:41 AM.