LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-19-2006, 01:32 PM   #1
munthe
Member
 
Registered: Apr 2005
Location: Denmark
Distribution: Gentoo
Posts: 38

Rep: Reputation: 15
Quake4 GLX visual problem, 64bit fedora


I have bin trying to install the quake4 demo but I keep getting the fellowing error, at runtime:
Code:
$ quake4-demo
[...]
--------------- R_InitOpenGL ----------------
Initializing SDL subsystem
Loading GL driver 'libGL.so.1' through SDL
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
TODO: Sys_SetClipboardData
********************
ERROR: SDL_SetVideoMode failed: Couldn't find matching GLX visual
********************
--------------- BSE Shutdown ----------------
---------------------------------------------
WARNING: rvServerScanGUI::Clear() - invalid scanGUI

idRenderSystem::Shutdown()
Sys_Error: SDL_SetVideoMode failed: Couldn't find matching GLX visual
I'm running fc5_x86-64, and have a Geforce 6800 GS with the official drivers from nVidia.
I have nstalled both the 32 and 64 bit SDL package.

Here's some relavant parts of my xorg.conf:
Code:
[...]
Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
[...]
Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "glx"
EndSection
[...]
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "MAG 570V"
	HorizSync    30.0 - 70.0
	VertRefresh  50.0 - 150.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "nVidia Corporation NV41.0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1400x1050" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
 
Old 06-20-2006, 10:31 AM   #2
munthe
Member
 
Registered: Apr 2005
Location: Denmark
Distribution: Gentoo
Posts: 38

Original Poster
Rep: Reputation: 15
Nobody have a clue how to solve this? I did some more research on the topic, and it seems that most people solve the by uncomment the Load GLX, but since I already have this done I really can't do that.

Here's some more information on the problem. Hope somebody out there know something, any help would be appreciated.
Code:
$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
[emil@localhost ~]$ cat /etc/X11/XF86Config | grep glx
cat: /etc/X11/XF86Config: Ingen sådan fil eller filkatalog
[emil@localhost ~]$ cat /etc/X11/xorg.conf | grep glx
        Load  "glx"
 
Old 06-20-2006, 12:48 PM   #3
munthe
Member
 
Registered: Apr 2005
Location: Denmark
Distribution: Gentoo
Posts: 38

Original Poster
Rep: Reputation: 15
Ok, I'll talk once more to my self
After reinstalling the nvidia drivers everything works with no complain,..
 
  


Reply

Tags
games, glx, graphics, nvidia, opengl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no matching GLX visual systelm Linux - Software 0 05-05-2006 03:32 AM
ut2003 glx visual problem tutwabee Linux - Games 5 08-25-2004 06:52 PM
GLX visual errors while starting a game w0lv3rin3 Linux - Software 0 03-07-2004 12:52 PM
video mode GLX visual? Longinus Linux - Software 6 02-22-2004 07:46 PM
ut2003--- couldn't set video mode:couldn't find matching GLX visual <h1>tux</h1> Linux - Newbie 1 08-22-2003 07:17 PM


All times are GMT -5. The time now is 09:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration