LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-14-2003, 10:35 PM   #1
LavaDevil94
LQ Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 47
Talking quake 3 arena demo additions


i managed to get linux quake 3 arena demo working, and i was wondering how to add stuff like extra maps, models, etc. anyone?
 
Old 09-12-2003, 07:26 PM   #2
ogromano
LQ Newbie
 
Registered: Sep 2003
Distribution: KDE
Posts: 6

Rep: Reputation: 0
how did you get past the default.cfg problem

I'm still trying to install it. It keep saying:

Q3 1.11 linux-i386 Dec 4 1999
----- FS_Startup -----
Current search path:
/root/.q3a/baseq3
q3demo.x86/baseq3

----------------------

Running in restricted demo mode.

----- FS_Startup -----
Current search path:
/root/.q3a/demoq3
q3demo.x86/demoq3

----------------------
----- CL_Shutdown -----
-----------------------
----- CL_Shutdown -----
-----------------------
Error: Couldn't load default.cfg

Did you get a similar message when installing??

- Ogro -
 
Old 09-12-2003, 09:24 PM   #3
ogromano
LQ Newbie
 
Registered: Sep 2003
Distribution: KDE
Posts: 6

Rep: Reputation: 0
now it looks like this....

It is times like these when Windows "seems" better....

[root@h240n2fls34o883 q3demo]# q3demo
Q3 1.11 linux-i386 Dec 4 1999
----- FS_Startup -----
Current search path:
/root/.q3a/baseq3
./baseq3/pak0.pk3 (1387 files)
./baseq3

----------------------

Running in restricted demo mode.

----- FS_Startup -----
Current search path:
/root/.q3a/demoq3
./demoq3

----------------------
execing default.cfg
Unknown command "alias"
Unknown command "alias"
Unknown command "viewsize"
Unknown command "volume"
Unknown command "sensitivity"
Unknown command "+mlook"
Unknown command "_windowed_mouse"
execing q3config.cfg
couldn't exec autoexec.cfg
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: h240n2fls34o883.telia.com
IP: 217.208.63.240
----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Using 8/8/8 Color bits, 16 depth, 0 stencil display.
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...GL_EXT_compiled_vertex_array not found

GL_VENDOR: Mesa project: www.mesa3d.org
GL_RENDERER: Mesa GLX Indirect
GL_VERSION: 1.3 Mesa 4.0.4
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_transpose_matrix GL_EXT_abgr GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_lod_bias
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 6

PIXELFORMAT: color(24-bits) Z(16-bit) stencil(0-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: software w/ 0 overbright bits
CPU:
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
Initializing Shaders
^3WARNING: no shader files found
trying projectionShadow.TGA...
^3Couldn't find image for shader projectionShadow
trying flareShader.TGA...
^3Couldn't find image for shader flareShader
trying sun.TGA...
^3Couldn't find image for shader sun
----- finished R_Init -----
trying gfx/2d/bigchars.TGA...
^3Couldn't find image for shader gfx/2d/bigchars
trying white.TGA...
^3Couldn't find image for shader white
trying console.TGA...
^3Couldn't find image for shader console

------- sound initialization -------
------------------------------------
----- Sound Info -----
sound system is muted
1 stereo
65536 samples
16 samplebits
1 submission_chunk
22050 speed
0x445b6000 dma buffer
Forcing all sounds to 8 bit
No background file.
----------------------
Loading vm file vm/ui.qvm.
Failed.
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Error: VM_Create on UI failed

- Ogro -
 
Old 09-13-2003, 02:28 PM   #4
LavaDevil94
LQ Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Original Poster
Rep: Reputation: 47
actully, i just installed the downloadable demo (i dont have full version) and i was wondering if it is possible to add to that.
 
Old 09-13-2003, 02:59 PM   #5
ogromano
LQ Newbie
 
Registered: Sep 2003
Distribution: KDE
Posts: 6

Rep: Reputation: 0
Well, I kind have to get the demo working before I can think of adding to it.

- Ogro -
 
Old 09-13-2003, 03:28 PM   #6
Baldorg
Member
 
Registered: Sep 2003
Location: GMT (-5)
Distribution: Mandrake 9.1
Posts: 288

Rep: Reputation: 31
I dont think you can add maps or skins/mods to the demo. That's why it's only a demo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The lighting in Quake3 Arena demo and Linux couvier Linux - Software 5 07-21-2004 09:32 AM
Quake 3 Arena PhuckFonix Linux - Games 2 05-30-2004 07:16 PM
Quake 3 Arena Freezes when switching to Team Arena murray_linux Linux - Games 3 12-13-2003 08:10 PM
quake 3 arena demo crashes my pc....and i have a 1.53ghz processor! set235 Linux - Games 2 10-16-2003 01:06 AM
I need help installing quake3 team arena demo. bling bling Linux - Software 1 06-19-2003 10:53 PM


All times are GMT -5. The time now is 08:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration