LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   qt4.6.2 fonts are horrible! Running slackware 13.1 (http://www.linuxquestions.org/questions/linux-software-2/qt4-6-2-fonts-are-horrible-running-slackware-13-1-a-840442/)

Holering 10-26-2010 12:51 AM

qt4.6.2 fonts are horrible! Running slackware 13.1
 
I don't know what I did but all my qt4 applications fonts began to look terrible! It just happened out of nowhere after booting my computer and running qmmp. They all look horizontally squashed. I was able to tediously change the fonts in qtconfig to Droid sans mono which helped a little and I can at least make out what words say but it looks bad. They basically have no antialiasing or hinting plus they're squashed. Thankfully qmmp lets me change the font setting. But bsnes and many other apps don't let you change the qt4 fonts...

I've read on numerous problems and solutions to this by editing the ~/.fonts.conf but that doesn't seem to have any effect (I actually had to make it since it didn't exist). Qt4 obviously isn't honoring my global font settings which I change through xfce4 appearance. I've changed the global font settings to different fonts and combinations with no luck in regards to qt4 fonts...

JZL240I-U 10-26-2010 09:16 AM

Maybe this hint might help you:

http://www.linuxquestions.org/questi...desktop-74516/

Holering 10-27-2010 01:09 AM

I don't quite understand how that link would apply to my problem... I did actually try and relate to it but I can't. I'm using xfce4 and nothing else. That's kind of a lie though cause I did install window maker and fvwm at one point and then uninstalled them and came back to xfce4... Maybe that's what did it...

JZL240I-U 11-01-2010 04:23 AM

It was meant as a "long shot". Gnome mixed up my fonts (and graphics) really terribly there and this was the remedy. I just hoped you could use the procedure to clear up your problem too. Incidentally you didn't hand out too many clues to find an opening to tackle this, so this was my try. Sorry if it didn't help.

disturbed1 11-01-2010 11:29 AM

Beautiufl Fonts in Slackware long - summed up here

brixtoncalling 11-18-2010 03:25 AM

It's possible that your .fonts.conf isn't being used. If you are still having this problem, I might be able to help you get it working.


All times are GMT -5. The time now is 07:34 AM.