LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-27-2005, 11:25 AM   #1
Boomba
Member
 
Registered: Jan 2004
Distribution: Fedora Core 4
Posts: 57

Rep: Reputation: 15
qt-mt not found error during configure


hi
when I tried to configure a package for kde I got this error....I searched google but none seems to have the answer. where do I get this QT 3.3 or qt-mt and how do I install it?

Quote:
checking for Qt... configure: error: Qt (>= Qt 3.3) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
thanx in advance
Boomba,
 
Old 01-27-2005, 04:18 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,374

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
I'm not sure what version redhat 9 would include, but you will more than likely already have some version of qt3 insatlled. in that case, install qt-devel-3.3.3.rpm (or similar name) from your distro cd's. if you need to get a newer version (you can run "rpm -qv qt" to see what versions of qt are installed) then just go somewhere like rpm.pbone.net for updates, or update via apt-get if you use it.
 
Old 01-31-2005, 10:32 PM   #3
Boomba
Member
 
Registered: Jan 2004
Distribution: Fedora Core 4
Posts: 57

Original Poster
Rep: Reputation: 15
i have qt version 3.1.1-6 and no matter what rpm i try to install for qt (whether it be 3.2 or 3.3) , I always get "Failed dependecies" similair to the ones above. How do I solve this? I wanted to install QT so i can install KDE 3.2.

these failed dependecies are inacurate and even when I update them it still complains.

thanx in advance,
Boomba
 
Old 02-15-2005, 03:59 PM   #4
hramat
LQ Newbie
 
Registered: Feb 2005
Location: The Netherland
Distribution: Fedora core 3, Arch Linux
Posts: 9

Rep: Reputation: 0
I have the same problem and I had it before. Now I don't know how to solve it but it is something like I found in the Install instruction file from LICQ plugins. The problem is that you had installed older version of QT before and in the /etc/ld.so.conf linux finds first the older Qt than that new installed. So you have to remove that old one and install the new one. or try to make that linux find as first that newly installed Qt. Don't know how but when I will find it will let you know.

good luck

this is copied from that LICQ Install file
If you get errors like

Unable to load plugin (qt-gui): /usr/lib/licq/licq_qt-gui.so:
+undefined symbol: dragEnterEvent__14QMultiLineEditP15QDragEnterEvent.

or similiar (text after "undefined symbol: " might vary) then you have
a older Qt 2.x lib in the paths given in /etc/ld.so.conf. uninstall them or
make sure that the Qt 3.x lib is found first.
 
Old 02-15-2005, 04:06 PM   #5
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
to make it find the new one first (assuming you have two installed) you have to manipulate the library path manually. however, this is not the way to go ( not good). you need to upgrade your qt to AT LEAST 3.3 (3.2 will not work). try:

rpm -Uvh <rpm> to upgrade instead of install the qt rpm. While I'm not recommending the following, if you uninstall the old qt and want to install the new qt but it complains about dependencies and you absolutely KNOW that you have what it needs, you could pass the --nodeps flag to rpm (rpm --nodeps <rpm>) to disable dependency checking and also if rpm complains about conflicting files you could pass the --force flag. As I said above, I'm not recommending this (but then again I don't recommend rpm's either )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: no acceptable ld found in $PATH rover Linux - Newbie 2 12-04-2009 06:35 AM
configure: error: No ar utility found Mugatu LinuxQuestions.org Member Success Stories 1 01-09-2005 05:15 PM
Configure error: QT not found marsonist Linux - Software 3 04-26-2004 12:48 AM
configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found Mugatu Linux - Software 14 12-15-2003 04:11 AM
configure: error: no acceptable cc found in $PATH nistelrooy Mandriva 3 10-07-2003 01:37 PM


All times are GMT -5. The time now is 03:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration