LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-31-2002, 02:01 AM   #1
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Angry Qt


I try to compile Qt but I get a strange error.
I really dunno what's the trouble, I tried before to compile another version of qt and it was successful but now If I try to compile another one I always get the same error:

g++ -o ./moc mocgen.o qbuffer.o qcollection.o qcstring.o qdatastream.o qdatetime.o qfile.o qgarray.o qgdict.o qglist.o qglobal.o qgvector.o qiodevice.o qregexp.o qstring.o qtextcodec.o qtextstream.o qfile_unix.o

/usr/bin/ld: cannot find -lstdc++
collect2: ld returned 1 exit status
make[2]: *** [moc] Error 1
make[2]: Leaving directory `/usr/local/qt/src/moc'
make[1]: *** [src-moc] Error 2
make[1]: Leaving directory `/usr/local/qt'
make: *** [init] Error 2

What is this?
 
Old 03-31-2002, 11:18 AM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
What version of QT?
I'm assuming its v3.0.3 for kde3 and if I'm right you'll need to upgrade autoconf and automake to the latest versions.
 
Old 03-31-2002, 12:48 PM   #3
jISV
Member
 
Registered: Feb 2002
Location: England
Distribution: MDK8.2
Posts: 128

Rep: Reputation: 15
Is it worth installing KDE 3?
 
Old 03-31-2002, 12:57 PM   #4
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
I'd wait untill the final is out. RC3 was up on the ftp servers but it's been removed.
 
Old 04-01-2002, 01:20 AM   #5
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 45
qt 2.3.1 I think
I don't want to install Kde 3.0 right now, dont like beta testing.
And I have kde 2.2.2 already burned on a cd.

I have done my automake/autoconf (but hum... can It be my version of these progs that is too recent?)

But what this error msg is suppose to be? what is lstdc++ ? gcc?
 
Old 04-01-2002, 01:33 AM   #6
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
For Qt-2.3.1 check that your using autoconf-2.13 and automake-1.14, they're not installed by defaule in slack 8 but they are on the extra's cd under /pasture.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration