LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   QPopper not accepting mail from local domain (http://www.linuxquestions.org/questions/linux-software-2/qpopper-not-accepting-mail-from-local-domain-857644/)

manutdfan1988 01-20-2011 05:01 PM

QPopper not accepting mail from local domain
 
I have QPopper and Sendmail setup on a Red Hat server, they both seem to be running ok and listening on usual pop and smtp ports 25 and 110.

QPopper is running through xinetd and the config file is as follows

Code:

service pop3
{
        disable        = no
        flags          = REUSE
        socket_type    = stream
        wait            = no
        user            = root
        protocol        = tcp
        port            = 110
        server          = /usr/sbin/popper
        instances      = 50
        per_source      = 10
        log_on_failure  += USERID
}

The problem is I get an error in the maillogs when trying to send mail from a PC on our local domain about the canonical client name which is to do with reverse dns. I understand this can be turned off at runtime of qpopper but nowhere seems to detail how to do this, apart from -R flag at runtime but as it is running through Xinetd I am not sure where to put it.


A few more details on the problem, if I VPN onto our network from my home desktop I can send mail fine. Receiving mail is also no problem, it is just sending. I have setup only our local domain in the access file for sendmail.


Any help would be greatly appreciated.

bathory 01-21-2011 12:39 AM

Hi,

qpopper is a pop3 daemon and it's used by mail clients in order to read mail. It has nothing to do with your problem. Sending and receiving mail is done by an MTA, which in your case is sendmail.
Maybe you need to setup smtp authentication if you want to be able to send mail from home using your sendmail server.
BTW if you want qpopper to stop doing reverse lookups you can add in the qpopper xinetd conf file the following:
Code:

server_args = qpopper -R
Regards

manutdfan1988 01-23-2011 07:00 PM

Thanks I think I have been a little bit confused with SMTP POP stuff as I have never setup a working mail server before.


All times are GMT -5. The time now is 03:33 PM.