LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-10-2004, 12:44 PM   #1
mpk25
LQ Newbie
 
Registered: Apr 2004
Location: Colorado
Distribution: Redhat 8 and 9
Posts: 6

Rep: Reputation: 0
QMAIL error:554 Transaction failed: message format error


Hello,
we have be running a qmail e-mail server server for about two years at my company. Last week friday I got an email from a higher up in the company saying that he got a bounced email when he was trying to contact the state health department. I have had no messages from anyone else bounce back like this. I thought it was a wierd message to get (I haven't messed with the email server in weeks, ). I talked to one of their admins who was able to send me a test message, however when i replied to the message the message below is what bounced back.

-we run qmail 1.06
-have amavis running with CLAM

Here it is:
The original message was received at Mon, 10 May 2004 10:21:46 -0600
from [63.x.x.x]

----- The following addresses had permanent fatal errors -----
<x>@cdhs.state.co.us
(reason: 554 Transaction failed: message format error)
(expanded from: <x.x@state.<x>.us>)

----- Transcript of session follows -----
... while talking to <x>.state.<x>.us.:
>>> DATA
<<< 554 Transaction failed: message format error
554 5.0.0 Service unavailable



My understanding of qmail is limited. What would cause an error like this? I contacted their administrator and they seem to think that it is a problem on our side. Any info would be greatly appreciated!
 
Old 10-15-2004, 01:53 PM   #2
mpk25
LQ Newbie
 
Registered: Apr 2004
Location: Colorado
Distribution: Redhat 8 and 9
Posts: 6

Original Poster
Rep: Reputation: 0
Post The Fix

Turns out that this was a combination of issues.:

-The mc-afee webshield can sometimes cause this problem. After numerous google searches it came up in the fix log for service pack 1 for the appliance


-Amavis was adding X-headers to each email saying that it was scanned. Evidently some email servers don't like receiving mail that has been scanned...
I had to simply edit the amavis.conf file to remove the X-headers from being inserted into the email


just an FYI for any other email server admins that run into this problem like I did.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rpm error: can't create transaction lock NL-Stitch Linux - Newbie 5 10-19-2011 08:50 AM
Failed to open device gt68xxLlibusb 004:002 invalid arguments error message radatan71 Linux - Hardware 1 10-24-2005 09:07 PM
Ext3-fs error (device hda1) in start-transaction kt8993 Linux - General 0 02-05-2005 12:09 PM
Postfix - 554 Transaction failed (in reply to MAIL FROM command) FastFeet Linux - Networking 1 02-03-2004 11:55 PM
When playing RealAudio I get an Unknown data format error message Notbobdylan Linux - Newbie 0 01-19-2004 10:23 PM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration